Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Julia
    @juliaweist
    @juanulload Yes, under Manage > My Displays
    rdobson1
    @rdobson1
    In this demo - http://demo.collectiveaccess.org/editor/collections/CollectionEditor/Edit/collection_id/14 , it is possible to add archive items directly under the archive structure. How do I go about enabling object creation while working in a collection?
    CollectiveAccess
    @collectiveaccess
    You'd need to set ca_objects_x_collections_hierarchy_enabled is app.conf
    along with ca_objects_x_collections_hierarchy_relationship_type
    where "ca_objects_x_collections_hierarchy_relationship_type" is a valid object-collection relationship type to be used when creating the hierarchical links
    Lucy Saikhan
    @lucybbs
    Dear, Julia
    Thank you for your detail response. could I provide you my username and password to you and look at what happened to my updated system? I did not see the export button for my export mapping.
    CollectiveAccess
    @collectiveaccess
    Julia is on vacation now
    send me the details and I'll take a look as time allows
    Lucy Saikhan
    @lucybbs
    can I sent to you in private conversation? if allowed?
    CollectiveAccess
    @collectiveaccess
    Lucy Saikhan
    @lucybbs
    Yes, I just emailed. Thanks for your time.
    artvrc
    @artvrc
    A question about Collection in providence: Is it possible to have one particular collection as default? I've set "Related collections" in UI using the "object <-> collection" relationship, and right now it's set as a type-ahead lookup field. Majority of our new records belong to one collection, so it would be nice if this collection is already set as default in the object record entry. Thx!
    Kehan Harman
    @kehh
    @artvrc yes you can using the prepopulate configuration, setting the mode to be addIfEmpty http://docs.collectiveaccess.org/wiki/Prepopulate
    Kehan Harman
    @kehh
    I'm not so sure about the above actually - prepopulate may only work for intrinsics and metadata elements, not for relationships.
    artvrc
    @artvrc
    @kehh I could try but does the graphic interface allow doing what you suggested? I am only using graphic UI of Providence. thanks.
    yelto
    @yelto
    Hmm, unfortunately AFAIK @kehh is right, prepopulate cannot populate relationships. A "fill in the collection by default" feature could be of general interest, but it probably requires a plugin.
    yelto
    @yelto
    Probably missing something really really obvious here, but what's the standard way to print a label from an object's editor (or summary)? The summary shows the various reports (which are typically full page affairs) but no labels. No problem printing labels from the search results pages, but what about printing the label for the object just created/edited from its editor/summary? Thanks!
    CollectiveAccess
    @collectiveaccess
    We don't have provision for that. Labels can only be run from search results
    yelto
    @yelto
    Ah, ok, thanks... As a possible workaround, any way to define reports with different templates (in particular pageSize) to sneak in a label as a very peculiar "report"?
    yelto
    @yelto
    Sorry, I meant summary, not report (as in app/printTemplates/summary). The workaround of launching a search is not ideal, because the search results must include the object, but not as the only result (as in an idno search), because then we are back to the object editor instead of a search results page...
    artvrc
    @artvrc
    A question about data import using the Excel template...does it allow CSV file now? This page says "soon-to-be-available". http://docs.collectiveaccess.org/wiki/Data_Import:_Creating_and_Running_a_Mapping
    Kehan Harman
    @kehh
    @yelto add the object to a printing set, search by the set and then print. That way you can accumulate a number of objects to print. But you can use the summary templates in print and have a special case for a label display. But both pretty circuitous.
    @artvrc @yelto you could try the relationshipGenerator plugin that we contributed a couple of years ago: https://github.com/collectiveaccess/providence/tree/master/app/plugins/relationshipGenerator
    yelto
    @yelto

    @kehh thanks, yes, very circuitous for a simple "print this object's label". I've filed PROV-1940 as an enhancement request.
    In the meanwhile, getting into the code of the summary templates and hijacking the content generation part is fairly easy. The issue is how to adjust the template size, which is read out of @-formatted comments and applies to all summaries. It is not immediately clear how to special-case it so real summaries keep their full-page size and summaries-turned-labels get their own smaller sizes. Any ideas?

    @artvc @kehh relationshipGenerator, excellent, thanks.

    @artvc Yes, CSV should be ok.

    sterlingjenson
    @sterlingjenson
    Is there a trick for importing text to a field within a container within a larger container? Here is the command I am trying to use: ca_objects.condition_reports.cr_detail.cr_detail_text
    condition_reports is the main container / cr_detail is the secondary container / cr_detail_text is supposed to be the text field to write more details in.
    CollectiveAccess
    @collectiveaccess
    @artvrc Yes, CSV and tab are definitely supported. I have updated the wiki to indicate this.
    @sterlingjenson Just use ca_objects.condition_reports.cr_detail_text
    The sub-containers should not be included
    sterlingjenson
    @sterlingjenson
    thanks.
    naeemmuhammad
    @naeemmuhammad

    Hi,
    We need some help in making searches on object_x_object relationship fields for a particular relationship type in Pawtucket2. We used “{{{ca_objects_x_objects.preferred_labels%restrictToRelationshipTypes=partOfSeries&width=210px}}}” display template to display a search field in the search form. When we make the search, we get some results however with the following error:


    Something went wrong
    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND swi.field_num = '') AND swi.access = 0' at line 7 in /libis/CA/test/collectiveaccess/pa_cct-staging/releases/20161125130538/app/helpers/errorHelpers.php line 47:

    In Db_mysqli->execute(Object DbStatement, Object DbStatement, ' INSERT INTO ca_sql_search_phrase_80ea2ee335b10af6a71d6a8fffe746b2 SELECT swi.index_id + 1, 1 FROM ca_sql_search_words sw INNER JOIN ca_sql_search_word_index AS swi ON sw.word_id = swi.word_id WHERE sw.word = ? AND swi.table_num = ? AND (swi.field_table_num = AND swi.field_num = '') AND swi.access = 0 ', Array(2), ) in DbStatement line 151
    At DbStatement->executeWithParamsAsArray(Array(2)) in Db line 270
    At Db->query(' INSERT INTO ca_sql_search_phrase_80ea2ee335b10af6a71d6a8fffe746b2 SELECT swi.index_id + 1, 1 FROM ca_sql_search_words sw INNER JOIN ca_sql_search_word_index AS swi ON sw.word_id = swi.word_id WHERE sw.word = ? AND swi.table_num = ? AND (swi.field_table_num = AND swi.field_num = '') AND swi.access = 0 ', 'ren', 57) in SqlSearch line 801
    At WLPlugSearchEngineSqlSearch->_doQueriesForSqlSearch(Object Zend_Search_Lucene_Search_Query_Boolean, '57', 'ca_sql_search_search_final', 0, Array(2)) in SqlSearch line 369
    At WLPlugSearchEngineSqlSearch->search('57', '(./partOfSeries:"ren wu zhuan")', Array(2), Object Zend_Search_Lucene_Search_Query_Boolean) in SearchEngine line 276
    At SearchEngine->doSearch('((ca_objects_x_objects.preferred_labels/partOfSeries:"Ren wu zhuan"))', Object ObjectSearchResult, Array(4)) in ObjectSearch line 50
    At ObjectSearch->search('((ca_objects_x_objects.preferred_labels/partOfSeries:"Ren wu zhuan"))', Array(4)) in BrowseEngine line 1878
    At BrowseEngine->execute(Array(3)) in BaseBrowse line 48
    At BaseBrowse->execute(Array(3)) in SearchController line 288
    At SearchController->__call('objects', Array(1)) in RequestDispatcher line 273
    At SearchController->objects() in RequestDispatcher line 273
    At RequestDispatcher->dispatch(Array(2)) in AppController line 112
    At AppController->dispatch(true) in index line 121

    Any help to solve this problem?
    Thanks.

    CollectiveAccess
    @collectiveaccess
    object-object relationships (or relationships of any other stripe) do not have preferred labels
    naeemmuhammad
    @naeemmuhammad
    @collectiveaccess How can we adapt the above mentioned display template to search 'related objects' based on their titles?
    CollectiveAccess
    @collectiveaccess
    It's not a display template
    It's a field spec
    and the first thing you'll need to do is index the title and the other side of the relationship
    keep in mind once you do this searches will find objects with either the title of the object itself or the related one
    and there'll be no way to restrict to one side or another, since the field name is identical
    Kehan Harman
    @kehh
    @naeemmuhammad @collectiveaccess could you use an access point?
    yelto
    @yelto
    Hello, how does one search for a specific date with ES? According to http://docs.collectiveaccess.org/wiki/Search_Syntax#Searching_on_dates a
    '#' prefix is used, but it does not appear to work (it does on SqlSearch). Thanks.
    sterlingjenson
    @sterlingjenson
    Dumb question, @yelto, what search field are you utilizing? For a while I was wondering why modified.[username]:date wasn't working, but it turns out that I was using the wrong search.
    I was trying to utilize the quick search bar, but I reread that page and realized I needed to go into the objects search to actually get the query to work properly.
    yelto
    @yelto
    @sterlingjenson Thanks for the thought, good point, I suspect almost everyone gets caught by the quicksearch silently dropping query syntax (we filed a bug report about this http://clangers.collectiveaccess.org/jira/browse/PROV-1894). But no, this is on the object searches (both basic search via query syntax and advanced search via form). ElasticSearch does not seem to handle #. If you are using ElasticSearch and you get the exact date result, please let me know!
    Historical Arvada
    @arvadahistory_twitter
    Hello, As a test, I uploaded a .doc file (because I've been having issues with pdf contents being indexed) and then proceeded to search for a specific word inside the document, but it doesn't come up. Now, I have a feeling this and the pdf are connected, so is it possible to have the error go away about not being able to find pdfminer and still not have it actually mine the document? Thanks! Matt
    Bruno Duyé
    @brunetton

    Hi all, @collectiveaccess, I've a doubt about the "dontCreate" option for "listItemSplitter" refinery in import mapping file. In the wiki, it's defined as:

    If set to true (or any non-zero value) the splitter will only do matching and will not create new records when matches are not found.

    I need to import entities with a metadata matching to a list.
    When importing with dontCreate set to 1, non existing items of the list are still added to the list.
    Is this a bug ? Or a misunderstanding from myself ?
    All details here: http://www.collectiveaccess.org/support/forum/index.php?p=/discussion/298157/dontcreate-option-for-listitemsplitter-problem

    Thanks a lit

    Julia
    @juliaweist
    @brunetton please see response on the forum
    Bruno Duyé
    @brunetton
    Thanks @juliaweist , just answered you.
    => I think there's a bug around dontCreate setting.
    rdobson1
    @rdobson1
    How, in existing 1.63 installation, can I create a collection x storage locations relationship type? We have the storage locations hierarchy visible on our collections editor forms, but can't pick a relationship type and therefore can'