Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    CollectiveAccess
    @collectiveaccess
    @claman How can we help you?
    Bruno Duyé
    @brunetton
    Hello @collectiveaccess, thanks for the wiki access. I'm really sorry but it don't seems to work. Maybe because a few days past between the mail and my attempts ? Can you please give me another wiki access ? You can use the username "brunetton"; this is my usual pseudo.
    Thanks !
    Morgan
    @msjonesking
    Hello @collectiveaccess , Can you provide any information architecture or planning documents for the website and/or database setup for users?
    Alla Efimova
    @IAmAllaEfimova_twitter
    Hello @collectiveaccess . Can you answer these questions for me: How many users can have access permission to the database? Can it be accessed off-site on multiple devices?
    Julia
    @juliaweist
    Hi @msjonesking what specifically are you looking for documentation on? This is a wide range of topics and things are in various places on the wiki
    @IAmAllaEfimova_twitter do you mean access permissions to the application through the web interface? There is no limit, beyond server/system performance based on available bandwidth, etc. Yes, it can be accessed anywhere with an internet connection (assuming you don't set up an extra level of security, like a firewall) on a variety of devices.
    Massimiliano Losego
    @profago
    image-viewer.jpg
    Hello @collectiveaccess .
    Can you answer these questions for me:
    • Why when i download uploaded images they are corrupted also if I can see them in thumbnails online [and also if they are fine if I download them via sftp] there is any KB related?
    • Which is the best way to solve image viewer problem (I'm attaching a previuos screenshot)
    • There is a way to set thumbnails quality (now is too poor) [I'm using Imagick]
      Thank you
    sterlingjenson
    @sterlingjenson
    @profago I tend to have better luck with GMagick than IMagick in general, so perhaps see if you can switch over to see if that helps.
    Massimiliano Losego
    @profago
    tnx for the suggestion, now I have installed ImageMagick and the result is very better.
    But the bigger problem still remains the images corruption (it doesn't happens with pdf for example)
    CollectiveAccess
    @collectiveaccess
    In what way are the images corrupt?
    Massimiliano Losego
    @profago
    here you may find the orginal and the downloaded one (1)
    CollectiveAccess
    @collectiveaccess
    No sure how that happened – there's no garbage appended to it
    Is every image like this?
    Massimiliano Losego
    @profago
    Yes, every image.
    What is really strange is that in Providence I have all those problem but in Pawtucket2 all is working fine (both download and image viewer)
    CollectiveAccess
    @collectiveaccess
    I will do so tomorrow
    Karl Becker
    @karbecker
    Hi! Is there a way to do a media import via terminal? As far as I unserstand CaUtils do not offer an option for this, do they? They only work for Data Import. We are about to import 34000 pictures, so a terminal solution would be great 😉
    CollectiveAccess
    @collectiveaccess
    Only data import is possible at the moment
    File a JIRA for command-line media import and we'll see about adding it in the future
    Bradley Tsalyuk
    @bradley_tsalyuk_twitter
    Hello, I've been looking at the demo for CA and I'm trying to figure out how to recreate something I see appearing in the Object Editor. There is a screen called "List Item Test" with a field called "Related occurrences list". When a related occurrence is added it populates an exportable spreadsheet. How is this created?
    ericwm
    @eriwm
    A belated Happy New Year to all at Collective Access and forum members. Git checkout Develop tells me my version origin/develop is up to date however I still cannot get the document viewer to work. Is the viewer still work in progress or do I have something wrong in my install? Thanks.
    Apologies should have said 1.7 develop.
    noje
    @noje
    I'm also using the 1.7 develop and the document viewer is not working either (Got stuck at the "add" screen and nothing else is displayed)
    CollectiveAccess
    @collectiveaccess
    Make sure you're using an up-to-date media_processing.conf file in app/conf
    and that all of your multipage media have been processed with that configuration. You may need to run caUtils reprocess-media --mimetypes=application/pdf
    to get the required previews in place
    ericwm
    @eriwm
    @collectiveaccess Thanks for your response, my media-processing config file is dated 16/01/2017. I only have a couple of sample media files which I shall delete and try again.
    ericwm
    @eriwm
    @collectiveaccess Hi again, I deleted everything from my media folder and uploaded a pdf file (using upload media in object editor) Looking in the media folder I find the original pdf with pages converted to jpg. In object editor page I see the upload with thumbnail of the first page which is a grey hash. Previously I could see the writing on the front page. Clicking on the thumbnail opens the document viewer which is blank. Trying to upload a jpeg usig this method results in an error -file type not supported. Any suggestions? (Using Firefox Browser in Ubuntu 16.04)
    ericwm
    @eriwm
    @collectiveaccess Further to the above I have checked the actual pages in the media file and find that all the jpegs are of the front page in different sizes eg, large,small, preview etc. i.e it sems to be converting one page only.??
    ericwm
    @eriwm
    @collectiveaccess Done some more investigation into this problem and found following - Deleted/purged Graphicsmagic and then reinstalled, After this I could upload jpeg and see it in object editor and the docviewer. Could upload a pdf and see thumbnail in object editor but not in docviewer. Looked in media/collectiveaccess/images folder and can see document pages converted to jpeg, I have attached my image file, could you take a look at it when you have time and let me know if there is a problem. Thanks
    Bruno Duyé
    @brunetton
    Hi @collectiveaccess Is it "normal" that on develop branch we can't add anymore a type restriction to a container metadata ? (maybe to any metadata type)
    Thanks
    Julia
    @juliaweist
    @brunetton It's working fine for us with the latest develop code (Schema revision 143)
    ericwm
    @eriwm
    @collectiveaccess I have re-installed Providence 1.7 schema 143 to make sure I have the latest viewer configuration. I also used caUtils to reprocess my image folder. In the media_display.config the default image viewer is set to Tileviewer, and the pdf viewer is set to Mirador. I still cannot see anything in the viewer when trying to view the pdf doc (1 page). Just see the bottom bar with the download tools. any suggestions as to how to proceed would be appreciated. Also if iset preferences to use Browser plugin (Firefox Document viewer) I cannot see the pdf document.
    Kehan Harman
    @kehh
    Is it possible to browse objects by attributes on related tables (For example browse artworks by the gender of the artist)? Didn't seem to be possible from reading browse.conf.
    Julia
    @juliaweist
    Hi @kehh. You can do this:
    gender = { type = attribute, element_code = gender, relative_to = ca_entities, group_mode = none, label_singular = _("gender"), label_plural = _("gender") }
    Julia
    @juliaweist
    if you have multiple entities related to the object this may not be ideal because it will return any object with 1 or more relationships to an entity that meets that gender criteria.
    Nathan Kemler
    @nkemler
    I need some help getting a view set up for the LCSH on Pawtucket. Right now I have the terms linked but I don’t have a detail view in Pawtucket created. Are there any templates for this page in existence already?
    Kehan Harman
    @kehh
    @juliaweist Magic thanks!!!
    Kehan Harman
    @kehh
    Bruno Duyé
    @brunetton
    Thanks for Wiki reflex @kehh !
    ericwm
    @eriwm
    Hi All, Still struggling with media viewer in1.7 dev. I upload my media via the object editor. I have upload, jpeg, audio and video and can view these ok. However I still cannot view uploaded pdf or doc files.
    ericwm
    @eriwm
    I have checked that the path to pdftotext is correct and if I run this from the command line on my pdf doc it converts fine. I have run media-process from caUtils and still nothing. All file permissions seem ok. I am sure it must just be a setting somewhere. Media processing is set to no queue. Any advice would be most welcome
    Karl Becker
    @karbecker
    Hi! I’m looking for help regarding the display of ULAN data in Pawtucket. I can call the output of the metadata element by adding {{{^ca_entities.ulan}}} to my entities detail view (ca_entities_default_html.php). Is it possible (like with wikipedia) to output more information from the linked ulan record directly? Thanks!
    Kehan Harman
    @kehh
    @kbecker87 The properties that you can display in your templates are documented (and customisable) under the ulan heading of linked_data.conf. You should be able to access the following properties of the element: detail_view_info, additional_indexing_info and extra_info.
    sterlingjenson
    @sterlingjenson
    Greetings all. After upgrading to Ubuntu 16.04 and switching to MariaDB, everything looked fine until a new volunteer tried to log into the system. When he logged in using his credentials, my account was pulled up. Has anyone else have a similar problem? I could not find a forum post about it. Thanks in advance.
    sterlingjenson
    @sterlingjenson
    The plot thickens. When I have the new user log in on a web browser that I had not logged into, he sees the researcher version of the site.
    which I set him to see.
    sterlingjenson
    @sterlingjenson
    I forgot to include that I am using C/A version 1.6.2.
    sterlingjenson
    @sterlingjenson
    I copied the Database and tried to use the current Development Branch of Providence to see if that helps . . . It appears that logging in and out of Providence is working, but now the layout is not functioning. I think I am going to take a break from this.