Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Karl Becker
    @karbecker
    Hi! I’m looking for help regarding the display of ULAN data in Pawtucket. I can call the output of the metadata element by adding {{{^ca_entities.ulan}}} to my entities detail view (ca_entities_default_html.php). Is it possible (like with wikipedia) to output more information from the linked ulan record directly? Thanks!
    Kehan Harman
    @kehh
    @kbecker87 The properties that you can display in your templates are documented (and customisable) under the ulan heading of linked_data.conf. You should be able to access the following properties of the element: detail_view_info, additional_indexing_info and extra_info.
    sterlingjenson
    @sterlingjenson
    Greetings all. After upgrading to Ubuntu 16.04 and switching to MariaDB, everything looked fine until a new volunteer tried to log into the system. When he logged in using his credentials, my account was pulled up. Has anyone else have a similar problem? I could not find a forum post about it. Thanks in advance.
    sterlingjenson
    @sterlingjenson
    The plot thickens. When I have the new user log in on a web browser that I had not logged into, he sees the researcher version of the site.
    which I set him to see.
    sterlingjenson
    @sterlingjenson
    I forgot to include that I am using C/A version 1.6.2.
    sterlingjenson
    @sterlingjenson
    I copied the Database and tried to use the current Development Branch of Providence to see if that helps . . . It appears that logging in and out of Providence is working, but now the layout is not functioning. I think I am going to take a break from this.
    Karl Becker
    @karbecker
    @kehh I tried {{{^ca_entities.ulan.detail_view_info}}} as well as {{{^ca_entities.ulan.extra_info}}} with no luck. Only without a property it shows some info, like 500007488] Hünten, Emil (Persons, Artists) - German painter, 1827-1903Do I need to configure anything in the linked_data.conf?
    noje
    @noje
    Hello ! I'd like to set a facet based on the source for objects. I tried this : Attribution = {
    type = attribute,
    field = object_sources,
    element_code = source_id,
    labelsingular = ("Attribution"),
    labelplural = ("Attribution")
    },
    But it's not working. Any suggestion ? Thanks !!
    Kehan Harman
    @kehh
    @kbecker87 Afraid that's the limit of my knowledge on that front. Does anything appear in your ca_attribute_values table for the ulan element? Looks like it goes in ca_attribute_values.value_blob (InformationServiceAttributeValue.php:L173:181)
    Kehan Harman
    @kehh
    @noje use the fieldList facet type (not attribute):
    Attribution = {
            type = fieldList,
            field = source_id,
            label_singular = _("Attribution"),
            label_plural = _("Attribution")
     }
    noje
    @noje
    @kehh Thanks !!
    noje
    @noje
    I'm also trying to get related object (objectsxobjects) on facets (the same way there already is for objectsxentities). I tried this :
    object_facet = {
            # 'type' can equal authority, attribute, fieldList, normalizedDates
            type = authority,        
            table = ca_objects,
            relationship_table = ca_objects_x_objects,
            restrict_to_types = [],
            restrict_to_relationship_types = [],
            individual_group_display = 0,
            groupings = {
                label = _("Name"), 
                type = _("Type"),
                relationship_types = _("Role")
            },
            group_mode = alphabetical,
            order_by_label_fields = [name_sort],
            indefinite_article = an,
            label_singular = _("object"),
            label_plural = _("objects")
        },
    based on the objects_entities but i guess i'm doing it wrong again ^^'
    Could someone help again ? Thanks !!
    Karl Becker
    @karbecker
    @kehh Yeah, it does, see a screenshot of the ca_attribute_values SQL table:
    I can extract the same text in Pawtucket but I’d like to pull more information from ULAN…
    Julia
    @juliaweist
    @noje currently we don't support self-reflexive browsing, meaning browsing on a table by it's own table.
    Lucy Saikhan
    @lucybbs

    How are you all,

    The project I mentioned before still did not finish yet. we plan to merge two separate collective access together. After I have exported data file, it was all flipped over and messed up. I have no clue why the column was not match with the metadata. if anyone could help me check the data form that I attached here that would be wonderful. Thank you so much.

    Cheers,
    Lucy

    Kehan Harman
    @kehh
    @kbecker87 OK that sounds like you might be able to influence what goes into the fifth column using linked_data.conf. I'm unsure what the display template syntax would be to get the extra info.
    @kbecker87 there's also caUtils reload-service-values which you would need to run to populate the data in the attribute once you've changed linked_data.conf.
    noje
    @noje
    @juliaweist Thanks !
    mcauleymedia
    @mcauleymedia
    Just upgraded to Providence 1.6.3 and using the current Master from pawtucket 2: not able to get images to display in the media overlay (zoom) in pawtucket. They work fine in Providence, but its blank in Pawtucket
    Julia
    @juliaweist
    Hi @lucybbs what steps did you take to create this csv file?
    ericwm
    @eriwm
    Hi, Could you please advise my of the correct command for downloading (cloning) the latest version of 1.7 dev. I have used git clone https://github.com/collectiveaccess/providence git as advised in a previous post but get vers 1.6.3. Thanks
    sterlingjenson
    @sterlingjenson
    You need to designate a different branch besides the main release.
    I think the command is -B "develop" or what ever branch you want to use
    Mark
    @markcruza_twitter
    Hi Julia, can I inquire something re hosting
    ericwm
    @eriwm
    Hi @sterlingjenson thanks for your reply - I forgot to run git checkout develop after downloading 1.6.3 . Should be asleep at 1.30 in the morning!!!
    ericwm
    @eriwm
    Hi all, Still not able to see .doc, .xml or .pdf files after upload
    Latest 1.7 installed, PHP7.0 installed, GraphicsMagick available, Office available, PDFWand available. pdf2txt and pdftotext installed in usr/bin. I used install poppler utils and install python-pdfminer to get the last two apps. Can see the thumbnails in object editor. Jpegs, mp3 audio and mp4 video play ok in viewer. I have tried setting preferences to all three options but still cannot view docs etc. Any advice on where to next will be much appreciated.
    Mark
    @markcruza_twitter
    Hi, ist there someone here from whirl-I-gig
    sterlingjenson
    @sterlingjenson
    @ericwm Dumb question: Have you looked under maintenance check in Providence for missing libraries? I thought I had gmagick installed, but when I checked, Providence said the library was not loaded.
    IIRC, I forgot to do something simple like adding in the extension code into php.ini
    sterlingjenson
    @sterlingjenson
    Has anyone tried out wkhtmltopdf 0.12.4
    to see if the problems the library in versions 0.12.2 and 0.12.3 in creating labels have been solved?
    sterlingjenson
    @sterlingjenson
    @eriwm , I am confusing two different sections. I should have said "Configuration Check" not "Maintenance Check"
    ericwm
    @eriwm
    @sterlingjenson . Configuration check says all GraphicsMagick is available, PDFWand & libreoffice..
    @sterlingjenson What extension code did you add into php.ini?.
    sterlingjenson
    @sterlingjenson
    I had to add gmagick.so after installing Gmagick
    sterlingjenson
    @sterlingjenson
    Do you have ghostscript installed?
    ericwm
    @eriwm
    @sterlingjenson Yes I have gs installed but I am not using Gmagick maybe I have to do something similar for GraphicsMagic. I will investigate and let you know. Thanks.
    Julia
    @juliaweist
    hi @markcruza_twitter feel free to email us at hosting@collectiveaccess.org
    ericwm
    @eriwm
    @sterlingjenson
    Hi again, I eventually got got the gmagick php ext installed properly and can now see docs in the doc viewer. I have not yet managed to get ca to use my browser (Firefox) default PDF viewer to open PDF documents for searching - always seems to default to the ca doc viewer, maybe there is some config setting to enable this? Also have you managed to get office to open .docs etc. Thanks very much for your help.
    Lucy Saikhan
    @lucybbs
    @juliaweist Hi Julia, I first import my mapping to it and then export from the all the type feature interface, click the export icon and then system generated by itself by using the former mapping that I exported.
    Lucy Saikhan
    @lucybbs
    This problem solved thank you.
    But I got another error.
    error.JPG
    It's said can not be empty. But some value do not have value, how should I change the setting?
    Thank you so much.