Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    koyna
    @koyna93_twitter
    image.png
    CollectiveAccess
    @collectiveaccess
    Does the 100% just "stick" there, or does it disappear after a few seconds?
    koyna
    @koyna93_twitter
    It sticks there and disappears only when I refresh the page
    CollectiveAccess
    @collectiveaccess
    Ok, make sure the PHP ZIP extension is present in your PHP install?
    askaandfish
    @askaandfish
    Hi! A question about Metadata standard. From CA Documentation, it said about VRA Core: "It will also be supported as a data export target format. This support is not yet implemented." I would like to know if this is supported now in 1.7.5? Thanks!
    CollectiveAccess
    @collectiveaccess
    No, I'm afraid we haven't gotten to it
    You can create a mapping yourself of course
    askaandfish
    @askaandfish
    Note, thanks! So is there any Metadata standard is supported as data export target format?
    CollectiveAccess
    @collectiveaccess
    In theory they all are in the sense that you can map anything in your system to XML, JSON, MARC or delimited text (TAB or CSV)
    but we are not currently packaging preset export mappings with profiles
    Export mappings are going to change depending upon your system's set up, since your export has to use the fields present in your particular configuration.
    askaandfish
    @askaandfish
    I see. So if I write my export mappings correctly, I can export in VRA Core compliant XML format, provided that my system's installation profile is also VRA Core. Am I correct?
    Kehan Harman
    @kehh
    Is there any sensible place to add a generic bundle that can be passed a template rather than co-opting one of the other available bundles and overriding the display template (format)? This is for both forms and displays. We were thinking something like adding them to getAvailableBundles() in app/models/ca_bundle_displays.php and app/models/ca_editor_ui_screens.php
    Julia
    @juliaweist
    @askaandfish that's correct
    rdobson1
    @rdobson1
    I'm a newish user with a brand new Pawtucket 1.75 install on a Windows / MAMP test. All my 'DOWNLOAD AS PDF' links are creating pdf files without the pdf extension. They open fine if I manually rename the download to add the pdf extension. Is this a known issue? Or a possible configuration issue?
    ca-ubos
    @ca-ubos
    Has anyone else trouble showing ^ca_objects.set_item_description in Pawtucket2’s set_item_info_html.php? We have objects in a set with a short text which was entered via set_item_cataloguers_ui and iot won’t show even though I’m 100% sure I got the right element code and I tried <unit relativeTo="ca_objects"> and <unit relativeTo="ca_sets">.
    CollectiveAccess
    @collectiveaccess
    @ca-ubos set_item_description is usually part of ca_set_items (the record recording the presence of the object in a specific set); it's used when you want to have content for an object specific to it's position in a set
    so try ca_set_items.set_item_description
    and make sure it's not in a unit relative to anything. You want it relative to the ca_set_items instance
    @rdobson1 I haven't heard of this one, but it does sound like a bug. Where exactly are these links showing?
    @kehh No, but what's a "generic" bundle really?
    The idea is that you should use the bundle that best corresponds to the information you're intending to display, and then customize it as needed. If that customization ends up making it largely about something else, I agree it's inelegant but it'll still work.
    We could easily add a generic "template carrier" bundle though. It would at least signal to someone looking at the configuration that a display bundle is broad and not really focussed on any one thing
    Kehan Harman
    @kehh
    @collectiveaccess part of the problem is other bundles get exposed to meaningless sort options and as you say it feels strange putting a related bundle just to show an intrinsic field with a template. Looking at the code for bundles made me think it would be possible, but I just wasn't sure what the best place would be to put it. A "template carrier" or "generic template" would be useful.
    koyna
    @koyna93_twitter

    @collectiveaccess

    Ok, make sure the PHP ZIP extension is present in your PHP install?

    We checked, the PHP ZIP is installed but it's still sticking

    koyna
    @koyna93_twitter
    The sticking issue got resolved, thanks!
    ca-ubos
    @ca-ubos
    @collectiveaccess thanks for your answer! unfotunately the method you suggested :point_up: March 30, 2018 4:20 PM returns a fatal error…
    CollectiveAccess
    @collectiveaccess
    What was the error specifically?
    @kehh Ok we'll put it on the list
    CollectiveAccess
    @collectiveaccess
    @ca-ubos I have created an issue for this: http://clangers.collectiveaccess.org/jira/browse/PROV-2418
    ca-ubos
    @ca-ubos
    Thanks!
    gideondejong
    @gideondejong
    Hello there, I got a CollectiveAccess / Pawtucket2 question. Is somebody there?

    Here's my Providence installation: https://ca.gdj.rctxs.de/
    Here's my Pawtucket installation: https://ca.gdj.rctxs.de/pawtucket/
    Here's my phpinfo: https://ca.gdj.rctxs.de/phpinfo/

    1) The "apache-error.log" tells me:

    [Wed
    Apr 18 09:38:35.823818 2018] [access_compat:error] [pid 22006:tid
    139716439496448] [client 217.227.8.249:56508] AH01797: client denied by
    server configuration: /var/www/sites/ca.gdj.rctxs.de/pawtucket/index.cgi
    [Wed
    Apr 18 09:38:35.823881 2018] [access_compat:error] [pid 22006:tid
    139716439496448] [client 217.227.8.249:56508] AH01797: client denied by
    server configuration: /var/www/sites/ca.gdj.rctxs.de/pawtucket/index.pl
    [Wed
    Apr 18 09:38:35.824923 2018] [proxy_fcgi:error] [pid 22006:tid
    139716439496448] [client 217.227.8.249:56508] AH01071: Got error 'PHP
    message: PHP Fatal error: Class 'ApplicationException' not found in
    /var/www/sites/ca.gdj.rctxs.de/pawtucket/index.php on line 33\n'

    2) Pawtucket doesn't seem to work.

    Thank you in advance!

    gideondejong
    @gideondejong
    The problem seems to have been solved, already. Thank you!
    CollectiveAccess
    @collectiveaccess
    Great
    Sean A.
    @ColonelSanderson
    Is it possible to arbitrarily load the editor of a ca_object into the webpage? render(caNavUrl(...)) doesn't work as expected.
    CollectiveAccess
    @collectiveaccess
    What exactly are you trying to accomplish?
    Sean A.
    @ColonelSanderson
    I'm trying to tweak ca_objects_components_list.php to show an editor screen instead of a template with a link
    CollectiveAccess
    @collectiveaccess
    Ah ok... you might be able to load it in an iframe, but I kind of doubt it
    Sean A.
    @ColonelSanderson
    I was hoping just to fetch the html in a similar fashion to how the quickadd/interstitial does it, and put it inline on the form
    murchmurch
    @murchmurch

    Hi! Im trying to import images into CA and extracting metadata using the EXIF tool. When i run the import i get this log: 2018-04-20 8:17:12 - INFO --> Found 2 files in directory 'H:/xampp/htdocs/providance17/import/mia'
    2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_exactly
    2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
    2018-04-20 8:17:12 - DEBUG --> Names to match: Array
    (
    [0] => mia
    )

    2018-04-20 8:17:12 - DEBUG --> Matched name mia on regex ^(.*)$
    2018-04-20 8:17:12 - DEBUG --> Trying to find records using boolean OR and values Array
    (
    [idno] => mia
    )

    2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_without_extension
    2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
    2018-04-20 8:17:12 - DEBUG --> Names to match: Array
    (
    [0] => mia
    )

    2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?).[A-Za-z0-9]+$
    2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_with_page_number_included
    2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
    2018-04-20 8:17:12 - DEBUG --> Names to match: Array
    (
    [0] => mia
    )

    2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?.[A-Za-z0-9-]+).[A-Za-z]+$
    2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
    2018-04-20 8:17:12 - DEBUG --> Names to match: Array
    (
    [0] => mia
    )

    2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?).[A-Za-z0-9]+$
    2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_with_page_number
    2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
    2018-04-20 8:17:12 - DEBUG --> Names to match: Array
    (
    [0] => mia
    )

    2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?).[A-Za-z0-9-]+.[A-Za-z]+$
    2018-04-20 8:18:41 - INFO --> Started import of H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg using mapping 1234
    2018-04-20 8:18:41 - ERROR --> Could not read source H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg (format=exif)
    2018-04-20 8:18:41 - INFO --> Importerade UlfWickbom_text.jpg som UlfWickbom_text.jpg

    As you can see the Files are found in the folder but when the EXIF part of the opoeration is run it can no longer find the file:
    2018-04-20 8:17:12 - INFO --> Found 2 files in directory 'H:/xampp/htdocs/providance17/import/mia'
    2018-04-20 8:18:41 - INFO --> Started import of H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg using mapping 1234
    2018-04-20 8:18:41 - ERROR --> Could not read source H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg (format=exif)
    2018-04-20 8:18:41 - INFO --> Importerade UlfWickbom_text.jpg som UlfWickbom_text.jpg

    Do i have to speciy something special in the maping file for the file location to make it work? I get the same behavior on a Ubuntu system...

    murchmurch
    @murchmurch
    An uppdate: If i configure the media_metadata.conf file to import the metadata it works as a charm.. But this does not give me the specific specific control that the import file gives. Any ie whats going on?
    CollectiveAccess
    @collectiveaccess
    @murchmurch How are you enabling EXIF processing in the importer?
    murchmurch
    @murchmurch
    @collectiveaccess : I have created a Data mapping excell that has EXIF as Imput Format and im using the media import setting "Extract embedded metadat object using mapping"
    Extract embedded metadata into objekt using mapping.jpg
    Data import Maping.jpg
    TBthegr81
    @TBthegr81
    @collectiveaccess
    I want to insert a comment via the Service API, I see that there is the file UserContentService.php in the deprecated folder with the function addComment, would that still work even if it's deprecated?
    And what would be the service path for that, would the deprecated folder name be part of the URI, or would ya need to move the file out of that folder?
    TBthegr81
    @TBthegr81

    @collectiveaccess Another issue, when loading any of our Providence websites it's super slow and I have tracked the problem down to the MySQL table ca_sql_search_word_index.
    I view what the database is doing via MySQL Workbench and I can see a bunch of Inserts and Deletes into this table before the server responds with the webpage.
    These write/deletes runs for about a minute before it stops, then you can use the site as intended for a while until it decides it needs to do it all over again.

    So my question is, what is this table for? I am assuming to cache searches and make them faster, but why does it behave the way it does and can we turn the search word indexing off in some way?