Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Massimiliano Losego
    @losegomax_twitter
    image.png
    we're experiencing a problem with Pawtucket slideshow when images are more than 3.
    Anybody has the same issue?
    We can't replicate the problem with the previous version of viewer in Pawtucket.
    TBthegr81
    @TBthegr81

    Am trying to save an object but having trouble figuring out the syntax.
    Creating my object with
    $entity = new ca_entities();
    $entity->setMode(ACCESS_WRITE);
    $entity->set('type_id', "76");

    And that all works, if I do a
    $entity->insert()
    It gets saved.

    But then I wanna add some name/email and whatnot values, tried
    $entity->addAttribute('email', $email);
    $entity->set('email', $email);

    But that doesn't seem to work, what am I missing?

    Biblioteca é muito +
    @bib_mais_twitter
    @kehh it worked, thank you very much! In addition, could this element (ca_objects.created.user) be included as an item in the search form? perhaps as an access point?
    Kehan Harman
    @kehh
    @bib_mais_twitter I'm not sure about that. Give it a try by creating an access point.
    bzotivla
    @bzotivla
    Hi all,
    I'm having some problems with the media in Pawtucket.
    In the image below (my Pawtucket installation) you can see that the image is broken and does not appear. I have media representation access set to "Accessible to public" so I have no idea what I'm doing wrong. Any thoughts?
    Thanks in advance.
    media.png
    Kehan Harman
    @kehh
    @bzotivla can you check whether the URL specified by the image tag is accessible by your web server.
    With Pawtucket you generally have to either copy the media in to the pawtucket installation make it available by a symbolic link. See https://docs.collectiveaccess.org/wiki/Installing_Pawtucket#Dealing_with_symlink_troubles for some help.
    Beatrice
    @bliberi_gitlab
    I'm experiencing the same exact problem with image viewer as @losegomax_twitter. It looks like if, when there are more than 3 images, a completely different component with an iframe is loaded. Is there someone that knows what's going on?
    bzotivla
    @bzotivla
    @kehh that didnt work. What value should i put on "public_access_settings" (app.conf) of Pawtucket? I have [0] and it shows everything i want except the image. It is a wrong value?
    My web server "says" that is not possible to load the image.
    thanks!
    CollectiveAccess
    @collectiveaccess
    @bliberi_gitlab You can set things such that a document viewer interface is used if there are more than X images
    @bliberi_gitlab Take a look in media_display.conf under the entry for image formats.
    You'll see directives: either use_mirador_for_image_list_length_at_least or use_universal_viewer_for_image_list_length_at_least
    Set these higher, or remove them entirely
    @bzotivla What sort of web server is this? Linux? Windows? Mac?
    bzotivla
    @bzotivla
    @collectiveaccess Its Linux
    Beatrice
    @bliberi_gitlab
    @collectiveaccess thank you!
    CollectiveAccess
    @collectiveaccess
    @bzotivla If you're getting broken images then it's likely that your media is in the wrong place, or your symlink is pointing the wrong location. Where is your back-end located on the server? And where is Pawtucket located on the machine?
    bzotivla
    @bzotivla
    @collectiveaccess The problem has been solved. It was a problem with the symlink. Thank you!
    OBXLABS
    @OBXLABS
    Hi @collectiveaccess - I asked this question on the forum but it's perhaps better placed here:
    Our institution is interested in using CA to manage our digital and physical archives. I've tried to go through the data import tutorial but it hasn't been successful. Most of the metadata does not import, including dates and descriptions. Are the sample mapping and sample data xlsx sheets up to date?
    sterlingjenson
    @sterlingjenson
    @OBXLABS , Perhaps double check the names of the fields that you want to import as I recall when I did the mapping a small typo in one of fields meant that the data was not being imported correctly.
    sterlingjenson
    @sterlingjenson
    I remember having to change the dates in the data as different individuals catalogued the dates differently. We had YYYY-MM-DD format and the importer wanted MM-DD-YYYY. I recall seeing a discussion about how to allow CA to import YYYY-MM-DD format after the fact, so I know the program has an option to import that date format
    Michael Schär
    @Michael-Schaer
    Hi there, what is the syntax in the data import mapping for importing to a metadataElement?
    Something like this:
    Rule type, Source, CA table.element
    Mapping, 1, myCustomMetaDataElement
    Michael Schär
    @Michael-Schaer
    Found it: The answer is "ca_objects.myCustomMetaDataElement"
    Julia
    @juliaweist
    @Michael-Schaer yes that's correct but keep in mind that ca_objects can more generally be ca_table.myCustomMetaDataElement
    and that for containers the syntax is ca_table.myCustomMetaDataElement.containerSubElement
    @OBXLABS - answered your question on the forum but here it is again: The CA demo site does not use the installation profile (aka CollectiveAccess configuration) that's provided on the Data Import Tutorial page, although it has some fields in common and those you've identified because they've imported correctly. To use the sample data and mapping available on the Data Import Tutorial page you must install the import profile configuration in a CollectiveAccess testing space.
    Josh Morgan
    @FantabulousJosh_twitter
    Having a bit of issue searching on a vocabulary in advanced search. Typing in any value does not return a result, nor does it start suggesting lists via type-ahead. This may be connected to the issue of Browse searching and nothing showing up when I click Terms.
    Julia
    @juliaweist
    @FantabulousJosh_twitter - how is the vocabulary set up in your system? As a relationship to ca_list items, or a metadata element drop-down list?
    Karl Becker
    @karbecker
    Hi! Is it possible to configure access to certain text-metadata elements in Pawtucket? We have a metadata element internal_notes that I’d like to show only to logged in full-access users in the frontend. Unregistered or registered visitors should not be able to see the field
    CollectiveAccess
    @collectiveaccess
    @karbecker Just wrap the place where you output it in an if statement checking access
    Karl Becker
    @karbecker
    Thanks! Do I have to use an if statement in PHP or is there any display template code für this like <ifdef code="ca_objects.elementcode" access=X>?
    Karl Becker
    @karbecker
    I managed to get it working with a hacky PHP if statement 😉 Thanks!
    Josh Morgan
    @FantabulousJosh_twitter
    @juliaweist As a relationship to ca_list items.
    Julia
    @juliaweist
    @FantabulousJosh_twitter - and how is it set up on the Advanced Search form? Can you attach a screen shot of the form?
    Julian
    @julian_boolean_twitter
    Hi all, I have my multipart id config set to autogenerate serial idnos for entities. it seems to have gone off count, possibly from a import gone wrong. Entity idnos are are in the six digit range, when they should be in the three to four digit range. Is there anyway to reset it? not the end of the world if not!
    sshipley64
    @sshipley64
    Has anyone had issues in pawtucket2 with playing video in Chrome? It works/looks fine in Firefox,IE... But in Chrome, when you click the button, it briefly shows the lower bar of the media and then disappears... I went back to the default detail view to make sure it wasn't something I changed there.
    Julia
    @juliaweist
    @julian_boolean_twitter reset the numbers themselves, or the serialization for the next idno created?
    If it's the former then you could write a script or use our spreadsheet editor to clean them up by hand (depending how many outliers there are). For the later, the serialization will look to the highest number and create an id one after that.
    Anita Ruijmen
    @aruijmen
    Hi all, has anybody have any experience with downloading large search results (+1500) as pdf, word, csv using the export tools?
    Kehan Harman
    @kehh
    @aruijmen The PDF export performs best if you're using the wkhtmltopdf pdf generation plugin. The complexity of your display will determine the amount of time it takes to download the results.
    However some database tuning by a DBA can make the downloads a lot faster (giving more memory to MySQL (innodb) helps significantly).
    sterlingjenson
    @sterlingjenson
    @aruijmen, building on what @kehh said, Providence works best with a wkhtmltopdf version 0.12.1
    RurouniDante
    @RurouniDante
    HI all, I am currently trying to get PDF support working on a Windows 10 / Apache2.4 system. After doing some testing, I noticed that the tilepics aren't being generated for any PDF files. I'm thinking it's a processor for the PDFs (maybe Zend?). I've done the configuration for the Windows OS based on the installation guide, but I'm not sure what else I can do. If anyone has any insight, it would be greatly appreciated
    Kehan Harman
    @kehh
    @sterlingjenson @aruijmen wkhmltopdf 0.12.4 also works well - I know there were issues with 0.12.3.
    sterlingjenson
    @sterlingjenson
    good to know
    Matías Butelman
    @mbutel_twitter

    Hi. I'm trying to configure a minimal pawtucket installation. For example, I would like to remove some menu items (or even don't generate the linked pages altogether? like "My collections" or "Gallery"). Also, is there a way to disable the browse menu and just link to the "Browse all items" page?
    Finally, where can I configure how the Browse all items page works?

    thanks in avance!

    Julian
    @julian_boolean_twitter
    @juliaweist Hi Julia, thanks for the tips! I cleaned them up by writing an importer to just overwrite the old numbers, which worked a charm. However, the serialization is still off, and not sequential, even though the highest number is way lower. I tried rebuilding sort/hierarchy/search to no avail. any ideas? Thank you!
    Biblioteca é muito +
    @bib_mais_twitter
    Captura de Tela 2018-10-18 às 16.28.52.png