Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Matthieu Coudron
    @teto
    there is a new LTS every 3 months and the https://www.stackage.org/lts-16.0 dates back from june. Should I expect a lts 17 this month then ?
    Keagan McClelland
    @ProofOfKeags
    That would certainly be nice. I'm currently having to pin nightly due to ARM being unsupported on 8.8.x and the most recent ARM support is 8.6.3 which has been exiled due to Windows issues
    8.10.x has native armv7 though
    Song Zhang
    @HaskellZhangSong
    Hello, I am a newbie who wants to add derive-topdown package to stackage. May I ask how the author names are ordered? Where should I add my name and email?
    Adam Bergmark
    @adambergmark_twitter
    @HaskellZhangSong order doesn't matter
    Vaclav Svejcar
    @vaclavsvejcar
    Hello, given this issue https://gitlab.haskell.org/ghc/ghc/-/issues/18446 that prevents building some packages on macOS Big Sur with GHC <8.8.5 and <8.10.3, would it be possible to switch to 8.8.5 for LTS that should solve the issue?
    Mihai Maruseac
    @mihaimaruseac
    we'll probably need a new LTS
    Yair Chuchem
    @yairchu
    How often does nightly update? (just looking forward to using ghc 8-10.3 :)
    Yair Chuchem
    @yairchu
    @vaclavsvejcar an alternative could be to work around the problem in a way that also older GHCs would work, see commercialhaskell/stack#5456
    Jakub Nowak
    @MrQubo
    Hi! It seems like cabal-install was removed from the lts snapshots (as of 14.27). How should I install cabal command without it? I want to build a project which uses cabal and doesn't have stack.yaml.
    I've tried installing from hackage with stack install cabal-install. But the problem is that cabal-install-3.4.0.0 requires Cabal-3.4.0.0 and cabal-install-3.2.0.0 requires base < 4.14. So I can't install neither with lts-17.9 snapshot.
    Adam Bergmark
    @adambergmark_twitter
    @MrQubo a package doesn't need a stack.yaml to be installable by stack. depending on how you want to use that package it may be easier to either do a stack init in that project or add it to extra-deps of an existing project
    for cabal-install, it has outdated dependencies so it hasn't been apart of snapshots for a while. checking if i can get it to build
    Jakub Nowak
    @MrQubo

    @adambergmark_twitter I've managed to install cabal-install by explicitly adding its dependencies to extra-deps:

    extra-deps:
      - Cabal-3.4.0.0
      - cabal-install-3.4.0.0
      - random-1.2.0

    But this doesn't seem right. I'll go with your suggestion and just add stack.yaml to this project. Thanks for the tip.

    Adam Bergmark
    @adambergmark_twitter
    Looks ok to me, If a package is not in a snapshot then you may need to add multiple extra-deps
    you also have ghcup install cabal btw
    Tom McLaughlin
    @thomasjm
    question, can someone tell me why stm's bounds on a recent LTS seem to be incompatible with base? If I look at LTS 17.10, the page https://www.stackage.org/lts-17.10/package/stm-2.5.0.0 shows that stm comes from Hackage version 2.5.0.0@rev:1, which specifies base >=4.3 && <4.14. and yet base on this snapshot is base-4.14.1.0.
    this is tripping me up because I'm trying to use Haskell.nix to build things from this snapshot, and cabal is complaining about this bound conflict, so I'm wondering how stackage gets around it
    Adam Bergmark
    @adambergmark_twitter
    @thomasjm i suspect that the stm 2.5.0.0 that ships with GHC is not the same as what was uploaded to hackage. unfortunately i don’t think ghc devs make such guarantees. the stackage says ”Latest on Hackage” not that we are using exactly that release
    Simon Jakobi
    @sjakobi
    @thomasjm This is the upstream issue: haskell/stm#45
    Tom McLaughlin
    @thomasjm
    ah, thank you both. so i guess it's up to subtleties of cabal vs. stack configuration for when it uses the GHC-provided version vs. when it tries to pull in the hackage version and runs into solver problems
    Andy Aylward
    @aaylward
    hi all -- is there a plan to release a stackage version for ghc 8.10.5? It would be helpful for folks on arm mac :)
    Adam Bergmark
    @adambergmark_twitter
    we are trying to direct all chat to the haskell foundation slack. but the short answer is that we are waiting for 8.10.6 for LTS. nightly is already at 9.0.1
    Andy Aylward
    @aaylward
    thanks @adambergmark_twitter
    Daniel Chambers
    @daniel-chambers
    Hi, I think I've found a bug in LTS 18's configuration for the mintty package. It is specifying a flag that no longer exists on the newest version of the package that causes the package to fail to build correctly on Windows (details on this Stack Overflow answer: https://stackoverflow.com/a/70046775/107512).
    I'm wondering what the correct process is to have this fixed? Can I just submit a PR correcting that flag to use the correct one in the build-constraints for the lts18 branch? To be clear, I'm not the maintainer of that package, but I'd like to help contribute this fix if I can. :)