stack install cabal-install. But the problem is that
base < 4.14. So I can't install neither with lts-17.9 snapshot.
@adambergmark_twitter I've managed to install cabal-install by explicitly adding its dependencies to extra-deps:
extra-deps: - Cabal-22.214.171.124 - cabal-install-126.96.36.199 - random-1.2.0
But this doesn't seem right. I'll go with your suggestion and just add stack.yaml to this project. Thanks for the tip.
ghcup install cabalbtw
stm's bounds on a recent LTS seem to be incompatible with
base? If I look at LTS 17.10, the page https://www.stackage.org/lts-17.10/package/stm-188.8.131.52 shows that
stmcomes from Hackage version 184.108.40.206@rev:1, which specifies
base >=4.3 && <4.14. and yet
baseon this snapshot is