These are chat archives for composer/composer

17th
Jul 2015
Kevin Auvinet
@ke20
Jul 17 2015 13:44

Hello all,
I've a problem with composer but I don't know how to resolve it.
I've try update composer and clear the cache, but there is always the error.

Someone can help me ?

(I'm french sorry for my mistakes)

Aleksey Razbakov
@razbakov
Jul 17 2015 13:45
give me ur composer.json
the minimal config that is failing
Kevin Auvinet
@ke20
Jul 17 2015 13:47
Here the piece of code for this problem
"repositories":  [
        {
            "type": "package",
            "package": {
                "name": "nusphere/nusoap",
                "version": "0.9.5",
                "dist": {
                    "url": "http://downloads.sourceforge.net/project/nusoap/nusoap/0.9.5/nusoap-0.9.5.zip",
                    "type": "zip"
                },
                "autoload": {
                    "classmap": ["lib/"]
                }
            }
        }
]
Do you need all my json ?
Aleksey Razbakov
@razbakov
Jul 17 2015 13:51
it is only repo
give me also require section
Kevin Auvinet
@ke20
Jul 17 2015 13:52
"require": {
        "php": ">=5.3.3",
        "symfony/symfony": "2.6.*",
        "doctrine/orm": "2.4.*",
        "doctrine/doctrine-bundle": "~1.2",
        "twig/extensions": "~1.0",
        "symfony/assetic-bundle": "dev-master",
        "symfony/swiftmailer-bundle": "~2.3",
        "symfony/monolog-bundle": "~2.4",
        "sensio/distribution-bundle": "~3.0.12",
        "sensio/framework-extra-bundle": "~3.0",
        "incenteev/composer-parameter-handler": "~2.0",

        "goetas/apache-fop": "1.0.*",
        "jms/serializer-bundle": "~0.13",
        "yousign/yousign-api-client": "~1.3",
        "smalot/pdfparser": "*",
        "setasign/fpdf": "1.7",
        "setasign/fpdi": "1.5.3",
        "tecnick.com/tcpdf": "~6.2",
        "jms/serializer": "0.16.*",
        "egulias/email-validator": "^1.2"
    },
    "require-dev": {
        "sensio/generator-bundle": "~2.3",
        "fzaninotto/faker": "1.5.*@dev",
        "phpunit/phpunit": "^4.7",
        "nelmio/alice": "^2.0"
    }
Aleksey Razbakov
@razbakov
Jul 17 2015 13:54
i don’t see "nusphere/nusoap” in your require section
Kevin Auvinet
@ke20
Jul 17 2015 13:54
My json worked fine there as 3 days ago and I didn't update
It depends to yousign/yousign-api-client
Aleksey Razbakov
@razbakov
Jul 17 2015 14:00
ok
Kevin Auvinet
@ke20
Jul 17 2015 14:19
I have already got this error and it was gone alone some hours after.
But I don't know if there is a problem with my code or with Composer.
Aleksey Razbakov
@razbakov
Jul 17 2015 14:27
i think it is like a problem with this zip
or connection problem
no idea
Kevin Auvinet
@ke20
Jul 17 2015 14:31
I try to download the zip with the direct link and it works correctly.
The zip file seems not corrupt.
No problem, thx for your help !!
Henrik Thesing
@henrikthesing
Jul 17 2015 14:36
Sorry, different topic: Is there a way to execute a script after a modules was updated, which is part of the module itself? The docs about "scripts" only describe the way to execute scripts defined in the root composer file.
Aleksey Razbakov
@razbakov
Jul 17 2015 14:44
"post-update-cmd": [
Henrik Thesing
@henrikthesing
Jul 17 2015 14:55
Can I define this in the modules composer.json?
Aleksey Razbakov
@razbakov
Jul 17 2015 15:06
i am not sure about it
why don’t u try?
Henrik Thesing
@henrikthesing
Jul 17 2015 15:21
I'll try it, thanks
Kevin Auvinet
@ke20
Jul 17 2015 15:25
@razbakov Just for info, my problem seems to be cause by sourceforge which is in maintenance
The file downloaded by a wget is an html file and not a zip file ...
And in the HTML file there is a javascript redirection
Thx for your help again and sorry for the inconvenience
Aleksey Razbakov
@razbakov
Jul 17 2015 15:55
@ke20 that’s exactly what i thought when i saw an error and when i checked the link with zip and i had to wait 1s to start downloading zip, next time i should try to download directly with wget :D