These are chat archives for composer/composer

18th
May 2016
MarekL
@marek-l
May 18 2016 06:55
hello, I am not quite sure if I understand usage of my own git repository as packages source, is there any way to have packages (bundles) in one repository and require them from that? Or every package must have own git repository? Thanks
Théo FIDRY
@theofidry
May 18 2016 07:57
Hi @marek-l, you can have several composer packages in the same git repository, that's what is doing Symfony for example: https://github.com/symfony/symfony; however, it requires to do some sub tree split so 1 git repo/ composer package is by far the easiest way to go
Rob
@alcohol
May 18 2016 08:04
@marek-l you can have a monolithic repository setup using path repository definitions
@marek-l but you will have to clarify your use-case a bit more if you really want a proper answer
MarekL
@marek-l
May 18 2016 08:14
@alcohol thank you very much for reply, ok I will try to clarify what I want. I want to have one own git repository and require packages from that this way: require "mynamespace/package1" ... require "mynamespace/package2" ... I have configured my repository in repositories section of composer.json and it is working with one package in repository. My question is how to configure my git repo to have stored multiple packages in repo.
Rob
@alcohol
May 18 2016 08:14
storing multiple packages in the same repository does not make much sense
it's still not clear to me why you would want to do this also
if your repository is a project/application, then just use namespaces and map those using autoload definitions
if you are talking about a library/package that can be consumed by other people/projects, then you really cannot have more than 1 per repository.
MarekL
@marek-l
May 18 2016 08:16
ok, I understand
yes you are right, It is not good idea
Rob
@alcohol
May 18 2016 08:17
it's not about being right or wrong, it is just not possible :)
MarekL
@marek-l
May 18 2016 08:17
yes :)
Tim Kelty
@timkelty
May 18 2016 18:49
Hi all - is anyone around to help me with a "minimum-stability" question?
I have a package with a dep that is currently using dev-master, simply because the author hasn't published any actual versions. I have "minimum-stability": "dev" in my package's composer.json, but I don't want everyone that uses my package to do the same, which now it seems they have to
is there any way around that?
Ben Johnson
@mmic-bjohnson
May 18 2016 19:25
@timkelty Pretty sure you can still use "minimum-stability": "stable" and dev-master in your require. In fact, I'm doing it myself.
Tim Kelty
@timkelty
May 18 2016 19:27

Here's what I get: ```❯ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1

- nystudio107/seomatic 1.1.17 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.10 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.11 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.12 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.13 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.14 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.15 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.16 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.17 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.5 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.6 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.7 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.8 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- nystudio107/seomatic 1.1.9 requires crodas/text-rank dev-master -> satisfiable by crodas/text-rank[dev-master].
- Removal request for crodas/text-rank == 9999999-dev
- Installation request for nystudio107/seomatic ^1.1.5 -> satisfiable by nystudio107/seomatic[1.1.10, 1.1.11, 1.1.12, 1.1.13, 1.1.14, 1.1.15, 1.1.16, 1.1.17, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.1.9].```
with a composer.json of: { "require": { "nystudio107/seomatic": "^1.1.5" } }
nystudio107/seomatic requires crodas/text-rank, which doesn't have a published version
I tried changing the requirment in nystudio107/seomatic to "crodas/text-rank" : "@dev", instead of dev-master, no luck
Project requires nystudio107/seomatic which requires crodas/text-rank
Can only get it to intstall with minimum-stability: dev on Project
Tim Kelty
@timkelty
May 18 2016 19:36
Ah ok - it seems that it works if in Project, I also do "crodas/text-rank": "@dev"
which makes sense I guess, I need to whitelist that one package. I guess I was hoping having nystudio107/seomatic list is as @dev would be enough
Ben Johnson
@mmic-bjohnson
May 18 2016 20:07
@timkelty Ah, okay, yeah, you discovered what I was going to say on your own it seems. So, it's all working at this point?
Tim Kelty
@timkelty
May 18 2016 20:08
Yep! I'd rather not have to specify that child dep in my top level proj, but if thats how it is with no published version, that's fine
thanks for the help
Ben Johnson
@mmic-bjohnson
May 18 2016 20:10
@timkelty To my knowledge, that is how/the only way it is done. Any time! :thumbsup: