These are chat archives for composer/composer

15th
Jun 2016
Tim Kelty
@timkelty
Jun 15 2016 17:53
Anyone around to help me with a composer require issue?
for the life of me, I cannot get this specific non-packagist package to install via repositories:
  "require": {
    "page-8/craft-manytomany": "^0.1.2@dev"
  },
  "repositories": [
    {
      "type": "vcs",
      "url": "https://github.com/page-8/craft-manytomany"
    }
  ]
}
This message was deleted

I get:

Your requirements could not be resolved to an installable set of packages.

Problem 1The requested package page-8/craft-manytomany could not be found in any version, there may be a typo in the package name.

Hans-Christian Andersen
@thebuccaneersden
Jun 15 2016 17:55
@timkelty try pinning to just:
"page-8/craft-manytomany": “~0.1.2”
?
Tim Kelty
@timkelty
Jun 15 2016 17:56
@thebuccaneersden same error
I don't get it. https://github.com/page-8/craft-manytomany has a 0.1.2 tag, and a composer.json with
ha!
it has a typo (quote) in the package name
Hans-Christian Andersen
@thebuccaneersden
Jun 15 2016 18:21
lol!
maybe create a PR on that project?