These are chat archives for composer/composer

22nd
Aug 2016
Tareq Mahmood
@tareqtms
Aug 22 2016 04:45
@davidjeddy my current version is 1.0.0-beta
David J Eddy
@davidjeddy
Aug 22 2016 05:24
Take the beta off the branch name. Then make sure packgist updates. That should do the trick for you
Rob
@alcohol
Aug 22 2016 05:56
@hellboy81 you should just use npm for that
@tareqtms you do not have a stable tag yet
Tareq Mahmood
@tareqtms
Aug 22 2016 05:57
@davidjeddy Thanks, I will do when I think the project is complete for the production use.
@hellboy81 But I have removed the part says “minimum-stability”:”stable” (in composer.json), shouldn’t it allow to download unstable verions now?
Rob
@alcohol
Aug 22 2016 05:59
@tareqtms no because the default is stable.
Tareq Mahmood
@tareqtms
Aug 22 2016 05:59
@alcohol Ok. I see, thanks.
Rob
@alcohol
Aug 22 2016 06:00
you can choose to allow dev stability for all packages, or you can allow it for your specific package only by changing the constraint to "^1.0@dev"
if you choose to go with "minimum-stability: 'dev'" i recommend you also add "prefer-stable: true"
Tareq Mahmood
@tareqtms
Aug 22 2016 06:10
@alcohol Thanks. I will check on that.
David J Eddy
@davidjeddy
Aug 22 2016 12:32
For your own package if it's not production ready use the number below version 1. Then in your projects composer. Json file override the constrained as stated above