These are chat archives for composer/composer

24th
Aug 2016
Felix Becker
@felixfbecker
Aug 24 2016 15:43
But when trying to install, I get the error
  [UnexpectedValueException]
  Invalid version string ""
Does anyone know what I did wrong?
Ben Johnson
@mmic-bjohnson
Aug 24 2016 17:36
@felixfbecker How are you attempting to install the package?
Felix Becker
@felixfbecker
Aug 24 2016 18:19
composer require felixfbecker/advanced-json-rpc
I also tried composer require felixfbecker/advanced-json-rpc:1.0.0, same error
Ben Johnson
@mmic-bjohnson
Aug 24 2016 19:20
@felixfbecker Are you using the latest version of Composer? i.e., have you run composer self-update any time recently?
David J Eddy
@davidjeddy
Aug 24 2016 19:27
This is likely completely unrelated; why the 'v' in the version number?
Felix Becker
@felixfbecker
Aug 24 2016 21:23
yes
@davidjeddy Thats the convention I adopted for tagging releases, seems like many big composer packages do it aswell
disclaimer: I come from NodeJS and NPM and I am very confused with all this tag-infering and stability etc
Felix Becker
@felixfbecker
Aug 24 2016 21:34
I fixed it :D it was a problem with the project, not the library