These are chat archives for composer/composer

3rd
May 2017
Alexander Gaal
@alexgaal
May 03 2017 18:50

Hello,

why I can't require my package via composer in phpstorm?

[InvalidArgumentException]
  Could not find package alexgaal/php-benchmark at any version for your minimum-stability (stable). Check the package spelling or your minimum-stability
Ben Johnson
@cbj4074
May 03 2017 18:51
@alexgaal At which version are you requiring alexgaal/php-benchmark?
Darryl Meganoski
@DMeganoski
May 03 2017 18:52
I believe there is some sort of registration process to be able to install your package by name. What you would have to do in this case is add your repository to the 'reposititories' config in composer.json.
Alexander Gaal
@alexgaal
May 03 2017 18:52
there is only one branch
I've added it on packagist and github.
hmm not sure, then.
Ben Johnson
@cbj4074
May 03 2017 19:17
@alexgaal That doesn't really answer the question... :D How are you requiring it? @dev-master?
In other words, show us the line of relevance in your composer.json.
Alexander Gaal
@alexgaal
May 03 2017 19:18
Nah, just composer require alexgaal/php-benchmark via terminal
Ben Johnson
@cbj4074
May 03 2017 19:18
Right, so it's not "stable".
And your minimum stability requirement is "stable".
So, the message seems to be accurate.
You'll either need to change your minimum stability requirement, or tag your branch, thus making it "stable".
Alexander Gaal
@alexgaal
May 03 2017 19:20
ah, in my package composer.json is min-stability: dev, idk why.
I could bet I typed stable in there.
Ben Johnson
@cbj4074
May 03 2017 19:28
@alexgaal It's not your package that matters; it's the setting in the parent ("top-level") composer.json.
"At the project-level", if you will.