These are chat archives for composer/composer

29th
Dec 2017
Manjunath Reddy
@manju16832003
Dec 29 2017 15:22
Hey all, composer is taking for ever to install a package
Running composer require guzzlehttp/guzzle:~6.0 in a laravel app
Its stuck, even with -v I don't see any progress.
any of you having the same issues?
Manjunath Reddy
@manju16832003
Dec 29 2017 15:28
OK, this is wired, can't seem to install any package with composer.
sticking with basics... going to use php-curl
Ben Johnson
@cbj4074
Dec 29 2017 16:09
@manju16832003 No, I have never seen that happen. :/
Which PHP version?
Manjunath Reddy
@manju16832003
Dec 29 2017 16:09
:-) 7
specifically PHP 7.0.13-1+deb.sury.org~xenial+1 (cli) ( NTS )
Ben Johnson
@cbj4074
Dec 29 2017 16:10
Great, thank you. Which Composer version?
Manjunath Reddy
@manju16832003
Dec 29 2017 16:10
Composer version 1.5.6
After for about 20mins I got this

`composer require require guzzlehttp/guzzle

[InvalidArgumentException]
Could not find a matching version of package require. Check the package spelling, your version constraint and that the package is available in a stability which matches your minimum-stability (stable).`

Ben Johnson
@cbj4074
Dec 29 2017 16:11
You have require in there twice
Hence the bizarre error message
That doesn't explain why it took so damn long, but remove that extra require and give it another go.
Manjunath Reddy
@manju16832003
Dec 29 2017 16:11
Yes, trying :-)
No luck :-). its stuck
hmmm after 5mins
Using version ^6.3 for guzzlehttp/guzzle ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev)
Manjunath Reddy
@manju16832003
Dec 29 2017 16:22
Here is the actual error message

`Using version ^6.3 for guzzlehttp/guzzle
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1

- symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
- symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
- symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
- Installation request for symfony/event-dispatcher (locked at v4.0.2) -> satisfiable by symfony/event-dispatcher[v4.0.2].

Installation failed, reverting ./composer.json to its original content.
`

Ben Johnson
@cbj4074
Dec 29 2017 16:31
@manju16832003 I have no idea why it takes so much time, but that is a separate issue.
The error you're receiving now is pretty cut-and-dry. You need PHP 7.1.3 or later to use the packages you're requesting.
Manjunath Reddy
@manju16832003
Dec 29 2017 16:32
Interesting.
Ben Johnson
@cbj4074
Dec 29 2017 16:34
It likely has something to do with pcntl, which is available only in 7.1.
So, you either need to use older versions of everything, or upgrade PHP.
Manjunath Reddy
@manju16832003
Dec 29 2017 16:35
is there a command to upgrade php to latest..
Ben Johnson
@cbj4074
Dec 29 2017 16:36
Yeah, it looks like you are using Ondrej Sury's PPA for Ubuntu. Smart guy!
Is this in a VM? Is it testing only? Do you care about anything breaking?
Manjunath Reddy
@manju16832003
Dec 29 2017 16:36
oh Yes...
Homestead vagrant from Laravel
Ben Johnson
@cbj4074
Dec 29 2017 16:37
Okay, perfect. Then the easiest thing to do is simply to upgrade Homestead.
Your version appears to be quite stale.
Manjunath Reddy
@manju16832003
Dec 29 2017 16:37
Yes, I guess so. ... my vagrant box is quite old... Probably 1.3 years lol
Ben Johnson
@cbj4074
Dec 29 2017 16:37
That's a different subject, though, and may be best asked over in laravel/laravel.
(I can help you there)