These are chat archives for composer/composer

28th
May 2018
Nicky De Maeyer
@ctrl-f5
May 28 2018 12:51
Hello, In my project I'm trying to install phpcs ^3.2, but I have also installed robo, which has phpcs ^2.9 as a require-dev. phpcs ^3.2 thus fails because of the restriction in a require-dev of a subpackage. although it seems require-devs of subpackages are not installed?
I could solve this by doing "squizlabs/php_codesniffer": "3.2.0 as 2.9.1" but then I can not install other packages that require phpcs ^3.x
Nicky De Maeyer
@ctrl-f5
May 28 2018 13:11
So why does it check a subpackage's require-dev when those are not installed?
also, this doesn't seem right:
$ composer why-not slevomat/coding-standard


  [InvalidArgumentException]                                         
  Could not find package "slevomat/coding-standard" in your project
Nicky De Maeyer
@ctrl-f5
May 28 2018 13:19
I found the first issue, in the installed robo version, phpcs is in "require", not in "require-dev"