Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    still-dreaming-1
    @still-dreaming-1
    @cbj4074 And there is the link for the chatroom for any type of PurposefulPhp related chat: https://gitter.im/still-dreaming-1/PurposefulPhp
    Ben Johnson
    @cbj4074
    @still-dreaming-1 Awesome! Thank you! I will check that out :thumbsup:
    Mike Schinkel
    @mikeschinkel

    @cbj4074

    "Be aware also of installed.json"

    Yes! That just bit me yesterday.

    Ben Johnson
    @cbj4074
    @mikeschinkel :thumbsup: :D
    Ben Johnson
    @cbj4074
    Does anyone know precisely which phase of composer update | install checks/recreates the binary symlinks?
    I'm curious if there is a means by which to "force" that process to occur without having to do something hacky, like composer --no-scripts update fake-repo-to-force-bin-symlinking
    hellboy81
    @hellboy81
    Hi
    Is this chat dead or alive?
    Ben Johnson
    @cbj4074
    @hellboy81 I think we're the only two here
    (I say that tongue-in-cheek, so to speak)
    hellboy81
    @hellboy81
    I have big trouble with autloader
    How can I test PSR-4 autoloads?
    Owen Melbourne
    @OwenMelbz
    try use the thing your autoloading - if it works, it works, if it doesnt it doesnt :D
    FlyLo11
    @FlyLo11

    hello,

    {
      "autoload": {
        "psr-0": {
          "App_": "lib/App/"
        }
      }
    }

    this fails to load class App_Test_MyClass located in lib/App/Test/MyClass.php when doing composer dump-autoload
    it works only with composer dump-autoload -o
    am I missing something?

    it works only when defining it as "":"lib/"
    Owen Melbourne
    @OwenMelbz
    tried psr4 autoloading instead?
    dont think psr0 autoloadings been supported for several years now
    FlyLo11
    @FlyLo11
    yeah, i suppose so
    Owen Melbourne
    @OwenMelbz
    might find more docs/articles giving better help with that
    FlyLo11
    @FlyLo11
    from looking at the ClassLoader code, it replaces the underscore with a backslash, so App_ becomes App\, it assumes it's supposed to be a namespace
    seems confusing, in docs it provides an example with underscores, i thought that means it expect partial class name, not a namespace
    but it was still funny that dump-autoload -o just scans those directories and correctly builds the class map
    Owen Melbourne
    @OwenMelbz
    im not sure myself - have you tried using the classmap or files method?
    "autoload": {
        "classmap": ["lib/App/"]
    }
    FlyLo11
    @FlyLo11
    no, '":"lib/" solved it. i was curious if it was a bug or smth
    i would probably expect a classmap would work too
    Joseph Leon
    @JosephLeon
    Im getting an error "Cannot create cache directory /composer/cache/repo/https--packagist.org/, or is not writable....". I've googled the issue and many said it had to do with a ~/.composer file. However I do not have that, I'm on CentOs if that matters.
    Ben Johnson
    @cbj4074
    @JosephLeon Yeah, I can't imagine the user as whom you are running composer has sufficient rights to create a directory at the root of the filesystem.
    If you don't have a ~/.composer file, create one. :D
    Owen Melbourne
    @OwenMelbz
    did you ever run as root?
    Vishal Bhalodiya
    @vishuB
    hello
    in my composer.json
        "minimum-stability": "dev",
        "require": {
            "php": ">=5.4.0",
            "yiisoft/yii2": "~2.0.6",
            "yiisoft/yii2-bootstrap": "~2.1.0",
            "yiisoft/yii2-swiftmailer": "~2.0.0",
            "yiisoft/yii2-imagine": "^2.1",
            "unclead/yii2-multiple-input": "~2.0",
            "yiisoft/yii2-jui": "^2.0",
            "kartik-v/yii2-widget-select2": "@dev",
            "kartik-v/yii2-widget-depdrop": "@dev",
            "phpoffice/phpexcel": "^1.8",
            "mpdf/mpdf": "^6.1"
        },
    is it possible to update "yiisoft/yii2" as stable version ?
    niwde
    @edwint88
    do you mean 2.0.6@stable?
    Vishal Bhalodiya
    @vishuB
    no
    justpie
    @justpie

    Hey all, is there anway that I can force composer to install a package even if it doesn't meet the requirement?

    My composer.json requires framework-bundle: 3.0; The package barcode-bundle requires ~2.3. I want to see if i can force the install of the package to see if i can get it working.

    My Composer.json

    require: {
    "symfony/framework-bundle": "3.0",
    "mopa/barcode-bundle": "dev-master",
    }

    barcode-bundle composer.json

    require: {
    "symfony/framework-bundle": "~2.3",
    }
    saima-akhtar
    @saima-akhtar
    hello every one....
    i want to make my final year project ...online chat room with audio video call,web based can anyone guide or help please
    Ben Johnson
    @cbj4074
    Sounds pretty ambitious.
    Ben Johnson
    @cbj4074
    (and your question is completely unrelated to this channel)
    Manjunath Reddy
    @manjufy
    Hey all, composer is taking for ever to install a package
    Running composer require guzzlehttp/guzzle:~6.0 in a laravel app
    Its stuck, even with -v I don't see any progress.
    any of you having the same issues?
    Manjunath Reddy
    @manjufy
    OK, this is wired, can't seem to install any package with composer.
    sticking with basics... going to use php-curl
    Ben Johnson
    @cbj4074
    @manju16832003 No, I have never seen that happen. :/
    Which PHP version?
    Manjunath Reddy
    @manjufy
    :-) 7