Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    FlyLo11
    @FlyLo11
    but it was still funny that dump-autoload -o just scans those directories and correctly builds the class map
    Owen Melbourne
    @OwenMelbz
    im not sure myself - have you tried using the classmap or files method?
    "autoload": {
        "classmap": ["lib/App/"]
    }
    FlyLo11
    @FlyLo11
    no, '":"lib/" solved it. i was curious if it was a bug or smth
    i would probably expect a classmap would work too
    Joseph Leon
    @JosephLeon
    Im getting an error "Cannot create cache directory /composer/cache/repo/https--packagist.org/, or is not writable....". I've googled the issue and many said it had to do with a ~/.composer file. However I do not have that, I'm on CentOs if that matters.
    Ben Johnson
    @cbj4074
    @JosephLeon Yeah, I can't imagine the user as whom you are running composer has sufficient rights to create a directory at the root of the filesystem.
    If you don't have a ~/.composer file, create one. :D
    Owen Melbourne
    @OwenMelbz
    did you ever run as root?
    Vishal Bhalodiya
    @vishuB
    hello
    in my composer.json
        "minimum-stability": "dev",
        "require": {
            "php": ">=5.4.0",
            "yiisoft/yii2": "~2.0.6",
            "yiisoft/yii2-bootstrap": "~2.1.0",
            "yiisoft/yii2-swiftmailer": "~2.0.0",
            "yiisoft/yii2-imagine": "^2.1",
            "unclead/yii2-multiple-input": "~2.0",
            "yiisoft/yii2-jui": "^2.0",
            "kartik-v/yii2-widget-select2": "@dev",
            "kartik-v/yii2-widget-depdrop": "@dev",
            "phpoffice/phpexcel": "^1.8",
            "mpdf/mpdf": "^6.1"
        },
    is it possible to update "yiisoft/yii2" as stable version ?
    niwde
    @edwint88
    do you mean 2.0.6@stable?
    Vishal Bhalodiya
    @vishuB
    no
    justpie
    @justpie

    Hey all, is there anway that I can force composer to install a package even if it doesn't meet the requirement?

    My composer.json requires framework-bundle: 3.0; The package barcode-bundle requires ~2.3. I want to see if i can force the install of the package to see if i can get it working.

    My Composer.json

    require: {
    "symfony/framework-bundle": "3.0",
    "mopa/barcode-bundle": "dev-master",
    }

    barcode-bundle composer.json

    require: {
    "symfony/framework-bundle": "~2.3",
    }
    saima-akhtar
    @saima-akhtar
    hello every one....
    i want to make my final year project ...online chat room with audio video call,web based can anyone guide or help please
    Ben Johnson
    @cbj4074
    Sounds pretty ambitious.
    Ben Johnson
    @cbj4074
    (and your question is completely unrelated to this channel)
    Manjunath Reddy
    @manjufy
    Hey all, composer is taking for ever to install a package
    Running composer require guzzlehttp/guzzle:~6.0 in a laravel app
    Its stuck, even with -v I don't see any progress.
    any of you having the same issues?
    Manjunath Reddy
    @manjufy
    OK, this is wired, can't seem to install any package with composer.
    sticking with basics... going to use php-curl
    Ben Johnson
    @cbj4074
    @manju16832003 No, I have never seen that happen. :/
    Which PHP version?
    Manjunath Reddy
    @manjufy
    :-) 7
    specifically PHP 7.0.13-1+deb.sury.org~xenial+1 (cli) ( NTS )
    Ben Johnson
    @cbj4074
    Great, thank you. Which Composer version?
    Manjunath Reddy
    @manjufy
    Composer version 1.5.6
    After for about 20mins I got this

    `composer require require guzzlehttp/guzzle

    [InvalidArgumentException]
    Could not find a matching version of package require. Check the package spelling, your version constraint and that the package is available in a stability which matches your minimum-stability (stable).`

    Ben Johnson
    @cbj4074
    You have require in there twice
    Hence the bizarre error message
    That doesn't explain why it took so damn long, but remove that extra require and give it another go.
    Manjunath Reddy
    @manjufy
    Yes, trying :-)
    No luck :-). its stuck
    hmmm after 5mins
    Using version ^6.3 for guzzlehttp/guzzle ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev)
    Manjunath Reddy
    @manjufy
    Here is the actual error message

    `Using version ^6.3 for guzzlehttp/guzzle
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)

    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    - symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
    - symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
    - symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
    - Installation request for symfony/event-dispatcher (locked at v4.0.2) -> satisfiable by symfony/event-dispatcher[v4.0.2].

    Installation failed, reverting ./composer.json to its original content.
    `

    Ben Johnson
    @cbj4074
    @manju16832003 I have no idea why it takes so much time, but that is a separate issue.
    The error you're receiving now is pretty cut-and-dry. You need PHP 7.1.3 or later to use the packages you're requesting.
    Manjunath Reddy
    @manjufy
    Interesting.
    Ben Johnson
    @cbj4074
    It likely has something to do with pcntl, which is available only in 7.1.
    So, you either need to use older versions of everything, or upgrade PHP.
    Manjunath Reddy
    @manjufy
    is there a command to upgrade php to latest..
    Ben Johnson
    @cbj4074
    Yeah, it looks like you are using Ondrej Sury's PPA for Ubuntu. Smart guy!