Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Vishal Bhalodiya
    @vishuB
    no
    justpie
    @justpie

    Hey all, is there anway that I can force composer to install a package even if it doesn't meet the requirement?

    My composer.json requires framework-bundle: 3.0; The package barcode-bundle requires ~2.3. I want to see if i can force the install of the package to see if i can get it working.

    My Composer.json

    require: {
    "symfony/framework-bundle": "3.0",
    "mopa/barcode-bundle": "dev-master",
    }

    barcode-bundle composer.json

    require: {
    "symfony/framework-bundle": "~2.3",
    }
    saima-akhtar
    @saima-akhtar
    hello every one....
    i want to make my final year project ...online chat room with audio video call,web based can anyone guide or help please
    Ben Johnson
    @cbj4074
    Sounds pretty ambitious.
    Ben Johnson
    @cbj4074
    (and your question is completely unrelated to this channel)
    Manjunath Reddy
    @manjufy
    Hey all, composer is taking for ever to install a package
    Running composer require guzzlehttp/guzzle:~6.0 in a laravel app
    Its stuck, even with -v I don't see any progress.
    any of you having the same issues?
    Manjunath Reddy
    @manjufy
    OK, this is wired, can't seem to install any package with composer.
    sticking with basics... going to use php-curl
    Ben Johnson
    @cbj4074
    @manju16832003 No, I have never seen that happen. :/
    Which PHP version?
    Manjunath Reddy
    @manjufy
    :-) 7
    specifically PHP 7.0.13-1+deb.sury.org~xenial+1 (cli) ( NTS )
    Ben Johnson
    @cbj4074
    Great, thank you. Which Composer version?
    Manjunath Reddy
    @manjufy
    Composer version 1.5.6
    After for about 20mins I got this

    `composer require require guzzlehttp/guzzle

    [InvalidArgumentException]
    Could not find a matching version of package require. Check the package spelling, your version constraint and that the package is available in a stability which matches your minimum-stability (stable).`

    Ben Johnson
    @cbj4074
    You have require in there twice
    Hence the bizarre error message
    That doesn't explain why it took so damn long, but remove that extra require and give it another go.
    Manjunath Reddy
    @manjufy
    Yes, trying :-)
    No luck :-). its stuck
    hmmm after 5mins
    Using version ^6.3 for guzzlehttp/guzzle ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev)
    Manjunath Reddy
    @manjufy
    Here is the actual error message

    `Using version ^6.3 for guzzlehttp/guzzle
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)

    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    - symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
    - symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
    - symfony/event-dispatcher v4.0.2 requires php ^7.1.3 -> your PHP version (7.0.13) does not satisfy that requirement.
    - Installation request for symfony/event-dispatcher (locked at v4.0.2) -> satisfiable by symfony/event-dispatcher[v4.0.2].

    Installation failed, reverting ./composer.json to its original content.
    `

    Ben Johnson
    @cbj4074
    @manju16832003 I have no idea why it takes so much time, but that is a separate issue.
    The error you're receiving now is pretty cut-and-dry. You need PHP 7.1.3 or later to use the packages you're requesting.
    Manjunath Reddy
    @manjufy
    Interesting.
    Ben Johnson
    @cbj4074
    It likely has something to do with pcntl, which is available only in 7.1.
    So, you either need to use older versions of everything, or upgrade PHP.
    Manjunath Reddy
    @manjufy
    is there a command to upgrade php to latest..
    Ben Johnson
    @cbj4074
    Yeah, it looks like you are using Ondrej Sury's PPA for Ubuntu. Smart guy!
    Is this in a VM? Is it testing only? Do you care about anything breaking?
    Manjunath Reddy
    @manjufy
    oh Yes...
    Homestead vagrant from Laravel
    Ben Johnson
    @cbj4074
    Okay, perfect. Then the easiest thing to do is simply to upgrade Homestead.
    Your version appears to be quite stale.
    Manjunath Reddy
    @manjufy
    Yes, I guess so. ... my vagrant box is quite old... Probably 1.3 years lol
    Ben Johnson
    @cbj4074
    That's a different subject, though, and may be best asked over in laravel/laravel.
    (I can help you there)
    Kongthap Thammachat
    @jeud

    hi i would like to install private repo from github instead of packagist, i have setup my composer.json as below

    {
      "repositories": [
        {
          "type": "package",
          "package": {
            "name": "laravel-repo",
            "version": "1.1",
            "source": {
              "url": "https://github.com/jeud/laravel-repo.git",
              "type": "git",
              "reference": "master"
            }
          }
        }
      ],
      "require": {
        "laravel-repo": "1.1"
      }
    }

    it's working but i'm not sure what different between defining type: packageinside repositories and type: git without type: package ?

    shilili
    @shilili
    Hi all! Anyone interested in participating in a php authentication research project? It's remote and we're paying developers $100/hr to participate. The goal is to get insights on how to improve the developer onboarding experience for a SaaS. Message me if interested!
    ahsan waseem
    @ahsanwaseem
    hi everyone
    need a little help
    regarding php