Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Ben Johnson
    @cbj4074
    :thumbsup:
    Nicky De Maeyer
    @ctrl-f5
    Hello, In my project I'm trying to install phpcs ^3.2, but I have also installed robo, which has phpcs ^2.9 as a require-dev. phpcs ^3.2 thus fails because of the restriction in a require-dev of a subpackage. although it seems require-devs of subpackages are not installed?
    I could solve this by doing "squizlabs/php_codesniffer": "3.2.0 as 2.9.1" but then I can not install other packages that require phpcs ^3.x
    Nicky De Maeyer
    @ctrl-f5
    So why does it check a subpackage's require-dev when those are not installed?
    also, this doesn't seem right:
    $ composer why-not slevomat/coding-standard
    
    
      [InvalidArgumentException]                                         
      Could not find package "slevomat/coding-standard" in your project
    Nicky De Maeyer
    @ctrl-f5
    I found the first issue, in the installed robo version, phpcs is in "require", not in "require-dev"
    testmyusernamebaby
    @testmyusernamebaby

    @testmyusernamebaby
    hi there
    i'm have a problem with composer
    when install some frameworks like laravel 5.6 after insatll and when updating dependencies
    i have
    [Composer\Downloader\TransportException]   The 'http://packagist.org/p/fideloper/proxy%249271e19129358853986ed3ca9315ced11a42439a57f49537033c3b436a6ff543.json   ' URL could not be accessed: HTTP/1.1 400 Bad URI

    can any one tell me ho to fix this please ?
    the url is opened in browser and not problem that's so weird

    Philipp Kropp
    @pkropp

    Hi everyone. Is there a way to use the docker composer container for doing composer install in a subfolder of the given docker-compose project? tried docker run --rm -w /var/www/html/first/second/third -v $PWD:/app composer install

    Composer could not find a composer.json file in /var/www/html/first/second/third

    Philipp Kropp
    @pkropp
    This did the trick if someone wanna know:
     docker run --rm -v "$(pwd)"/app/path/to/source:/app composer composer install
    Aaron
    @aarongerig

    Whenever I require umpirsky/country-list I get following error:

    [ErrorException]
      copy(/Users/username/Desktop/test/vendor/umpirsky/country-list/053a8fdb1a2700b6d8a
      2572533a89e77): failed to open stream: Permission denied

    I already tried to fix it with sudo chown -R $USER ~/.composer/, but unfortunately that didn't help.
    Do you have any ideas?

    Yasfelp
    @Yasfelp
    Hello, I have a big problem iam a developer from Cuba and recently i started learning laravel, but due to my location and poor (realy inexistent) access to internet im forced to stop learning laravel
    so can any body give me a full repo of composer
    to setup a local enviroment in my work place or home
    if posible a satis.json file that can be able to download all packages from packagist.org
    Owen Melbourne
    @OwenMelbz
    don't imagine packagist will provide you with a whole list, and versions would be ever changing so it would be constantly out of date which is tricky
    Yasfelp
    @Yasfelp
    @OwenMelbz Thats better then anything remember I have no acces at all to repositorys or packages
    Owen Melbourne
    @OwenMelbz
    anybody know if it's possible to overwrite a packages autoload array? theres basically a PHP file it's including which I don't need
    Lucas Freitas
    @lucasff
    yasfelp if you have some time with internet you can try to build a cache proxy of composer, maybe in a small raspberry pi server... but it will work only for the ones you download once and they're cached at that moment, you cannot have all (since that would be such a big size you can't host it by yourself).
    Renato Marinho
    @renato2marinho_twitter

    Hey guys, I'm GitScrum founder. I want to invite group members to get to know GitScrum. Site: https://site.gitscrum.com/

    GitScrum’s agile approach to project management has proven itself to be a time and money saving strategy with the flexibility to keep up with rapid changes.

    testmyusernamebaby
    @testmyusernamebaby

    i tried to install laravel from composer but i had this problem !!!

    @php -r "file_exists('.env') || copy('.env.example', '.env');"
     Loading composer repositories with package information
     Updating dependencies (including require-dev)


      [Composer\Downloader\TransportException]
      The 'http://repo.packagist.org/p/fideloper/proxy%24cd38bfdf33be50279112e09e4abd2f2a540454676431630e6e55e68b727bb876
      .json' URL could not be accessed: HTTP/1.1 400 Bad URI    

    testmyusernamebaby
    @testmyusernamebaby
    can i use proxy to composer just in command ?? i mean by paramter ???? not add to env
    rapitkan
    @rapitkan_gitlab
    Hi!
    Matt Andrade
    @andrade1379

    Hey guys, was wondering how one would be able to require multiple Drupal modules at once?

    composer require drupal/<module1> drupal/<module2> drupal/<module3>

    OR

    composer require drupal/<module1> <module2> <module3>
    Romain GRELET
    @babaorum
    the first one will work, i do not think the second one will
    Matt Andrade
    @andrade1379
    @babaorum you’re correct
    Karl Viiburg
    @kurbar

    Hi, am I able to somehow have two different sets of repositories based on some env?

    I'm developing a modular app and I'm loading in different modules through Composer.

    For development purposes I use local symlinked copies but for deployments I want to have VCS repositories for those. Changing the files back and forth is quite tedious so I was wondering if there is a way I can make it easier.

    Stavros Kefaleas
    @skiabox
    hello!
    I get the following error
    ➜  ~/Sites/PhpProject3 php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
    PHP Warning:  copy(https://getcomposer.org/installer): failed to open stream: Host is down in Command line code on line 1
    
    Warning: copy(https://getcomposer.org/installer): failed to open stream: Host is down in Command line code on line 1
    Stavros Kefaleas
    @skiabox
    problem solved
    it was a little snitch signature problem
    little snitch is the most popular mac os firewall
    Alex K
    @alex-enchi
    Hi, I have a weird question. Currently I am working with application without composer and because of many reason we can't install one, at least now. Is there any way to bundle composer library, like this https://github.com/wapmorgan/MediaFile with dependencies into one bundle? If so where I can read about it
    Thanks
    Christian Sciberras
    @uuf6429
    @alex-enchi you don't need composer after you get your dependencies... just create a composer.json file with the dependencies you want, run composer install and then use/copy the resulting vendor directory.
    Alex K
    @alex-enchi
    @uuf6429 do I need to still use autoload.php?
    Christian Sciberras
    @uuf6429
    Correct
    Alex K
    @alex-enchi
    Thank you
    Christian Sciberras
    @uuf6429
    Note that you won't need the composer.json/lock files afterwords, but I would still save them somewhere.
    Alex K
    @alex-enchi
    I'll definitely keep them under git, my main concern was that it's impossible to have composer installed and ran on target machines, only on local dev environment.
    Christian Sciberras
    @uuf6429
    The general recommendation is that you do not run composer in production. What we did at my previous company is to have build machines whose environment is identical to production. These machines would create a standalone release package that is tested and then used in production. Nowadays, one could use docker images for the same purpose, I suppose.
    Alex K
    @alex-enchi
    We're not there yet and dealing with a lot of legacy, but slowly moving forward. Hope it'll work out smoothly.
    Thanks for clarification
    Jochen Manz
    @jochenmanz
    Hi! I just noticed a strange new behaviour with 1.7.3 related to the "replace tag" change. I do have a repo which requires symfony/symfony: "3.4.18". I am not able to require a newer version of symfony/serializer (4.1 in my case) because symfony/symfony has a replace set for same.version. Is this a known bug or even known and good behaviour? It works with 1.7.2 and lower
    ok, found a issue about that: composer/composer#7764 seems like we have to change our way :D
    Stavros Kefaleas
    @skiabox
    hello guys
    I am getting class not found error
    when I try to use a 3rd party library using composer
    any ideas?
    Ben Johnson
    @cbj4074
    @skiabox It would help to see the actual error message...
    (and the require statement you used to add the dependency)
    xicond
    @xicond
    is there a way to specify different name for composer.lock ?
    Phiter Fernandes
    @phiter
    hey guys
    I have a custom composer script that generates a file, and this command has an argument