Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 22 22:18
    jakirkham commented #952
  • Jan 22 09:57
    hmaarrfk commented #673
  • Jan 22 07:44
    jschueller commented #673
  • Jan 22 03:42
    hmaarrfk commented #673
  • Jan 21 17:59
    jakirkham commented #673
  • Jan 21 16:53
    jschueller commented #673
  • Jan 21 16:52
    jschueller commented #673
  • Jan 21 16:52
    jschueller commented #673
  • Jan 21 16:52
    jschueller commented #673
  • Jan 21 16:31
    jschueller commented #673
  • Jan 21 15:11
    isuruf commented #673
  • Jan 21 09:39
    isuruf commented #831
  • Jan 21 03:43
    beckermr commented #831
  • Jan 20 19:12
    jschueller commented #673
  • Jan 18 05:50
    cbeebe44 commented #956
  • Jan 18 04:21
    jakirkham closed #956
  • Jan 18 04:21
    jakirkham commented #956
  • Jan 18 02:41
    cbeebe44 opened #956
  • Jan 14 18:13
    chmreid commented #955
  • Jan 14 18:11
    chmreid commented #955
Uwe L. Korn
@xhochy
@isuruf yes, but will do it new recording later that looks less clumsy.
Christopher J. Wright
@CJ-Wright
conda-forge in gifs would be a great docs page
Isuru Fernando
@isuruf
Thanks @xhochy
Duncan Macleod
@duncanmmacleod
ok, my build is rerunning, thanks @chrisburr, @xhochy!
Isuru Fernando
@isuruf
@saraedum, build system is setting -mmacosx-version-min=10.6
Duncan Macleod
@duncanmmacleod
does anyone know is conda-api is still maintained, or whether there is something else to use to create/modify environments from python?
Julian Rüth
@saraedum
@isuruf it seems to be setting it to -mmacosx-version-min=10.9 actually. So is it wrong that the build is searching for 10.6 here?
Isuru Fernando
@isuruf
@saraedum,
x86_64-apple-darwin13.4.0-clang -arch x86_64 -O2 -g -Wall -Wmissing-prototypes -Wshadow -Wpointer-arith -Wstrict-prototypes -Wmissing-declarations -Wcast-align -Wcast-qual -Wwrite-strings -Wempty-body -Wformat -Wformat-security -Wignored-qualifiers -Wenum-conversion -finline-functions -fno-stack-protector -fno-strict-aliasing -fno-builtin -Wno-cast-align -Wno-self-assign -Wno-tautological-compare -mmacosx-version-min=10.6 -march=core2 -mtune=haswell -mssse3 -ftree-vectorize -fPIC -fPIE -O2 -pipe -I$PREFIX/include -fdebug-prefix-map=$SRC_DIR=/usr/local/src/conda/valgrind-3.15.0 -fdebug-prefix-map=$PREFIX=/usr/local/src/conda-prefix -undefined dynamic_lookup -arch x86_64 -O2 -g -Wall -Wmissing-prototypes -Wshadow -Wpointer-arith -Wstrict-prototypes -Wmissing-declarations -Wcast-align -Wcast-qual -Wwrite-strings -Wempty-body -Wformat -Wformat-security -Wignored-qualifiers -Wenum-conversion -finline-functions -fno-stack-protector -fno-strict-aliasing -fno-builtin -Wno-cast-align -Wno-self-assign -Wno-tautological-compare -mmacosx-version-min=10.6 -Wl,-pie -Wl,-headerpad_max_install_names -Wl,-dead_strip_dylibs -Wl,-rpath,$PREFIX/lib -L$PREFIX/lib -o valgrind valgrind-launcher-darwin.o valgrind-m_debuglog.o
Above is what I see in azure
Julian Rüth
@saraedum
@isuruf You're right of course. Some lines say 10.9 and then 10.6 later in the same line. That confused me. So should we build with 10.9 actually?
Isuru Fernando
@isuruf
@saraedum, you should build with whatever MACOSX_DEPLOYMENT_TARGET variable tells you
It's 10.9 globally in conda-forge
Julian Rüth
@saraedum
That's 10.9 ok thanks. :)
Anthony Scopatz
@scopatz
@mingwandroid etc, are there any docs for how to build a CDT package?
Ray Donnelly
@mingwandroid
Not sure, but they are just normal recipes with no real deps.
jayfurmanek
@jayfurmanek

@hmaarrfk did a good job with some recent ones on aarch64 here:
conda-forge/staged-recipes#9028

It clubs the -devel versions into the same recipe

Anthony Scopatz
@scopatz
I think I am confused about how they work then
Ray Donnelly
@mingwandroid
Hmm, I'd rather they remained autogenerated personally.
jayfurmanek
@jayfurmanek
I followed that for these ppc64le ones:
conda-forge/staged-recipes#9395 (merged)
conda-forge/staged-recipes#9583 (needs a review)
Anthony Scopatz
@scopatz
Yeah, how do I autogenerate them, is my question
Ray Donnelly
@mingwandroid
conda skeleton rpm --distro=centos6 --arch=x86_64 libGL
Anthony Scopatz
@scopatz
Ahh OK
Ray Donnelly
@mingwandroid
`conda skeleton rpm --distro=centos7 --arch=ppc64le libGL
jayfurmanek
@jayfurmanek
will that work for non-x86?
Ray Donnelly
@mingwandroid
the distros are a bit hard-coded at the top of cran.py in conda-build
still, it seems to work ok
jayfurmanek
@jayfurmanek
well thats good
Ray Donnelly
@mingwandroid
you can even build them on Windows (though I'm checking that still works now)
Isuru Fernando
@isuruf
@mingwandroid, they don't on windows
Anthony Scopatz
@scopatz
Is conda-forge tied to centos6 for CDTs for linux-64?
Or can we use centos7?
Ray Donnelly
@mingwandroid
What is it you hope to gain except excluding people with old installations?
Anthony Scopatz
@scopatz
That packages don't seem to exist on centos6
Ray Donnelly
@mingwandroid
Build CF packages! ;-)
Anthony Scopatz
@scopatz
specifically systemd
Ray Donnelly
@mingwandroid
Ha systemd!
Anthony Scopatz
@scopatz
Normally I would :wink:
Ray Donnelly
@mingwandroid
Well, are you making a conda-forge linux distro here?
To be honest, a systemd package doesn't make a lot of sense to me.
Anthony Scopatz
@scopatz
I need libudev to get bluetooth support, which is now part of systemd
I agree most parts of systemd are not relevant
And the build instructions for systemd say in needs to be built into /usr
Ray Donnelly
@mingwandroid
well, udev existed in centos6 and if you run something that links to that on centos7 it will be running a systemd-aware udev and should integrate into your system OK.
(in theory)
Anthony Scopatz
@scopatz
Yes, so the problem there is that centos6 udev is v147 and bluez needs at least libudev v172
Ray Donnelly
@mingwandroid
but from our perspective, we should try to avoid systemd since it's not the only init system on Linux. Gentoo do not even use it by default. I'm not a systemd hater though so I'm not arguing from that perspective at all.
Anthony Scopatz
@scopatz
Yeah, I hear you... It doesn't really matter to me
I just wish they hadn't merged like this
It is kind of a mess for us