by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jul 03 20:13

    conda-forge-coordinator on master

    Re-ran make.py. [ci skip] (compare)

  • Jul 03 20:08
    jakirkham commented #1077
  • Jul 03 20:07

    jakirkham on master

    Update adding_pkgs.rst removes… addin back line in 'commands' Merge pull request #1077 from A… (compare)

  • Jul 03 20:07
    jakirkham closed #1077
  • Jul 03 18:17

    conda-forge-coordinator on master

    Re-ran make.py. [ci skip] (compare)

  • Jul 03 18:13

    beckermr on broken

    (compare)

  • Jul 03 18:12
    beckermr closed #1094
  • Jul 03 18:12
    beckermr commented #1094
  • Jul 03 15:48
    beckermr commented #1092
  • Jul 03 15:46
    bellet edited #1092
  • Jul 03 15:45
    bellet commented #1092
  • Jul 03 15:24
    beckermr opened #1094
  • Jul 03 15:23

    beckermr on broken

    DOC prefer repo data patches (compare)

  • Jul 03 15:13

    beckermr on broken

    DOC update docs on broken packa… (compare)

  • Jul 03 14:41
    beckermr edited #1085
  • Jul 02 16:11
    beckermr edited #1085
  • Jul 02 01:24
    CJ-Wright commented #1093
  • Jul 01 16:50
    bellet commented #1092
  • Jul 01 16:43
    bellet opened #1092
  • Jun 30 01:39
    bollwyvl commented #1052
Isuru Fernando
@isuruf
what's the fastest way to check the type of a file in python?
Ray Donnelly
@mingwandroid
There's no systemd for centos6 for us to repackage here.
Anthony Scopatz
@scopatz
Yeah, it also doesn't work for centos7
Ray Donnelly
@mingwandroid
centos7 is only tested on ppc64le and aarch64 ATM, there are hardcoded tables in cran.py (could be moved to a file if anyone cared enough, I don't see us distro hopping enough for that to be worthwhile personally)
I didn't add entries for centos7 intel as we don't target that as our base on intel as things stand.
teseoch
@teseoch

Hi, i am getting a wierd error when i try to rerender:

I tried to re-render for you, but it looks like I wasn't able to push to the v0.3a branch of libigl/igl-feedstock. Did you check the "Allow edits from maintainers" box?

any idea why?

teseoch
@teseoch
(the checkbox is checked and i tried uncheck -> check)
teseoch
@teseoch
no idea? I believe that missing re-render is causing the problems on windows
Mark Harfouche
@hmaarrfk
@mingwandroid the autogenerated ones don't really work for Conda forge. The split devel packages don't get pushed due to the dependency on an other package that is being built at the same time.
Having them together avoids that dependency circle.
Mark Harfouche
@hmaarrfk
Finally, the skeleton didn't have sha256 autogenerated, nor did it have tests, something that was recently asked. It became important due to the fact that too level directories are stripped sometimes.
Teake Nutma
@teake
There’s a PR on a feedstock I maintain but I can’t merge it (nor make changes to the cloned branch, which I want to do first). I guess I don’t have maintainer rights on my own feedstock repo? The repo in question is https://github.com/conda-forge/astromatic-psfex-feedstock.
Chris Burr
@chrisburr
@teake There is a command in the docs to get the bot to "update team"
Teake Nutma
@teake
Yup that works. Thanks @chrisburr!
Sylvain Corlay
@SylvainCorlay
Hey, do you know how I should use qmake in conda recipes?
since qt is typically a host dependency, and qmake a build tool...
Marcelo Duarte Trevisani
@marcelotrevisani
@SylvainCorlay I think you will need to create a recipe for qmake since this is not present on conda-forge
usually using just cmake is enough , unless you are using something very specific of qmake or there is no config for cmake
Ray Donnelly
@mingwandroid

@mingwandroid the autogenerated ones don't really work for Conda forge. The split devel packages don't get pushed due to the dependency on an other package that is being built at the same time.

I don't really understand what you mean here, can you explain it to me? Maybe it was more broke when you tried them? Should work fine, anyway, if conda skeleton rpm is not behaving as you need it we should fix that. I think the problems you mentioned have been fixed already FWIW conda-build is not closed source!

Sylvain Corlay
@SylvainCorlay

I think you will need to create a recipe for qmake since this is not present on conda-forge

although there seems to be some example of recipes using qmake - but probably with the host's qmake

Marcelo Duarte Trevisani
@marcelotrevisani
If you install qt you will have qmake as it is building with qt
@SylvainCorlay can you show me please those examples?
Sylvain Corlay
@SylvainCorlay
yes, but you don't get qt as a build dependency though right?
those examples are the ones I get from a github search for qmake in the conda-forge organization.
Uwe L. Korn
@xhochy
I have setup a windows machine for conda builds but run into the problem that it cannot find kernel32.lib at link time. What could I be missing?
Isuru Fernando
@isuruf
@xhochy, your VS env as not activated properly. Are you using VS2017? Note that vs2017_win-64 package is broken atm.
Uwe L. Korn
@xhochy
I'm using VS 2015, seem that installing the Windows SDK fixed my issues
Started out with only installing the build tools
Matthew R Becker
@beckermr
i'm seeing "ERROR (galsim,lib/python3.6/site-packages/galsim/_galsim.so): $PATH/lib/libc++.1.dylib found in build prefix; should never happen" in a build. Does anyone have any hints on what this means or how to fix it?
Travis Wrightsman
@twrightsman

I've been getting strange errors using conda build locally on my workstation (Azure build works fine) for my conda-forge recipe "ledger":

...
ld: cannot find -lmpfr
ld: cannot find -lgmp
...

It seems ld can't find the libraries specified in the host section of my recipe. Has anyone encountered this before? (conda-build 3.18.9)

Travis Wrightsman
@twrightsman
Tested that the build works when creating a build environment manually in conda and running the steps of build.sh with the latest source code of the recipe.
Isuru Fernando
@isuruf
Can anybody with a windows machine help out with conda-forge/qt-feedstock#122 ?
Just need to build that package with conda-build
Filipe
@ocefpaf
@isuruf I'll arrive home later today. I'll try to build it this weekend.
Francesco Biscani
@bluescarni
Hello! What is exactly the difference between the clang and clangdev packages? Which one should I install if I want to build a package using clang rather than MSVC on Windows?
Francesco Biscani
@bluescarni

Another question: why is it that this package is being built on OSX using clang 8 rather than clang 4?

https://dev.azure.com/conda-forge/feedstock-builds/_build/results?buildId=74186

I don't see anything in particular in the recipe that is asking for clang 8:

https://github.com/conda-forge/abseil-cpp-feedstock/blob/master/recipe/meta.yaml

The build with clang 8 is problematic because then it causes compatibility issues when one depends upon that package:

https://travis-ci.org/bluescarni/piranha-tng/jobs/587826816#L233

(at least if I am interpreting this correctly...)

Francesco Biscani
@bluescarni
Oh ok, thanks! That is not automatically generated right?
Chris Burr
@chrisburr
In your build it looks like you're asking for clang<5
And yeah that's written by hand
Francesco Biscani
@bluescarni
Yes, in that build I want to enforce an older clang in order to emulate the conda build environment. Sorry for asking, but I took co-maintainership of that package only yesterday and I did not realise that file was there...
I'll take out that line from the conda_build_config.yaml then, thanks a lot for the help
Francesco Biscani
@bluescarni

Sorry to bother with another question... looking for some OSX help. The package above (abseil-cpp) installs a bunch of CMake package files, one of which contains the following:

set_target_properties(absl::time_zone PROPERTIES
  INTERFACE_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/include"
  INTERFACE_LINK_LIBRARIES "\$<\$<PLATFORM_ID:Darwin>:/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/System/Library/Frameworks/CoreF
oundation.framework>"
)

Thus, it seems like it hard-coded an absolute path rather than a path relative to the conda prefix. This eventually leads to issues when using the package if the host does not have that specific version of the SDK. Should this be considered an upstream problem, or is there something I can do within conda to work around?

Francesco Biscani
@bluescarni

The relevant upstream code should be this:

https://github.com/abseil/abseil-cpp/blob/d9aa92d7fb324314f9df487ac23d32a25650b742/absl/time/CMakeLists.txt#L57

if(APPLE)
  find_library(CoreFoundation CoreFoundation)
endif()
and below:
absl_cc_library(
  NAME
    time_zone
    [...]
  COPTS
    ${ABSL_DEFAULT_COPTS}
  DEPS
    $<$<PLATFORM_ID:Darwin>:${CoreFoundation}>
)
Francesco Biscani
@bluescarni
That does not look very right. The usual way with cmake would be to create an imported target for the framework, link to that instead, and the having the framework-finding logic exported in the CMake files that get installed.
But perhaps there's something I am missing about this OSX Frameworks stuff...
Isuru Fernando
@isuruf
@bluescarni, yes, you should just patch that line to "-framework CoreFoundation"
Instead of ${CoreFoundation}