by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 08 18:50
    isuruf edited #1126
  • Aug 08 18:50
    isuruf edited #1126
  • Aug 08 18:40
    isuruf edited #1126
  • Aug 08 05:58
    isuruf edited #1126
  • Aug 08 05:51
    isuruf edited #1126
  • Aug 08 03:05
    isuruf edited #1126
  • Aug 08 01:26
    isuruf edited #1126
  • Aug 07 20:05

    conda-forge-coordinator on master

    Re-ran make.py. [ci skip] (compare)

  • Aug 07 19:57
    jakirkham commented #1131
  • Aug 07 19:53

    beckermr on master

    Update staging announcement dat… (compare)

  • Aug 07 19:53
    beckermr closed #1131
  • Aug 07 19:53
    beckermr commented #1131
  • Aug 07 19:52
    jakirkham review_requested #1131
  • Aug 07 19:52
    jakirkham review_requested #1131
  • Aug 07 19:52
    jakirkham opened #1131
  • Aug 07 18:15
    isuruf edited #1126
  • Aug 07 18:14
    beckermr edited #1126
  • Aug 07 18:03
    beckermr edited #1126
  • Aug 07 17:49
    beckermr edited #1126
  • Aug 07 17:22
    beckermr closed #993
Sylvain Corlay
@SylvainCorlay

I think you will need to create a recipe for qmake since this is not present on conda-forge

although there seems to be some example of recipes using qmake - but probably with the host's qmake

Marcelo Duarte Trevisani
@marcelotrevisani
If you install qt you will have qmake as it is building with qt
@SylvainCorlay can you show me please those examples?
Sylvain Corlay
@SylvainCorlay
yes, but you don't get qt as a build dependency though right?
those examples are the ones I get from a github search for qmake in the conda-forge organization.
Uwe L. Korn
@xhochy
I have setup a windows machine for conda builds but run into the problem that it cannot find kernel32.lib at link time. What could I be missing?
Isuru Fernando
@isuruf
@xhochy, your VS env as not activated properly. Are you using VS2017? Note that vs2017_win-64 package is broken atm.
Uwe L. Korn
@xhochy
I'm using VS 2015, seem that installing the Windows SDK fixed my issues
Started out with only installing the build tools
Matthew R Becker
@beckermr
i'm seeing "ERROR (galsim,lib/python3.6/site-packages/galsim/_galsim.so): $PATH/lib/libc++.1.dylib found in build prefix; should never happen" in a build. Does anyone have any hints on what this means or how to fix it?
Travis Wrightsman
@twrightsman

I've been getting strange errors using conda build locally on my workstation (Azure build works fine) for my conda-forge recipe "ledger":

...
ld: cannot find -lmpfr
ld: cannot find -lgmp
...

It seems ld can't find the libraries specified in the host section of my recipe. Has anyone encountered this before? (conda-build 3.18.9)

Travis Wrightsman
@twrightsman
Tested that the build works when creating a build environment manually in conda and running the steps of build.sh with the latest source code of the recipe.
Isuru Fernando
@isuruf
Can anybody with a windows machine help out with conda-forge/qt-feedstock#122 ?
Just need to build that package with conda-build
Filipe
@ocefpaf
@isuruf I'll arrive home later today. I'll try to build it this weekend.
Francesco Biscani
@bluescarni
Hello! What is exactly the difference between the clang and clangdev packages? Which one should I install if I want to build a package using clang rather than MSVC on Windows?
Francesco Biscani
@bluescarni

Another question: why is it that this package is being built on OSX using clang 8 rather than clang 4?

https://dev.azure.com/conda-forge/feedstock-builds/_build/results?buildId=74186

I don't see anything in particular in the recipe that is asking for clang 8:

https://github.com/conda-forge/abseil-cpp-feedstock/blob/master/recipe/meta.yaml

The build with clang 8 is problematic because then it causes compatibility issues when one depends upon that package:

https://travis-ci.org/bluescarni/piranha-tng/jobs/587826816#L233

(at least if I am interpreting this correctly...)

Francesco Biscani
@bluescarni
Oh ok, thanks! That is not automatically generated right?
Chris Burr
@chrisburr
In your build it looks like you're asking for clang<5
And yeah that's written by hand
Francesco Biscani
@bluescarni
Yes, in that build I want to enforce an older clang in order to emulate the conda build environment. Sorry for asking, but I took co-maintainership of that package only yesterday and I did not realise that file was there...
I'll take out that line from the conda_build_config.yaml then, thanks a lot for the help
Francesco Biscani
@bluescarni

Sorry to bother with another question... looking for some OSX help. The package above (abseil-cpp) installs a bunch of CMake package files, one of which contains the following:

set_target_properties(absl::time_zone PROPERTIES
  INTERFACE_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/include"
  INTERFACE_LINK_LIBRARIES "\$<\$<PLATFORM_ID:Darwin>:/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/System/Library/Frameworks/CoreF
oundation.framework>"
)

Thus, it seems like it hard-coded an absolute path rather than a path relative to the conda prefix. This eventually leads to issues when using the package if the host does not have that specific version of the SDK. Should this be considered an upstream problem, or is there something I can do within conda to work around?

Francesco Biscani
@bluescarni

The relevant upstream code should be this:

https://github.com/abseil/abseil-cpp/blob/d9aa92d7fb324314f9df487ac23d32a25650b742/absl/time/CMakeLists.txt#L57

if(APPLE)
  find_library(CoreFoundation CoreFoundation)
endif()
and below:
absl_cc_library(
  NAME
    time_zone
    [...]
  COPTS
    ${ABSL_DEFAULT_COPTS}
  DEPS
    $<$<PLATFORM_ID:Darwin>:${CoreFoundation}>
)
Francesco Biscani
@bluescarni
That does not look very right. The usual way with cmake would be to create an imported target for the framework, link to that instead, and the having the framework-finding logic exported in the CMake files that get installed.
But perhaps there's something I am missing about this OSX Frameworks stuff...
Isuru Fernando
@isuruf
@bluescarni, yes, you should just patch that line to "-framework CoreFoundation"
Instead of ${CoreFoundation}
Francesco Biscani
@bluescarni
Ok, I'll give it a go :) Thanks!
Anders Wallin
@aewallin
how fast does a new feedstock package get built? not immediately it seems?
Matthew R Becker
@beckermr
Travis has to run to make the feedstock
Then the feedstock repo ci has to run
Then finally anaconda has to index the feedstock and update their cdn
This last step takes about 30 min to an hour after the feedstock ci is done
You won’t see the package on conda at your command line until this last step is done
So in total I’d count on a few hours from when a pr is merged to when you can use the package
Anders Wallin
@aewallin
4 hours and still 'never built' over here https://github.com/conda-forge/allantools-feedstock - maybe azure is just busy? ;)
Matthew R Becker
@beckermr
Yup that looks like a problem.
Try opening a pr and bumping the build number
If that pr builds, then merge it and see what happens
Anders Wallin
@aewallin
that works, can I leave build number at 1 for now?
Matthew R Becker
@beckermr
Yup. Once a version bump comes through, you will bump the version and reset the build number to zero
Glad that worked! Happy conda-omg!
Conda-ing!
Anders Wallin
@aewallin
OK, thanks.
Aleksey Bilogur
@ResidentMario
Is regro-cf-autotick-bot being slow right now? I pushed a new version of geoplot to PyPi yesterday (https://pypi.org/project/geoplot/), but I haven't gotten the PR to the feedstock yet.
Uwe L. Korn
@xhochy
Could be that the bot cannot pattern match the recipe as there is no Jinja variable for the name as with other packages