Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
Repo info
  • 13:51
    dholth commented #11911
  • 13:31
    sampellino commented #9221
  • 13:00
    travishathaway synchronize #11852
  • 12:09
    travishathaway synchronize #11852
  • 12:01
    travishathaway synchronize #11852
  • 11:58
    travishathaway labeled #11743
  • 11:58
    travishathaway unlabeled #11743
  • 11:58
    travishathaway assigned #11743
  • 11:56
    travishathaway commented #11743
  • 11:54
    travishathaway synchronize #11852
  • 11:43
    travishathaway synchronize #11852
  • 08:26

    dbast on main

    Enable one single test for linu… (compare)

  • 08:26
    dbast closed #11911
  • 08:05
    travishathaway synchronize #11852
  • 07:39
    travishathaway synchronize #11852
  • 07:18
    travishathaway unpinned #11308
  • 07:18
    travishathaway unpinned #11316
  • 07:17
    travishathaway unpinned #11321
  • 07:10
    travishathaway commented #7328
  • 05:50
    FFY00 synchronize #11788
Christian Roth

Can anybody help me understand how to read this solving config error?

Package cudnn conflicts for:
pytorch-lightning=1.4.5 -> pytorch[version='>=1.6'] -> cudnn[version='>=7.6,<8.0a0|>=,<8.0a0|>=,<9.0a0|>=,<9.0a0']
pytorch::torchvision=0.10.0 -> pytorch==1.9.0 -> cudnn[version='>=,<8.0a0|>=,<9.0a0']The following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.27=0
  - nvidia::cudatoolkit=11.1.1 -> __glibc[version='>=2.17,<3.0.a0']
  - pytorch-lightning=1.4.5 -> pytorch[version='>=1.6'] -> __glibc[version='>=2.17|>=2.17,<3.0.a0']
  - pytorch::pytorch=1.9.0 -> cudatoolkit[version='>=11.1,<11.2'] -> __glibc[version='>=2.17,<3.0.a0']
  - pytorch::torchvision=0.10.0 -> cudatoolkit[version='>=11.1,<11.2'] -> __glibc[version='>=2.17|>=2.17,<3.0.a0']

Your installed version is: 2.27

Why would __glibc==2.27 conflict with __glibc[version='>=2.17|>=2.17,<3.0.a0']? What am I overlooking here?

Jaime Rodríguez-Guerra
Might be a red herring. If pytorch is involved (which requires 2.17 as you see), there's a chance a package for 2.12 is involved somehow in the dependency tree. Try solving with mamba and see if their error is a bit clearer.
1 reply
Marcelo Duarte Trevisani
Could someone please review this PR?
Maximilian Koch

Hi all,

I'm trying to build a package which includes h5py. When using conda build, it seems to install the wrong version of the dependency. It installs 3.2.1-py37h6c542dc_0, which includes hdf5: 1.10.6-nompi_h6a2412b_1114. The problem is that this hdf5 lib, seems to have these setting:
(Read-Only) S3 VFD: yes

This causes an error for me. When just running conda install h5py==3.2.1, it does install the right version.

Chris Meyer
Hi all, I noticed that packages for Python 3.10 are starting to become available. However, some packages (like h5py) are not yet available on Windows. h5py depends on pkgconfig, which is also not available on Windows. Are these packages expected to be available currently or are they still being built or is there some other reason they are not available on Windows?
Pat Gunn
Could whomever maintains the anaconda/miniconda docker images consider adding mamba to those images? It's pretty important for CI use.
7 replies
Isuru Fernando
@jezdez, can we speed up the conda-build issue/PR locking? I get around 5 emails everyday for about 5 days now and it's annoying
2 replies
cc @chenghlee
Fred Eisele
Is there a way to promote a conda environment to configure the default os environment?
I am not referring to the conda base environment.
Benjamin Bertrand
conda environments are isolated by nature. What I have done in the past is to automatically activate a specific environment using a file under /etc/profile.d on Linux so that users can use that env directly. For command line tools, another solution I used is to create simple wrappers under /usr/local/bin. Users can launch a tool without knowing it's installed in a conda env.
Ian Stokes-Rees
I'm getting repeated HTTPS connection errors from conda when trying to do conda update conda (currently running 4.11.0) -- using --debug the problem seems to be [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate -- is this just me or is there some kind of server-side issue? If it is just me can someone suggest what I need to do to correct this?
1 reply
Pat Gunn
I'm wondering if there's an existing tool to relocate a conda directory, before I get too deep into writing one for our particular needs
Right now it looks like the user's conda install path gets written into a lot of things under each environment's BASE/bin, the main CONDA_BASE/bin, as well as ~/.conda/environments.txt
Pat Gunn
It looks like conda-pack does a subset of what I want, but I was hoping for something that rewrites paths for every environment
Jannis Leidel
Andrew Kapocsi
The link to the conda mailing list in the README of the conda repo is dead: https://github.com/conda/conda#getting-help
Anyone know if there is a replacement?
Leo Fang
Any chance CDN sync has not happened in the past ~4 hrs? I am seeing packages that were uploaded a few hrs ago are not yet visible to the conda solver.
1 reply
the new multi-platform conda-ci container enable much faster test executions on Apple M1:
  • time docker run --platform linux/amd64 --rm -v ${PWD}:/opt/conda-src -e TEST_SPLITS=3 -e TEST_GROUP=1 ghcr.io/conda/conda-ci:master-linux-python3.9 /opt/conda-src/dev/linux/unit.sh needs 9:17.24
  • time docker run --platform linux/arm64 --rm -v ${PWD}:/opt/conda-src -e TEST_SPLITS=3 -e TEST_GROUP=1 ghcr.io/conda/conda-ci:master-linux-python3.9 /opt/conda-src/dev/linux/unit.sh needs 2:41.42 -> factor 3.4 faster :)
1 reply
Getting 403 errors trying to install pytorch packages with conda -- is there any known outages right now? --
The packages are listed in the directory listing for the server, but clicking on them gives an XML error and 403 message saying "Access Denied" and "Request has Expired":
Mark Harfouche
There was a known outage. Not sure if it is resolved. Definitely fewer error this morning.
might be related.
Cheng H. Lee
It was cloudflare-related but nothing to do with the outages posted on their status page. In any case, Anaconda pushed a hotfix to anaconda.org that should mitigate the issue.
1 reply
Heya! keeps trying to install different Python versions and then failing when it doesn't find some dep - example error: - nothing provides openssl >=1.1.1,< needed by python-3.7.1-h0371630_3
I explicitly put python==3.8.* (also tried it with a single = in my yaml file.
Not really sure what to do? Is there a reliable way to pin the Python version? Is there a reliable way to do detective work and see what package in my yaml file is responsible for this chain of events?
Stephen Nayfach
I updated my package checkv yesterday (https://anaconda.org/bioconda/checkv) but the new version (1.0.0) still is not available when I run conda install -c bioconda checkv. Is there something I did wrong when I updated the recipe?
1 reply
Dave Clements
We are pleased to announce that conda 4.14.0 & conda-build 3.22.0 releases are now available, featuring
⇒ rename conda environments
⇒ channel notifications
⇒ better error handling
⇒ and more!
Many thanks to all our contributors, especially the 14 new contributors who helped make this happen
Griffin Tabor

So I ran into this trying to update figure out the right workflow for my system

So its clear what I want to do is not the "conda approved" workflow so I am trying to figure out the right method.

I have software repo A that provides a conda environment to run it. Then I have software repo B that uses repo A as a dependency but also adds a number of additional dependencies that are not needed for repo A.

It seems like what I would want is to specify a new environment in repo B that is something like "these dependencies plus whatever is in the repo A environment file" and for the package manager to solve for if that's possible (and it will be) and build me that environment. If its not possible it would throw and error just like it does if I make a single environment file that isn't possible, like asking for specific versions of packages that don't go together.

What is the suggested workflow for this? Would env update second_file.yaml work to add second set of dependencies?

Alan Hoyle
I installed a tool with micromamba on a CentOS 7 machine. The install worked fine, but when I try to run it, I get an error: ImportError: libffi.so.7: cannot open shared object file: No such file or directory I see libffi.so.6 in the system lib64, and libffi.so.8 in my ~/micromamba/lib (it's a symbolic link to somewhere else in the hierarchy). Is this most likely a problem with the conda package?
1 reply
Daniel Holth
Hello condans
Jaime Rodríguez-Guerra
Pat Gunn
I'm wondering if people have hints as to how to debug when a package on a conda channel is not considered a candidate for installation (apart from the obvious "wrong arch")
Pat Gunn
This fails: conda create -n assimp_test -c flyem-forge -c conda-forge assimp=4.0.1 but I can see in the flyem-forge channel that there is a Linux package of assimp 4.0.1. Unclear how to debug further
4 replies
Pat Gunn
Weird. I can download the bz2 package and manually put it into an environment first, then build the rest of the environment. Wondering if this is some channel index issue
Jaime Rodríguez-Guerra
There might be a CDN sync issue. Does it appear on the results of conda search?
1 reply
Dave Clements
Hi all, Minutes for the conda Community Call (starting in 10 minutes) are here
Jacob Barhak
I am having issues with installing an old package on windows that used to install well and I can no longer install it - I wonder what is the problem - it used to work and no longer works. This is anaconda 2 based and uses python 2 yet it does no longer install even with an older anaconda - here is the command I am using conda install mist -c jacob-barhak - here is the error I am getting CondaMultiError: CondaHTTPError: HTTP 404 NOT FOUND for url <https://conda.anaconda.org/jacob-barhak/win-64/win-64\inspyred-1.0-py27_0.tar.bz2> - can anyone with a windows machine can try to verify this is what they get...
I looked the anaconda cloud and the file is there. see: https://anaconda.org/jacob-barhak/inspyred I changed it access to public yesterday since I though it will be a source for the error, yet it seems the problem is elsewhere now...
Jacob Barhak
I located someone else who seemed to have a problem like mine and was no answered on stackoverflow: https://stackoverflow.com/questions/59335034/condahttperror-http-404-not-found-for-dask-core-2-7-0-py-0-tar-bz2
does anyone have any clue on why old packages cannot be located anymore?
Jacob Barhak

I also tried conda install inspyred -c jacob-barhak separately - it seems the problem is with this specific package and it is either a conda error or a cloud flare error since there is CF message attached to the http error. Here is how it loos like:

Downloading and Extracting Packages
inspyred-1.0         | 78 KB     |                                                                              |   0%

CondaMultiError: CondaHTTPError: HTTP 404 NOT FOUND for url <https://conda.anaconda.org/jacob-barhak/win-64/win-64\inspyred-1.0-py27_0.tar.bz2>
Elapsed: 00:00.423906
CF-RAY: 74c04c37b9b174a1-LHR

An HTTP error occurred when trying to retrieve this URL.
HTTP errors are often intermittent, and a simple retry will get you on your way.

Is there a way to tell if this is a conda issue or a cloud flare issue?

1 reply
Dave Clements
Hi All, a draft conda Discourse Forum is now up. See GitHub for the announcement, and for the call for help. My hope is to make this live by the end of September. Please provide feedback in GitHub or here. Thanks.
Dave Clements
🚀 We are elated to announce the release of #conda 22.9.0, the first version following CEP 8 (Conda Enhancement Proposal) in our new bi-monthly release cycle.
Dave Clements
We are (also!) pleased to announce that the conda Community Forum is now open. Questions, answers, discussions, and news about the conda ecosystem. It is (or will be!) all here.