Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 28 16:55
    javierm assigned #4200
  • Oct 28 16:49

    javierm on master

    Use labels for banner `web_sect… Group collection of checkboxes … Merge pull request #4200 from r… (compare)

  • Oct 28 16:49
    javierm closed #4200
  • Oct 28 16:07
    Senen review_requested #4200
  • Oct 28 15:45
    Senen synchronize #4200
  • Oct 28 12:05
    javierm assigned #4208
  • Oct 28 12:04
    javierm assigned #4206
  • Oct 28 11:34

    javierm on master

    Don't redirect when toggling vi… Hide checkbox when investments … Merge pull request #4212 from c… (compare)

  • Oct 28 11:34

    javierm on fix_ajax_redirect

    (compare)

  • Oct 28 11:34
    javierm closed #4212
  • Oct 28 11:24
    taitus assigned #4217
  • Oct 28 11:17
    taitus assigned #4212
  • Oct 28 11:15
    Michael1337 commented #4223
  • Oct 28 11:11
    Senen edited #4200
  • Oct 28 11:09
    Senen review_requested #4200
  • Oct 28 10:45
    javierm commented #4223
  • Oct 28 10:35
    Senen synchronize #4200
  • Oct 28 10:28
    javierm labeled #4224
  • Oct 28 10:28
    javierm commented #4224
  • Oct 28 08:28
    decabeza edited #4222
Leo Giovanetti
@leog
Hola Senén! Si puedes mandarme una invitación del Slack a lgiovanetti@partidodigital.org.uy te lo agradecería mucho. Tenemos interés en usar Consul para nuestra organización 👍
Senén Rodero
@Senen
Hola @leog, ya he enviado la solicitud a los administradores del canal (yo no lo soy) y en cuanto la acepten deberías recibir una notificación en ese correo electrónico. Nos vemos allí en breve 🤗.
Leo Giovanetti
@leog
Recibido, muchas gracias @Senen 👍
ivanmagdaleno
@ivanmagdaleno
Muchas gracias @Senen, muy potente y muy interesante consul, nos hemos juntado un equipo y ya estamos con ello desde hace unos meses, ahora nos estamos pegando con despliegues en producción, pero de momento sin dudas :)
Senén Rodero
@Senen
Genial @ivanmagdaleno, si necesitáis ayuda aquí estamos o preferiblemente en el espacio de trabajo de Slack (https://consul.slack.com/). Avísame si necesitáis invitaciones para el canal de Slack. Saludos y suerte 💪🏼
ivanmagdaleno
@ivanmagdaleno
@Senen Pues si vendria bien, mi correo es ivan.magdaleno@aeioros.com
Senén Rodero
@Senen
Solicitud enviada y ya aprobada por los administradores del canal, deberías recibir un email y tener acceso a 2 canales #general y #tech-questions. @ivanmagdaleno .
Kodeeswaran
@kodi1981
Am working with vsphere Consul deployment and referring this document to auto join the cluster...https://www.consul.io/docs/agent/cloud-auto-join.html#vsphere. what's is Best practice and methods to keep the password in an encrypted way. Because I have assigned the vsphere password as a variable under the /etc/environment. The consul service is getting exposed the password when I do ps - ef | grep consul. Consul version am using here is 1.2.2.. any one help me on this
Senén Rodero
@Senen
Hi @kodi1981 you are probably looking forthe Hashicorp Consul project: https://gitter.im/hashicorp-consul/Lobby
ernestogarj
@ernestogarj
Hola Buenos días a todos tengo un pequeño problemilla con consul lo he conseguido instalar usando installer en un servidor ubuntu 18.04 y funciona correctamente pero cuando reinicio el servidor aparece en la web error 502 bad gateway y deja de funcionar, he comprobado que tanto nginx y Postgrest esten ejecutandose que podria hacer?
ernestogarj
@ernestogarj
deploy 22347 0.8 6.9 418712 141764 ? Sl 11:47 0:01 puma 4.3.1 (unix:///home/deploy/consul/current/tmp/sockets/puma.sock)
deploy 22351 3.2 10.1 1093720 208372 ? Sl 11:47 0:06 puma: cluster worker 0: 22347
deploy consul_production ::1(60804) idle
deploy 23328 0.0 6.8 757692 141300 ? Sl 11:49 0:00 puma: cluster worker 1: 22347
he podido comprobar que cuando se reinicia esos proceso con el usuario deploy no estan iniciados no se si podria venir por ahi el problema
Senén Rodero
@Senen
Hola, @ernestogarj , efectivamente si puma no está arrancado la web no se va a servir. Deberías poder arrancar manualmente puma con capistrano “cap production deploy:start”. Espero noticias tuyas para ver como te ha ido 🤞🏼
ernestogarj
@ernestogarj
Hola @Senen muchas gracias he probado el comando que me comentas pero me indica la consola lo siguiente ""<<cap>> no esta instalado puede instalarlo escribiendo apt install capistrano"
lo curioso es que tambien lo indica cuando la web funciona
Senén Rodero
@Senen
¿En que directorio del servidor estás ejecutando el comando “cap"?
ernestogarj
@ernestogarj
en /root
Senén Rodero
@Senen
Me imagino que has seguido el video tutorial “How to setup CONSUL for a production environment”. ¿Cierto?
ernestogarj
@ernestogarj
@Senen si correcto junto con los pasos de github que hay en la pagina del installer la version de ubuntu use la recomendada tambien 16.04 que me equivoque antes
Senén Rodero
@Senen
ok, genial! Si vas más abajo en la documentación verás que hay otro video “How to setup Capistrano”. Esto es imprescindible para tener la herramienta capistrano (comando cap) para poder reinicar comodamente y subir nuevas versiones de Consul
ernestogarj
@ernestogarj
@Senen ok entonces voy a intentar seguir el video de cap a ver si se soluciona
Senén Rodero
@Senen
Te lo recomiendo, te facilitará la vida en adelante. Yo ahora me tengo que marchar un par de horas, pero si te encuentras problemas y quieres compartirlos por aquí les daré un vistazo cuando esté de vuelta. Mucha suerte 💪🏼
ernestogarj
@ernestogarj
Muchas Gracias @Senen te comentare que tal fue
ernestogarj
@ernestogarj
Hola Buenas @Senen consigue solucionar el problemilla que tenia ayer muchas gracias, queria hacerte una consulta ¿A que suele ser debido que tras registrar un usuario nuevo aparezca error 500? Aunque el usuario se genera bien
ernestogarj
@ernestogarj
He podido ver que es relacionado con el envio de correo he seguido el tutorial para ello el falo es que el servidor que yo utilizo para enviar correos es un servidor local dentro de mi red y no requiere autenticación directamente cualquier correo que le llega lo envia, ¿Como podria especificar que no utilice login en el fichero de configuración?
Senén Rodero
@Senen
Hola @ernestogarj , antes de nada disculpa por la espera, me han dejado de llegar notificaciones de Gitter, he tu comentario de milagro ... Asegurate de que delayed_jobs está corriendo en la máquina, me explico: Delayed Jobs se encarga de la ejecución de procesos en segundo plano y todos los emails de Consul se envian en segundo plano así que es estrictamente necesario tener tanto el servidor web (puma o unicorn) y el servicio delayed_jobs corriendo en el servidor para que la aplicación funcione correctamente. A ver si esto te sirve de ayuda.
Mauro Quinteros Prosperi
@mauroprosperi
Hola a todos! Mi consul no envia el correo de verificacion, usé el consul/consul y no el installer, hay algun problema con eso? mil gracias!
Mauro Quinteros Prosperi
@mauroprosperi
Vi que salió una nueva version de consul, hay documentacion o guia de esta ? creo que voy a intentar instalarla pero la documentacion desvia mucho y no es muy certera!
Senén Rodero
@Senen

Hola @ernestogarj , disculpa por la espera🙏🏼

¿Conseguiste arreglar el problema de configuración de tu correo electrónico? Si sigues teniéndolo y para ayudarte mejor me vendría bien que me respondieras a unas preguntas:

  1. ¿Qué versión de Consul que estás usando?
  2. ¿Has usado el instalador ( consul/installer) para montar tu servidor de producción?
Alexander
@WertND
Hi to all!
I have a question.
I have app service with http and grpc, and application open two ports - for grpc and for http. I want to register that app in consul. What is best practies way to register appliction with multiply ports?
Ochiu Cristi
@cristi.ochiu_gitlab
Translations. I have a question about a translation. We are working right now to translate Consul in Romanian. My question is ... what are the next steps after we will finish the translation so we can use it on our site?
Senén Rodero
@Senen
Hi @WertND , you are probably looking forthe Hashicorp Consul project: https://gitter.im/hashicorp-consul/Lobby
Hi @cristi.ochiu_gitlab , if you cannot wait for next Consul release i would recommend to download Romanian translations directly from Crowdin and add it to your Consul's fork. If you find any problem by doing this please ask us and will try to help you.
Senén Rodero
@Senen
Hola @mauroprosperi, estamos trabajando en mejorar la documentación ya que como dices hay algunas cosas que no están del todo actualizadas … :sweat_smile: Mientras tanto si necesitas soporte con temas que no encuentras en la documentación podemos mandarte una invitación al canal de Slack donde podremos hablar de una forma más cómoda. Si te animas pasame tu email por privado! Saludos y disculpa por la espera :pray:
Mehdi BRAHIMI
@bidHimArm

Hello Community,

I'm know nothing about ruby and I'm a noob in app development. I've created a deployment on a production server for my fork and started configuring the smtp with sendgrid (tried also with mailgun). I'm adding my sendgrid credentials to the secrets.yml, then restarting the prod server, and registering a new account, I land on the "Confirm your email address" page, but I receive no email. It seems that my app doesn't work.

Also even before configuring the smtp credentials I landed on the "Confirm your email address" page and not the Error 500 one.

Anyone for a help ?

Senén Rodero
@Senen

Hi @bidHimArm, thanks for trying Consul.

Did you look for lost emails at spam folder? Probably you have to whitelabel your smtp configuration to send emails from your domain through Sendgrid or MailGun servers.

Here is an article that will help you to whitelabel your Sendgrid configuration so your application emails are not considered as spam.
https://sendgrid.com/docs/glossary/whitelabel/

We have a Slack channel for technical questions where you would find answers for the most common problems. Past week other user had the same problem you have so probably you can get useful feedback if you decide to join. If you are interested in joining please send me an email address through a private message. 🤗

rashmiagar
@rashmiagar
Hello,
I am trying to setup Consul on heroku and I ran the dev_seeds. I have question about the public/systems folder
the production is not displaying the correct images
rashmiagar
@rashmiagar
Anyone can help?
Also have more questions about heroku installation. Is heroku recommended for use in production or only for demo purposes? And for heroku I am configuring it manually. Or should I be using the installer? I am getting <Rack::Timeout::RequestExpiryError: Request older than 30000ms.
rashmiagar
@rashmiagar
I am tasked with setting up Consul for Belgium’s municipalities. Is the multi tenancy feature been implemented?
Senén Rodero
@Senen

Hi @rashmiagar 👋, you can run Consul in Heroku but Heroku does not allow to store uploaded files on their own servers, you have to use an external storage for uploaded files like AWS S3 service.

You can use Heroku as production environment but there is no need to use Consul installer there. You are doing ok by doing it manually.

Multitenant is not a feature implemented yet but i think there is some people working on it, but not sure when it would be ready and included in a new Consul release. Here [1] is a starter pull request in this direction, maybe you can give it a 👍🏼.

Regarding the Timeout error, it would be helpful if you paste a more extense log from heroku. You can get it by running heroku logs from the command line. Which page is throwing this error?

[1] consul/consul#4030

Senén Rodero
@Senen
rashmiagar
@rashmiagar
alt
rashmiagar
@rashmiagar
This is detail of requestexpiryerror I got, even though the request I made was current and not a old one. I guess its related to rack_timeout gem but I set the RACK_TIMEOUT_SERVICE_TIMEOUT env variable to 20 in heroku.
Then I set Rails.application.config.middleware.insert_before Rack::Runtime, Rack::Timeout, service_timeout: 0 in rack_timeout.rb initializer, since then I am not getting error.
But not sure if its best way
@Senen
rashmiagar
@rashmiagar
And thanks so much for reply! :)