Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    rick
    @rick:rmendes.net
    [m]
    quand j'active
    iptables_chains:
    • DOCKER-USER
    c'est là que j'ai mon ip table init problème
    j'ai suivi https://crowdsec.net/blog/secure-docker-compose-stacks-with-crowdsec/ pour ajouter crowdsec à mes dockers qui tourne
    rick
    @rick:rmendes.net
    [m]
    si je commente la ligne - DOCKER-USER le service ne démarre toujours pas, mais l"erreur iptable n'est plus
    blotus
    @blotus
    hello
    @rick:rmendes.net juste pour confirmer, le bouncer tourne bien sur le host et non dans un container ?
    rick
    @rick:rmendes.net
    [m]
    correct @blotus
    voici le log du service : https://paste.armada.digital/uzedurikoc.pl
    blotus
    @blotus
    est-ce que tu pourrais aussi nous donner les logs du bouncer lui meme ?
    rick
    @rick:rmendes.net
    [m]
    comment je récupère ceux la ?
    AlteredCoder
    @AlteredCoder
    ils sont dans /var/log/crowdsec-firewall-bouncer.log
    blotus
    @blotus
    et quand tu lances ipset list, tu vois bien le set ou pas ?
    rick
    @rick:rmendes.net
    [m]
    j'ai pas ipset
    blotus
    @blotus
    ah ba voila :)
    coh7eiqu8thaBu
    @coh7eiqu8thaBu
    \o/
    rick
    @rick:rmendes.net
    [m]
    je me trome
    trompe
    je pensais que j'étais basé sur iptables
    mais ipset list me renvoie
    coh7eiqu8thaBu
    @coh7eiqu8thaBu
    si tu as une liste de plus de 2500 ip c'est que c'est bon
    rick
    @rick:rmendes.net
    [m]

    root@:/home# ipset list
    Name: crowdsec-blacklists
    Type: hash:net
    Revision: 6
    Header: family inet hashsize 1024 maxelem 65536 timeout 300
    Size in memory: 448
    References: 2
    Number of entries: 0
    Members:

    Name: crowdsec6-blacklists
    Type: hash:net
    Revision: 6
    Header: family inet6 hashsize 1024 maxelem 65536 timeout 300
    Size in memory: 1232
    References: 1
    Number of entries: 0
    Members:

    blotus
    @blotus
    ok donc le set existe bien
    coh7eiqu8thaBu
    @coh7eiqu8thaBu
    mais il est vide
    rick
    @rick:rmendes.net
    [m]
    et voila le log du bouncer
    plusieurs problème du coup
    je suis pas auth auprès de la local api
    cscli config show me donne
    docker-compose exec crowdsec cscli config show
    Global:
    • Configuration Folder : /etc/crowdsec
    • Data Folder : /var/lib/crowdsec/data
    • Hub Folder : /etc/crowdsec/hub
    • Simulation File : /etc/crowdsec/simulation.yaml
    • Log Folder : /var/log/
    • Log level : info
    • Log Media : stdout
      Crowdsec:
      • Acquisition File : /etc/crowdsec/acquis.yaml
      • Parsers routines : 1
        cscli:
      • Output : human
      • Hub Branch :
      • Hub Folder : /etc/crowdsec/hub
        Local API Server:
      • Listen URL : 0.0.0.0:8080
      • Profile File : /etc/crowdsec/profiles.yaml
      • Database:
        • Type : sqlite
        • Path : /var/lib/crowdsec/data/crowdsec.db
        • Flush age : 7d
        • Flush size : 5000
    blotus
    @blotus
    tu pourrais mettre le bouncer en mode debug ?
    on aura l'output des commandes ipset comme ca
    et pour l'erreur d'auth, c'est que ton crowdsec ne tourne probablement pas, tu te prends un connection refused
    (ca peut etre crowdsec qui ne tourne pas, un mauvais port ou une mauvaise IP)
    pour passer le bouncer en debug, modifie la ligne log_level dans son fichier de conf et met debug
    1 reply
    rick
    @rick:rmendes.net
    [m]
    done
    mon crowdsec tourne dans son container, si il tournait pas, je pourrais pas avoir ceci je pense
    blotus
    @blotus
    ok
    tu as bien expose le port de crowdsec sur le host ?
    rick
    @rick:rmendes.net
    [m]
    c'est mon container crowdsec
    et mon container metabase
    blotus
    @blotus
    ok donc faut que tu exposes le port de crowdsec (8080) sur ton host
    ton bouncer est configure pour taper sur localhost, mais comme le port du container est pas expose, ca pourra pas marcher
    rick
    @rick:rmendes.net
    [m]
    raahhhh
    touché
    le port 8080 était fermé
    blotus
    @blotus
    je pense que tu vas aussi devoir modifier la maniere dont le container est lance pour exposer le 8080
    rick
    @rick:rmendes.net
    [m]
    je viens de le faire