Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    rick
    @rick:rmendes.net
    [m]
    mon crowdsec tourne dans son container, si il tournait pas, je pourrais pas avoir ceci je pense
    blotus
    @blotus
    ok
    tu as bien expose le port de crowdsec sur le host ?
    rick
    @rick:rmendes.net
    [m]
    c'est mon container crowdsec
    et mon container metabase
    blotus
    @blotus
    ok donc faut que tu exposes le port de crowdsec (8080) sur ton host
    ton bouncer est configure pour taper sur localhost, mais comme le port du container est pas expose, ca pourra pas marcher
    rick
    @rick:rmendes.net
    [m]
    raahhhh
    touché
    le port 8080 était fermé
    blotus
    @blotus
    je pense que tu vas aussi devoir modifier la maniere dont le container est lance pour exposer le 8080
    rick
    @rick:rmendes.net
    [m]
    je viens de le faire
    blotus
    @blotus
    parfait, ca devrait au moins corriger les erreurs de connection refused
    (au passage, si t'es en setup mono-machine, je te recommande d'exposer le port que sur 127.0.0.1, ca evite les blagues potentielles :))
    rick
    @rick:rmendes.net
    [m]
    je suis en multi-containers
    ce serveur fait tourner funkwhale en fait
    hmm que veut tu dire par mono-machine ?
    blotus
    @blotus
    si tu n'as pas d'autres serveurs qui vont venir taper l'API de crowdsec
    rick
    @rick:rmendes.net
    [m]
    en principe non
    blotus
    @blotus
    et du coup, les logs du bouncer racontent quoi maintenant ?
    rick
    @rick:rmendes.net
    [m]
    dès que j'active - Docker-User j'ai des iptables init failed
    en le commentant
    j'arrive enfin à démarrer le service sans encombre
    blotus
    @blotus
    oooooh attends
    je crois savoir :)
    docker ne supporte pas IPv6
    et donc la chaine DOCKER-USER n'existe pas dans la config ip6tables
    passe disable_ipv6 a true dans la config du bouncer
    rick
    @rick:rmendes.net
    [m]
    ok service restarté
    et ipv6 désactivé
    ouf
    les metrics affichent mon bouncer enfin
    blotus
    @blotus
    cool !
    rick
    @rick:rmendes.net
    [m]
    je crois que c''est bon la
    à
    blotus
    @blotus
    yes :)
    tu peux faire un ipset list pour confirmer
    mais tu devrais avoir plein d'IPs dedans
    rick
    @rick:rmendes.net
    [m]
    c'est le cas
    bon du coup, mon gros soucis c'était la règle - Docker-User pour iptable qui n'existe pas sans ipv6
    et le disable-ipv6 qui etait en false
    en tout cas merci @blotus