Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Oct 24 21:29
    henil9891 opened #8962
  • Oct 24 19:59
    stoplion edited #8961
  • Oct 24 19:59
    stoplion edited #8961
  • Oct 24 19:59
    stoplion edited #8961
  • Oct 24 19:58
    stoplion opened #8961
  • Oct 24 18:54
    bjowes commented #4625
  • Oct 24 13:42
    brkreddy06 opened #8960
  • Oct 24 05:29
    davidmh synchronize #8453
  • Oct 23 22:31

    JessicaSachs on evergreen

    testing out monkeypatch of cy.c… (compare)

  • Oct 23 22:17
    CLAassistant commented #8959
  • Oct 23 22:17
    cypress-bot[bot] unlabeled #8714
  • Oct 23 22:17
    cypress-bot[bot] labeled #8714
  • Oct 23 22:17
    CLAassistant commented #8959
  • Oct 23 22:17
    cypress-bot[bot] commented #8959
  • Oct 23 22:16
    gvdp opened #8959
  • Oct 23 21:48
    renovate[bot] edited #3777
  • Oct 23 21:43
    milan-easykad commented #8146
  • Oct 23 21:38
    milan-easykad opened #8958
  • Oct 23 20:20
    haug1 opened #8957
  • Oct 23 19:44
    todd-m-kemp edited #8954
Victor Aprea
@vicatcu
We get this sort of thing a lot in the CLI
Timed out retrying: expected '<span.ng-value-label>' to be 'visible' This element `<span.ng-value-label>` is not visible because it has CSS property: `position: fixed` and it's being covered by another element: `<div class="ng-input">...</div>`
Kalaivanee Ramsekar
@kalaivanee.r88_gitlab
can someone help me how to get the value of the property from the response in cypress?
Victor Aprea
@vicatcu
I have elaborated and posted my comments above in a Stack Overflow post here: https://stackoverflow.com/questions/63384937/how-to-avoid-cypress-flakiness-using-ng-select-elements
any help or suggestions from the Cypress team and community would be greatly appreciated
:pray:
Nagimagi
@Nagimagi
hello, it works with postman, but threw 500 server error on cypress test. How come?
and why can't I sent a picture...
Nagimagi
@Nagimagi
cy.request() failed on:
url
The response we recieved from your web server was:
500 : Server Error
Mikail Kilic
@Mikail184_gitlab
Does anyone else have the issue since upgrading to 4.12.1 that submitting a form doesn't work? Its working fine with 4.11
Max Savchuk
@max.savchuk_gitlab
Hi, could anyone please explain why 'You cannot assign or work with the return values of any Cypress command. Commands are enqueued and run asynchronously.' (from Doc)
and why the below code doesn't work as expected.
const inputField = cy.get('[data-cy=inputField]')
inputField.type('text')
Sam Grönblom
@sgronblo
Has anyone seen the problem of Cypress reporting an error for an "after each" hook, even if you are not using any "after" hooks at all?
Mikail Kilic
@Mikail184_gitlab
cy.get('[data-cy=inputField]').then(input => {
    // Use cy.wrap to use Cypress comands again otherwise use jQuery
    cy.wrap(input).type('text')
})
that should do your job @max.savchuk_gitlab
Max Savchuk
@max.savchuk_gitlab
@Mikail184_gitlab thanks for the answer, i will try to use this
4 replies
sudheer-cypress
@sudheer-cypress
i am supposed to generate a report from UI. But i am not sure how much time it takes to download.So in this situation i just cant set wait time .Can any one suggest the ideal way to achieve this?
Mikail Kilic
@Mikail184_gitlab
go to your console and in network, and clear the history and generate the report to see where it comes from, after that use cy.request()
         cy.request({
            method: 'GET',
            url: ''
        })
vadymstroiu
@vadymstroiu

Hi. Is it possible to make a list of opened tabs?
The case is:

  1. I click on a button
  2. It generates the link and opens it in a new tab
  3. I have to navigate to this page and do some verifications

In case that Cypress does not support multi-tabs. It would be good to have a list of the opened tabs. So I can navigate to them.

Peter Scott
@peterscottsa
Does anyone know how to use EventSource? I can see support was added for it but there is no documentation to speak of.
I am trying to follow the example here cypress-io/cypress#2747 but no luck unfortunately
Ondskan56
@Ondskan56
Hey all, the issue with '.get' that scrolls the screen is really annoying and it seems that it hasn't been fixed since 2017.
Is this on the roadmap? Are you aware of this issue and you think on a solution? any feedback is appreciated
cypress-io/cypress#871
I tried some of the workaround and they work on some of my tests but they don't work on all of them.
I find it really difficult using Cypress with this issue.
AJRobson1
@AJRobson1
Can someone help me debug an issue? The last couple of days my tests have been failing because when I click a button to submit a login form the page just reloads with an empty form. I can't reproduce this manually and nothing in the tests or application code as changed since the issue started
6 replies
Anas Fitiani
@anas-qa
Did anyone notice that execution speed decreased after upgrading to 4.12?! weird one right?
sudheer-cypress
@sudheer-cypress
Need help badly,a file downloads to my local after clicking on it from UI using cypress.I want my test to end there itself.But cypress keeps on waiting to load a new page .Pls help
Patrick Schaub
@pschaub
@sergom13_twitter we also have heavy problems here with the scroll behaviour stuff in cypress. would really like to disable it. somehow the workarounds are not working for us. Anybody can help here?
raddy83
@raddy83
Hi, I'm working with Windows 10( Cypress: 4.11.0 and Browser: Chrome 84). When I'm trying to run test on Electron then everything is ok, but when I try to run tests with Chrome then Cypress is opening window with my application url ( url from baseURL - > e.g https://application-directory.com)), but other parameters from cy.visit('?/client_no=1003') gone.
jameseg
@jameseg
anyone have a way to deal with code coverage for parallel runs? I.E., in pipelines, it tries to write the same file from the config for each machine...
virtualcorsair
@virtualcorsair

Hello - I would like to understand how I can assert data in a pdf file? Basically, the file is already downloaded.
I have tried assertions in the callback loop, but cypress seems to skip it.

Here is my setup:

\plugins\index.js

const parsePdf = async (pdfName) => {
const pdfPathname = path.join(repoRoot, pdfName)
let dataBuffer = fs.readFileSync(pdfPathname)
return pdf(dataBuffer);
}

module.exports = (on, config) => {
on('task', {
getPdfContent (pdfName) {
return String(parsePdf(pdfName))
}
})
Test File "admin.reports.spec.js"

import LoginPageObjects from "../../support/pageObjects/common.pageObjects/login.pageObjects";
import ReportsDelegateReportPageObjects
from "../../support/pageObjects/common.pageObjects/reports.delegateReport.pageObjects";

import(LoginPageObjects);
import(ReportsDelegateReportPageObjects);

const loginPage = new LoginPageObjects();
const reportsPage = new ReportsDelegateReportPageObjects();

describe('Delegate Report Functionality', function (){

beforeEach(() => {
    // Provides admin credentials
    loginPage.getAdminLogin();
    // Navigates to Report Menu, Selects Report, Downloads PDF report.
    reportsPage.getMenuReport();
});

it('should return the report and verify the data in it', function () {
    cy.readFile('C:/Users/$user/Downloads/delegate_report.pdf', 'base64').should('contain.value', "Report")
});

});

1 reply
Max Savchuk
@max.savchuk_gitlab
@vadymstroiu maybe this will be useful for you: from cypress recipes
6 replies
abelmilash
@abelmilash
Hi. In my integration tests, I am visiting a page and making assertions about the contents (texts and table) displayed. After cy.visit('the url to visit'), Cypress loads all the contents in the page except for the table. If I do something like: cy.visit("the url to visit").wait("1000"), I see the contents of the table displayed, but I want to find other ways of doing this since wait("time") is described as anti-pattern. Any ideas on this?
Hemant Choudhari
@hemantc09
Hi All,
does anyone successfully completed OKTA login to react app using cypress? I found few solution but Im still getting OKTA screen .Even though I received the 200OK and 302 response. I really appreciate your help.
arawnsantos10
@arawnsantos10
Hello,
I am trying to exit the loop when my conditions are met but the each loop doesn't stop even if the condition are met
var loop = false; scorecardreview.employeeListItem().each(($e1, index, $list)=> { cy.wrap($e1).find('[datacy=statusStat]').invoke('text').then(text=>{ if(index >= 0 && text.trim() === 'No Scorecard' { cy.wrap($e1).find('.fa-ellipsis-h').click(); scorecardreview.assignScorecard().click() ; return false ; } }) })
Gleb Bahmutov
@bahmutov
@jameseg you would need to combine them yourself, which is not ideal
2 replies
learnuser
@learnuser
Hi All, is there a way bypass waiting for page load event?
Eduardo Del Balso
@edelbalso
Hi folks, I'm in a situation where if I do a cy.get('some-lookup').whithin(() => return cy.get('some-other-lookup')).should('contain','some-val'), but if I do 2-3 right after each other, only the first works and the subsequent ones fail. If I comment out the first one, then the second one works but third onwards fails, if I comment third, fourth works but fifth fails, etc... basically only the first one works and I'm not sure why
Sidharth LaLa
@SidharthLala1
image.png

ERROR: Failed to merge reports

SyntaxError: cypress/report/mochawesome-report/seelgo_report.json: Unexpected end of JSON input

Guys any idea why i am getting this error when i am performing mochawesome-merge
Mirza Chilman
@MirzaChilman
anyone experience cypress cannot cannot resolve ./commands cypress? my cypress somehow does not able to read custom command files
Flavia
@fzancanaro
This message was deleted
1 reply
nikkieta
@nikkieta
How to bypass login for login.microsoftonline.com in latest version of cypress. As even after bypassing it using token it still requires Active Directory login and gets refused to connect error.
6 replies
version i m using 4.10.1
Joakim
@Sefriol
Just a quick question: In cypress open, I can run all the tests from different files in same browser window/session. Any way to do this in cypress run? Now it seems to to launch a new window for each test file
4 replies
Eamonn Gahan
@edgahan
Hi all - I am using cypress parallel with gitlab runners with AWS autoscale and having trouble getting cypress to use more than one machine (Gitlab only sees one runner but there are 5 EC2 instances running). Has anyone got this setup working?