Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 18 13:38
    papajohn commented #414
  • Sep 18 05:53
    adnanhemani commented #414
  • Sep 18 01:11
    davidwagner opened #414
  • Sep 17 22:21

    adnanhemani on gh-pages

    Generated by commit 23b4f5f6482… (compare)

  • Sep 17 22:04

    adnanhemani on gh-pages

    Generated by commit 23b4f5f6482… (compare)

  • Sep 17 21:13

    davidwagner on fix_version_15_2

    (compare)

  • Sep 17 21:13

    davidwagner on master

    fixed bug from previous version CHANGELOG Delete top_movies.csv Accident… and 2 more (compare)

  • Sep 17 21:13
    davidwagner closed #413
  • Sep 17 20:37

    adnanhemani on gh-pages

    Generated by commit ec024b264ff… (compare)

  • Sep 17 20:32

    davidwagner on travis_doesnt_like_libgfortran

    (compare)

  • Sep 17 20:32

    davidwagner on master

    Try removing libgfortran depend… Merge pull request #412 from da… (compare)

  • Sep 17 20:32
    davidwagner closed #412
  • Sep 16 17:04
    SamLau95 commented #412
  • Sep 16 06:23
    adnanhemani commented #412
  • Sep 16 06:16

    adnanhemani on fix_version_15_2

    Delete hist_workout_2.ipynb Ac… (compare)

  • Sep 16 06:16
    adnanhemani synchronize #413
  • Sep 16 06:15

    adnanhemani on fix_version_15_2

    Delete top_movies.csv Accident… (compare)

  • Sep 16 06:15
    adnanhemani synchronize #413
  • Sep 16 06:09
    adnanhemani review_requested #413
  • Sep 16 06:09
    adnanhemani review_requested #413
Sam Lau
@SamLau95
do you have 0.3.dev21?
Chris Holdgraf
@choldgraf
I can confirm that @cboettig's code works on the latest version for me
Chris Holdgraf
@choldgraf
Also - quick quibble, but I often forget to open this package with python 3 sourced, and the error message you get for doing so is a bit cryptic (it just throws an import error)

think we could just put:

import sys
if sys.version_info < (3, 0):
    raise ValueError('This package requires python >= 3.0')

at the root __init__.py?

Sam Lau
@SamLau95
ah, that’s a good idea
Carl Boettiger
@cboettig
@SamLau95 yup, running on ds8.berkeley.edu and it says '0.3.dev21'
Chris Holdgraf
@choldgraf
@SamLau95 want me to make a PR?
Carl Boettiger
@cboettig
It's very strange. I have in my git history successful runs of the notebook with the very same code that works with multiple columns, so I'm not sure why it is failing for me now.
Chris Holdgraf
@choldgraf
hmm, that is weird - and it works for me
problem is I can't really debug it w/o the code breaking for me
maybe just to be sure you can pull the latest changes from the git repo
Sam Lau
@SamLau95
@choldgraf that’d be great
Carl Boettiger
@cboettig
Chris Holdgraf
@choldgraf
@SamLau95 hrmmm, actually it might be more complicated
because it looks like some of the changes actually result in a syntaxerror in 2.7
so it won't get to the point that it's running any code
perhaps a better option would be to prevent it from installing on any versions of python < 3.0?
Sam Lau
@SamLau95
ah i see
would you like to look into that?
if not, feel free to make an issue
Chris Holdgraf
@choldgraf
@cboettig so it looks like the problem is that the function is passing a list of column names to the table. E.g., this returns the same error you get:
t[['letter', 'count', 'points']]
and it looks like that function has indeed been updated. Here's the new code for it: np.array([fn(*[self.take(i)[col][0] for col in column_label]) for i in range(self.num_rows)])
note that there is another for loop: for col in column_label so now it's passing each column that you give individually, that way it never tries to pass a list
so try pulling and it should work
Carl Boettiger
@cboettig
interesting... so somehow I am running an old version of datascience even though it says 0.3.dev21 ?
I'm running this on ds8.berkeley.edu, so I have no ability to install there, but let me try locally. What version are you on?
Chris Holdgraf
@choldgraf
ah interesting
same version
but w/o knowing much about how the repo is organized, that's probably just the current dev branch
and presumably the version of that code being used in ds8 is a few commits behind the branch on github
Carl Boettiger
@cboettig
maybe version number didn't get bumped;
right.
um, so can you reproduce the error on your ds8.berkeley.edu account?
(and I'll try pulling and installing locally)
Chris Holdgraf
@choldgraf
I.......haven't figured that out yet :)
Carl Boettiger
@cboettig
hehe, what happens when you go to ds8.berkeley.edu and try to log in with your berkeley google account?
Chris Holdgraf
@choldgraf
ooo it works
Carl Boettiger
@cboettig
nice
Sam Lau
@SamLau95
oh, you know what?
it’s possible that we haven’t pushed a new version to the servers
i mean
we haven’t incremented the version number after making that change
Carl Boettiger
@cboettig
right
Sam Lau
@SamLau95
blah, that’s a pain
maybe there’s a way to locally install the datascience package from the github repo on ds8
Chris Holdgraf
@choldgraf
yeah I get the error on the ds8 servers
Sam Lau
@SamLau95
that makes sense
Chris Holdgraf
@choldgraf
I mean, could you theoretically just glone the datascience repo using a terminal in the ipyntbk and then make install from there?
Sam Lau
@SamLau95
yeah, that might work
i have to bother ryan manually to update the package version on the ds8 server so it’s not something i can take care of right this minute