Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Mike Sheldon
    @Elleo
    heya, what's the problem you're running into?
    dataassistant
    @dataassistant
    Debian Installation instructions from scratch draft. Please correct me as we go along:
    Are there any Debian pre-requsits that need to be installed via apt-get?
    cd /home/lucas/projects/
    1. git clone https://github.com/Elleo/gst-deepspeech.git
    dataassistant
    @dataassistant
    cd gst-deepspeech
    dataassistant
    @dataassistant
    I already have build essentials:
    sudo apt-get install build-essential
    (If you get the following, which it says todo in the install file):
    --I get the following:
    --in projects/gst-deepspeech/
    ./configure
    bash: ./configure: No such file or directory
    --I think we need to do :
    ./autogen.sh

    checking pkg-config is at least version 0.9.0... yes
    checking for GST... no
    configure: error:
    You need to install or upgrade the GStreamer development
    packages on your system. On debian-based systems these are
    libgstreamer1.0-dev and libgstreamer-plugins-base1.0-dev.
    on RPM-based systems gstreamer1.0-devel, libgstreamer1.0-devel
    or similar. The minimum version required is 1.0.0.

    configure failed

    sudo apt-get install libgstreamer1.0-dev and libgstreamer-plugins-base1.0-dev
    dataassistant
    @dataassistant
    --this completes successfully , we are are ready for make
    Now type 'make' to compile this module.
    --Getting this error:
    /bin/bash ../libtool --tag=CXX --tag=disable-static --mode=compile g++ -DHAVE_CONFIG_H -I. -I.. -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -Wall -g -O2 -MT libgstdeepspeech_la-gstdeepspeech.lo -MD -MP -MF .deps/libgstdeepspeech_la-gstdeepspeech.Tpo -c -o libgstdeepspeech_la-gstdeepspeech.lo test -f 'gstdeepspeech.cc' || echo './'gstdeepspeech.cc
    libtool: compile: g++ -DHAVE_CONFIG_H -I. -I.. -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -Wall -g -O2 -MT libgstdeepspeech_la-gstdeepspeech.lo -MD -MP -MF .deps/libgstdeepspeech_la-gstdeepspeech.Tpo -c gstdeepspeech.cc -fPIC -DPIC -o .libs/libgstdeepspeech_la-gstdeepspeech.o

    gstdeepspeech.cc:63:24: fatal error: deepspeech.h: No such file or directory

    include <deepspeech.h>

    dataassistant
    @dataassistant
    --looks like we will need to install
    deepspeach and DeepSpeech/native_client/
    cd /home/myusername/projects
    sudo apt-get install python3-virtualenv
    virtualenv -p python3 env_py3
    source env_py3/bin/activate
    pip install pip --upgrade
    pip install deepspeech
    --Now lets figure out how to install deepspeech native client
    dataassistant
    @dataassistant
    --looks like we will need to follow instructions here:
    https://github.com/mozilla/DeepSpeech#getting-the-code
    dataassistant
    @dataassistant
    tar -xzvf deepspeech-0.4.1-models.tar.gz
    dataassistant
    @dataassistant
    CPPFLAGS=-I/home/myusername/projects/DeepSpeech/native_client/

    In comment 27 you say I need path for LD_Library_path?

    Since there is no libdeepspeech-dev for debian just yet,,,where can I find it?
    (You’ll also need to point LD_LIBRARY_PATH to a compiled version of libdeepspeech.so)

    What do I do next?

    Mike Sheldon
    @Elleo
    yep, you just need to compile deepspeech yourself and point it at the resulting library, or you can pull a precompiled .so out of one of the python packages