These are chat archives for deployd/deployd

7th
Oct 2016
safaorhan
@safaorhan
Oct 07 2016 09:21

Hello friends!

Is it possible to setEncoding when querying collections

I tried to change ctx.res.outputEncodings but I couldn't see any changes in the response header
I also tried:
ctx.res._header = "Content-type: application/json; charset=utf-8";
but get error: [Error: Can't set headers after they are sent.]
Nicolas Ritouet
@NicolasRitouet
Oct 07 2016 09:32
@here hi Community, we would like to have your feedback on a potential 1.0.0 release: deployd/deployd#761
safaorhan
@safaorhan
Oct 07 2016 09:42
I support it :thumbsup:
Nicolas Ritouet
@NicolasRitouet
Oct 07 2016 09:45
@safaorhan thanks. How do you wish deployd to evolve? How do you see the future of Deployd?
you can answer in a private message if you prefer
safaorhan
@safaorhan
Oct 07 2016 09:51
I will answer here within a few hours
Nicolas Ritouet
@NicolasRitouet
Oct 07 2016 09:55
sure, take your time
Francesco
@FFrancesconi
Oct 07 2016 13:24
Hello everybody! I'm new to deployd (and so far loving it :) ) and looking for some help with an issue...
I am trying to use the dpd-s3 module and I installed it using NPM as suggested in the readme. The next step, according to the readme, is to set up my aws parameters "using the dpd dashboard", but I can't find anything related to modules and/or modules configuration on the dashboard
Am I missing something? Is there another dashboard page specifically for modules that I am not aware of? all I see on dpd dashboard is resources...
thanks in advance for any help you will be able to give me ;)
Andrei Alecu
@andreialecu
Oct 07 2016 14:17
@FFrancesconi you need to click the + button and add an S3 resource with a name
in the dashboard
you'll see the config options for the resource afterwards
Francesco
@FFrancesconi
Oct 07 2016 14:20
Oh ok, Will try immediately thanks ;)
Uhm... if I click "+" I only have two options "Collection" or "Users Collection"
maybe something is wrong with the npm installation?
Francesco
@FFrancesconi
Oct 07 2016 14:27
@andreialecu sorry forgot to mention you in the reply
;)
Nicolas Ritouet
@NicolasRitouet
Oct 07 2016 14:44
@FFrancesconi it looks like the dpd-s3 module hasn’t been correctly installed
how have you installed deployd?
are you using a package.json?
Francesco
@FFrancesconi
Oct 07 2016 14:51
@andreialecu nope, not using package.json. I ran npm install dpd-s3 that's all
hammadfauz
@hammadfauz
Oct 07 2016 15:02
@FFrancesconi you need to run that command in the same directory as your deployd project.
Francesco
@FFrancesconi
Oct 07 2016 15:02
@hammadfauz of course i did that ;)
matter of fact, in my project's module dir I can see dpd-s3 subdir
after installing
hammadfauz
@hammadfauz
Oct 07 2016 15:04
Did you stop and start deployd after installing?
Francesco
@FFrancesconi
Oct 07 2016 15:04
yep. stopped it before installing and started it afterwards
hammadfauz
@hammadfauz
Oct 07 2016 15:06
Usually any installed dpd- modules are automatically loaded when you start deployd..
Francesco
@FFrancesconi
Oct 07 2016 15:08
@hammadfauz I just tried to create a new project, entered the created dir, ran npm install in that dir, started deployd, and also in this new project I have no s3 option in dashboard, so it seems it is not something related to that specific project
hammadfauz
@hammadfauz
Oct 07 2016 15:09
You seem to have fine things correctly
Done*
Can you do npm remove dpd-s3
Francesco
@FFrancesconi
Oct 07 2016 15:10
@hammadfauz of course, will do it hang on
hammadfauz
@hammadfauz
Oct 07 2016 15:10
And install again? See if there were any errors during installation
Francesco
@FFrancesconi
Oct 07 2016 15:11
no error during install. Now i will start dpd and see if anything has changed on the dashboard
@hammadfauz same as before. npm gave no error, but I can't see any s3 option on dashboard
do you know if there is any way to check what modules are getting loaded?
hammadfauz
@hammadfauz
Oct 07 2016 15:15
What do you see when you click the add button next to resources in dashboard?
Francesco
@FFrancesconi
Oct 07 2016 15:16
@hammadfauz a dropdown with "Collections" and "Users Collection"
hammadfauz
@hammadfauz
Oct 07 2016 15:20
I am stumped. I hope someone else can help you with this.
Francesco
@FFrancesconi
Oct 07 2016 15:20
@hammadfauz thanks for trying, hopefully someone else will have an idea ;)
Andrei Alecu
@andreialecu
Oct 07 2016 15:32
@FFrancesconi run npm init in the folder
then npm install dpd-s3
then restart the app
Francesco
@FFrancesconi
Oct 07 2016 15:39
@andreialecu unfortunately, same result. I will try to reinstall deployd too...
Andrei Alecu
@andreialecu
Oct 07 2016 15:39
how are you running it?
also what OS are you on?
Francesco
@FFrancesconi
Oct 07 2016 15:41
@andreialecu on ubuntu 14.04, installed as a nodejs module
Andrei Alecu
@andreialecu
Oct 07 2016 15:42
are you using a run script or the dpd cli?
Francesco
@FFrancesconi
Oct 07 2016 15:43
@andreialecu the cli
@andreialecu tried to remove deployd and reinstalled it. then reinstalled the s3 mod. same result...
what should I see in the node_modules dir? only dpd-s3 subdir and no other directory, is that correct?
Francesco
@FFrancesconi
Oct 07 2016 16:34
I just tried installing dpd on my MacBook to see if it worked on a "fresh install". No luck, same results. Dpd works, but the s3 module is not loaded
exactly like on the linux box
hammadfauz
@hammadfauz
Oct 07 2016 18:27
@FFrancesconi I just tried this on my linux machine: dpd create s3Test
Then cd s3Test
Then, npm install dpd-s3
After that, I ran dpd
You can verify it works here: http://www.hammadfauz.com:2403/dashboard
It shows S3 bucket in the resources menu
TuxNetrunner
@TuxNetrunner
Oct 07 2016 18:51
@hammadfauz I will try again on a clean Linux vm
Francesco
@FFrancesconi
Oct 07 2016 19:03
@hammadfauz what version of DPD are you using? cause I just installed the latest (0.8.9), just wondering if on your linux box you have an older one...
(P.S.: for some reason the previous message written from my phone came from a different account but it's still me :) )
also, do you have dpd installed with -g option? (global)
hammadfauz
@hammadfauz
Oct 07 2016 19:14
I have a global copy of dpd installed. I am running 0.8.8
Francesco
@FFrancesconi
Oct 07 2016 19:26
I will try to install 0.8.8 just to make sure