Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Anton Medvedev
@antonmedv
Travis bot will no longer working
No travis-ci tests!
Tarjei Huse
@tarjei_twitter
Good morning. Any plans for a new version soon?
Salvatore Capritta
@scapritta
Hi everyone. Managing differents projects on different php versions. IS there any stable solution or version to use Deployer with old 5.6 or 7.0 projects?
Thanks everyone
Salvatore Capritta
@scapritta
ok, installing it via composer is auto-detecting. looks good ;)
Tom
@Lambik
hello, i too have an issue with deploy keys on github
i created one locally, then uploaded it to my server, and gave it access to my github private repo, but I probably need to do some more configuration work, because even when manually 'git clone'ing, I get an unauthorized
can one have multiple deployment keys on a server for github, and do they have to be created on the server itself?
Tom
@Lambik
resava
@resava
try to deploy on win server with error /c: /c: Is a directory. Someone with same expirience?
Ard2p
@Ard2p

Hello everyone, help solve the problem.
My server doesn't update paths for a long time

"\/var\/www\/user\/data\/www\/site\/backend\/releases\/11\/app\/Http\/Controllers"
"\/var\/www\/user\/data\/www\/site\/backend\/current" => "\/var\/www\/user\/data\/www\/site\/backend\/releases\/16\/app\/Http\/Controllers"

the server always sees the earliest version of the remote version
edvordo
@edvordo
I had the same problem, never managed to figure out what the problem was .. had to switch to just 1 kept version on the server ..
Ard2p
@Ard2p
I found what the problem is, OPcache
image.png
opcache_reset();
edvordo
@edvordo
I came across opcache ,tried the opcache_reset(), didn't help unfortunatelly
Paul Kamma
@X-Tender
Hi there, I have a gitlabCI task where I want to set a another deplyo file but no mater what I try he always use the default deploy.php file
  • vendor/bin/dep deploy ${CI_ENVIRONMENT_NAME} -f undo.php --tag=$CI_COMMIT_REF_NAME .. also tried --file=undo.php
image.png
Also got this errors :/
hershkoy
@hershkoy
I asked on stackoverflow a question about an issue that I have with deployer. If anyone has an idea how to fix, I would appreciate some help:
https://stackoverflow.com/questions/65287915/how-to-unlimit-php-deployer-composer-memory
edvordo
@edvordo
@X-Tender for the custom file I'd try debugging this portion of the code https://github.com/deployphp/deployer/blob/master/bin/dep#L38 .. tbh I'm not sure how it works without trying to run it myself, but I don't have a project with the lastest deployer on hand, so can't test myself ..

@hershkoy change this

set('composer', 'php -d memory_limit=-1  /usr/local/bin/composer');

to this

set('bin/composer', 'php -d memory_limit=-1  /usr/local/bin/composer');
hershkoy
@hershkoy
@edvordo It worked, Awesome! Do you want to answer in stackoverflow so it will be preserved for future generations?
edvordo
@edvordo
sure, why not :)
hershkoy
@hershkoy
I have another issue, btw:
In Process.php line 1203:
                                                                                                                                                                            [Symfony\Component\Process\Exception\ProcessTimedOutException]
  The process "ssh -A -o ControlMaster=auto -o ControlPersist=60 -o ControlPath=/home/ubuntu/.ssh/deployer_root@123.456.234.123:2222 -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no root@123.456.234.123  'bash -s; printf "[exit_code:%s]" $?;'" exceeded the timeout of 300 seconds.
Not sure if it is related to deployer or composer or ssh
I am check setting COMPOSER_PROCESS_TIMEOUT=600
edvordo
@edvordo
ssh issue, caused by long running composer install, I'd assume ..
I had this issue with the shared dirrectory, there is a lot files, so I aded this ti the deploy.php file
set('default_timeout', 1500);
hershkoy
@hershkoy
Perfect. Thanks. I will check
Paul Kamma
@X-Tender

@X-Tender for the custom file I'd try debugging this portion of the code https://github.com/deployphp/deployer/blob/master/bin/dep#L38 .. tbh I'm not sure how it works without trying to run it myself, but I don't have a project with the lastest deployer on hand, so can't test myself ..

When I run it localy on my mac it works via --file undo.php or --file "undo.php" but not in the gitlab env.

edvordo
@edvordo
silly question, but gotta be asked, just to make sure .. is the undo.php file in vcs?
Paul Kamma
@X-Tender
yes
.. i hope so .. let me check again :D
yes it is
no it isnt .. omg /o\
edvordo
@edvordo
@X-Tender did adding it solve the issue? :)
Paul Kamma
@X-Tender
yes. :)
Konrad Michalik
@jackd248
Hello there, i can't find an answer by my own so far, maybe the question has already been answered.
Is it possible to use deployer programmatically within the php context? So e.g. hosts configuration can be done dynamically?
I want to use deployer as part of a dynamic multi host php application.
David Zamora
@Dazag
Hi Konrad, what do you mean when you say " hosts configuration can be done dynamically?"
I have configured different hosts, for different stages of my app
I don't know if you mean that
1 reply
Jannis Gerlinger
@JannisGerlinger_twitter
image.png
Hi, i`m looking for the basic vendors.php. I want to remove the "--no-suggest" line so that i can resolve the error: Can anyone help?
im using composer v 1.8
edvordo
@edvordo
you can set a custom composer_options with whatever options you want .. the default is
set('composer_options', '{{composer_action}} --verbose --prefer-dist --no-progress --no-interaction --no-dev --optimize-autoloader --no-suggest');
Jannis Gerlinger
@JannisGerlinger_twitter
thank you edvordo
Jannis Gerlinger
@JannisGerlinger_twitter
Now i got a different error :(