These are chat archives for dereneaton/ipyrad

4th
Jul 2016
yexiaying
@yexiaying
Jul 04 2016 00:50
Hi, I have tried the -d flag and problem still exist. I send the txt to your email, Please check it when you have time. thank you very much.
@isaacovercast
Katie Lyons
@ladykiyenz
Jul 04 2016 18:57
Hi Deren/Isaac, I got another error running the empirical tutorial. I can make a subsampling branch, but when I try to create a low-depth branch (ipyrad -p params-sub4.txt -b sub4-lowdepth.) or branch the assembly with a new min_samples_locus (ipyrad -p params-base.txt -b min4), I get the following error:
loading Assembly: sub4
from saved path: /work/02916/kl23833/Pedicularis/pedicularis/sub4.json
Traceback (most recent call last):
File "/home1/02916/kl23833/miniconda2/bin/ipyrad", line 9, in <module>
load_entry_point('ipyrad==0.3.16', 'console_scripts', 'ipyrad')()
File "/home1/02916/kl23833/miniconda2/lib/python2.7/site-packages/ipyrad/main.py", line 439, in main
branch_assembly(args, parsedict)
File "/home1/02916/kl23833/miniconda2/lib/python2.7/site-packages/ipyrad/main.py", line 118, in branch_assembly
if os.path.exists(bargs[1]):
IndexError: list index out of range
Isaac Overcast
@isaacovercast
Jul 04 2016 19:00
Hi Katie, I think Deren actually just pushed a change to fix that problem the other day. Will you try conda upgrade -c ipyrad ipyrad and run it again, i'm pretty sure this is fixed in the newest version 0.3.17
Katie Lyons
@ladykiyenz
Jul 04 2016 19:05
Thanks Isaac!
Isaac Overcast
@isaacovercast
Jul 04 2016 19:05
No sweat. Let me know if it works.
Katie Lyons
@ladykiyenz
Jul 04 2016 19:12
It works!
Isaac Overcast
@isaacovercast
Jul 04 2016 19:12
sweet!
Isaac Overcast
@isaacovercast
Jul 04 2016 21:23
@yexiaying Pushed a new version that hopefully will resolve this issue (0.3.18).
conda upgrade -c ipyrad ipyrad
Shea Lambert
@SheaML
Jul 04 2016 22:16
This message was deleted
This message was deleted