These are chat archives for dereneaton/ipyrad

Feb 2017
Feb 24 2017 18:23
Hi, I had this warning when I try to install iPyrad UnsatisfiableError: The following specifications were found to be in conflict: - ipyrad -> cutadapt >=1.12 -> python 2.7*
  • python 3.5*
    Use "conda info <package>" to see the dependencies for each package. I need uninstall conda? and Re-install? Thank you for you time
Deren Eaton
Feb 24 2017 19:45
Hi @GissellaPineda , this is telling you that ipyrad can only be installed with python 2.7 (the most common Python version) and not with python 3.5, which is what your conda version has.
You can install a separate Python2 environment in your conda installation.
You have a few choices, actually. If you are not attached to your current conda installation you can simply remove it and install ipyrad using the ipyrad installation instructions. Or, you can install a separate python2 miniconda installation altogether to use for ipyrad and any other Python2 code you want to run. Or, you can setup a separate Python2 environment in your existing conda installation. See the conda documentation for more tips on how to do that.
Feb 24 2017 20:24
Thank you very much