These are chat archives for dereneaton/ipyrad

2nd
Nov 2017
tommydevitt
@tommydevitt
Nov 02 2017 13:54
@isaacovercast seems I broke something in trying to update my glibc library before I did conda install conda-build
Isaac Overcast
@isaacovercast
Nov 02 2017 15:00
@JStarrett Looks okay. How about we try re-running step 2 with -d -f -c 1, this will force debug and run with only 1 core. I'm trying to figure out which sample is causing the error so we can debug the sample, multithreading complicates this, so we set to 1 core. Then send me the last 20 or so lines of the ipyrad_log.txt file.
JStarrett
@JStarrett
Nov 02 2017 16:07
@isaacovercast as far as I can tell, the results are the same with 1 core. There is a line like this for every sample: 2017-11-02 10:21:58,595 pid=9908 [rawedit.py] DEBUG Entering cutadaptit_pairs - AR78
2017-11-02 10:21:59,072 pid=9908 [rawedit.py] DEBUG Entering cutadaptit_pairs - AR56
2017-11-02 10:21:59,330 pid=9908 [rawedit.py] DEBUG Entering cutadaptit_pairs - MY977
2017-11-02 10:21:59,467 pid=9908 [rawedit.py] DEBUG Entering cutadaptit_pairs - AR79 And then there are lines like this that I think is the same count as the number of samples, until the engine shutdown command: 2017-11-02 10:22:08,735 pid=9857 [rawedit.py] ERROR error in run_cutadapt(): AttributeError('NoneType' object has no attribute 'replace')
2017-11-02 10:22:08,735 pid=9857 [rawedit.py] ERROR error in run_cutadapt(): AttributeError('NoneType' object has no attribute 'replace')
2017-11-02 10:22:08,736 pid=9857 [rawedit.py] ERROR error in run_cutadapt(): AttributeError('NoneType' object has no attribute 'replace')
2017-11-02 10:22:08,736 pid=9857 [rawedit.py] ERROR error in run_cutadapt(): AttributeError('NoneType' object has no attribute 'replace')
2017-11-02 10:22:08,736 pid=9857 [rawedit.py] ERROR error in run_cutadapt(): AttributeError('NoneType' object has no attribute 'replace')
2017-11-02 10:22:08,736 pid=9857 [rawedit.py] ERROR error in run_cutadapt(): AttributeError('NoneType' object has no attribute 'replace')
2017-11-02 10:22:08,736 pid=9857 [rawedit.py] ERROR error in run_cutadapt(): AttributeError('NoneType' object has no attribute 'replace')
2017-11-02 10:22:08,849 pid=9857 [assembly.py] INFO shutting down engines
2017-11-02 10:22:08,862 pid=9857 [assembly.py] INFO finished shutdown
2017-11-02 10:22:08,864 pid=9857 [init.py] INFO debugging turned off
JStarrett
@JStarrett
Nov 02 2017 16:16
@isaacovercast I can run step 2 (and 3-7) of ipyrad with no errors as long as ipyrad does the demultiplexing in step 1, rather than using demultiplexed data from another source and giving the path to the sorted fastqs for step 1. Normally I would use ipyrad to demultiplex, but in this case I needed to use a different program (mrdemuxy). Some one else at my same institution is running into the same error in step 2 with their demultiplexed data from another source.
Isaac Overcast
@isaacovercast
Nov 02 2017 17:12
Probably a formatting issue with the sample fastq. Can you dropbox me one or two of the sample fastq files?