These are chat archives for dereneaton/ipyrad

13th
Nov 2018
solomonchak
@solomonchak
Nov 13 2018 06:00

Hi all, I'm trying to install ipyrad on an HPC. After installing miniconda2, I did

conda install -c ipyrad ipyrad -y

without error. But when I try

ipyrad --version

I got and error

Traceback (most recent call last):

File "/rigel/dsi/users/tc2856/miniconda2/bin/ipyrad", line 11, in <module>

load_entry_point('ipyrad==0.7.28', 'console_scripts', 'ipyrad')()

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/pkg_resources/init.py", line 484, in load_entry_point

return get_distribution(dist).load_entry_point(group, name)

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/pkg_resources/init.py", line 2707, in load_entry_point

return ep.load()

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/pkg_resources/init.py", line 2325, in load

return self.resolve()

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/pkg_resources/init.py", line 2331, in resolve

module = __import__(self.module_name, fromlist=['__name__'], level=0)

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/ipyrad/init.py", line 20, in <module>

from . import load as _load

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/ipyrad/load/init.py", line 14, in <module>

from .load import test_assembly

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/ipyrad/load/load.py", line 13, in <module>

from ipyrad.assemble.util import *

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/ipyrad/assemble/init.py", line 7, in <module>

from . import cluster_within

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/ipyrad/assemble/cluster_within.py", line 32, in <module>

from refmap import *

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/ipyrad/assemble/refmap.py", line 15, in <module>

import pysam

File "/rigel/dsi/users/tc2856/miniconda2/lib/python2.7/site-packages/pysam/init.py", line 5, in <module>

from pysam.libchtslib import *

ImportError: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

Please help!