Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Hamed Jafary
    @DisMissive_gitlab
    @GregOriol Hello there, I've a question. Recently i've uploaded an app to the diawi site but I can't seem to install it via the link provided. It downloads the app and while installing says unable to install the app. meanwhile I used the app store and it download & opens it just fine
    Greg ORIOL
    @GregOriol
    @DisMissive_gitlab Hi! The "unable to install app" popup appears mostly when the app doesn't have the correct provisioning for your device: is your device's UDID in provisioning profile of the app? (you can check that from your Diawi dashboard) is your app built with the correct settings/requirements for your device? Check also our knowledge base on the website for most common issues possible
    Hector
    @hquezada_twitter
    hi, when diawi comming?
    Greg ORIOL
    @GregOriol
    Hi @hquezada_twitter, we are already back :-)
    Hector
    @hquezada_twitter
    thanks!!
    Mandy Strickland
    @Astrickland1077_gitlab
    When will the site be up?
    Greg ORIOL
    @GregOriol
    Hello, the site is up! Do you see something unusual?
    Farhan
    @Frrank1
    Hi Diawi, hope everyone is doing great.
    I need to connect with your business department to get more information of you subscription models as we need to distribute our apps to specific users your platform seems to be a good fit please connect with me here or my email farhan@beam.live
    Greg ORIOL
    @GregOriol
    Hi @Frrank1, everyone is doing great thanks! Do you have any question we can discuss here? otherwise via a support ticket if you already have an account on the website
    adriana-haddad
    @adriana-haddad
    Hi,
    I have added a users udid ID to my apple account, but when they try to install the app they get this error "Warning: the provisioning profile inside this app doesn't seem to contain your device's UDID" none of the other users added and using the link encountered this issue.... Please help if you have any suggestions
    Greg ORIOL
    @GregOriol
    Hi! Does the UDID you added appear on the list displayed on the installation page? if you, your build is probably not using the latest provisioning profile: try to generate and download it from your apple account, drag&drop it to xcode and build again
    adriana-haddad
    @adriana-haddad
    Hi there,
    When I build the app straight to my ipad it works fine (it also performs fine on the emulator). When I try and install using a link, some functionality is broken and the app crashes.
    Greg ORIOL
    @GregOriol
    @adriana-haddad Hi! Well, Diawi doesn't change anything in the app you upload, so an idea could be to check the build rules applied to when you run it on the iPad and when you export it for upload
    gatelli
    @gatelli
    Hi, Is there a problm with Diawi ? I have this error: An error occurred:
    4001504: Invalid .apk file: couldn't retrieve the signature, the app must be signed to be able to install it on a device. It was working before...(and APK is signed)
    Greg ORIOL
    @GregOriol
    Hi! There is no known problem currently: uploads work fine. Are you sure the exported apk is signed?
    gatelli
    @gatelli
    Well pretty sure.. I did it several times. I'm currently trying with a debug version instead of release one. EDIT : working with debug, don't know if it's related..
    Greg ORIOL
    @GregOriol
    Probably that the other one is not signed then :-)
    Check with the commandline apksigner tool if you can (it's in the sdk's build-tools), like this: "./apksigner verify --verbose --print-certs theapp.apk"
    gatelli
    @gatelli
    I'm not fluent with this tool but I will try. Anyway I could upload the release version to Google Play (not published yet) without signing error... I thought I should have had an alert if app unsigned... I'll have a look.
    shashankfunngage
    @shashankfunngage
    Hi Everyone .. i have a doubt and a question , how this diawi 100+ installation works when i have permission to add 100 UDID's against my particular certificate
    Arthur Bouquet
    @arthurbouquet
    @shashankfunngage Hi, I've answered to your ticket on the website (I think it was you!)

    for the others who are interested in the answer :

    • with a regular iOS account (using Ad-Hoc builds) you can register up to 100 devices per device type (iPhone, iPad etc.).
    • with a enterprise iOS account (using In-House builds) you don't need to register your devices's UDIDs and there is no limit in the number of installs

    That's why there are some add-on on Diawi to allow more than 100 installations for an app!

    kageeker
    @kageeker
    My app icon doesnt show when i upload the app , any solutions to this ?
    Ps : its a flutter app
    Greg ORIOL
    @GregOriol
    Hi! Is it an iOS or an Android app?
    Haripriya B
    @HaripriyaB
    Hi guys, I'm here as a representative from AnitaB.org open source org. I want to know some feature of daiwi. We want to build apks for every Pull Request issued from the contributors AUTOMATICALLY. So that the tester need not build the project and then test it. Instead just download the apk from the PR and test it.
    Anyone from the dev team of diawi can respond pls??
    Greg ORIOL
    @GregOriol
    Hi @HaripriyaB ! Diawi is a tools to help install the app, but the build is on your side (for many technical and security reasons!): as soon as you have the apk, you can use Diawi
    Haripriya B
    @HaripriyaB
    ok thanks
    Rizwan Aalam
    @i-rizwan
    Hi guys, i am facing an issue while uploading the android app apk programmatically via curl shell script which has been mentioned in diawi doc, i am getting an error "0curl: (6) Could not resolve host: " previously 1 month back my same script was working now it is not working
    Greg ORIOL
    @GregOriol
    Hi @i-rizwan, could you check what the command "dig www.diawi.com" shows? it seems that your machine doesn't find our servers, this command might give a clue; otherwise try maybe with another internet access?
    Rizwan Aalam
    @i-rizwan
    Hi @GregOriol , thanks for replying, i have managed to solved this issue (after removing the callback url params it is working now in same script)
    Greg ORIOL
    @GregOriol
    @i-rizwan It is strange, but great that you found that!
    Khemchand Joshi
    @kjoshi07
    trying to upload android apk on diwai and showing error "manifest is missing application label" , application level is defined but still error is showing, does anybody facing such issue?
    Greg ORIOL
    @GregOriol
    Hi, the error may mean that you app is missing the label, which is necessary for an app; double-check with your build tools! if you still get this error, open a ticket from the dashboard and the support team will have a look!
    Nicolae Olariu
    @nicolaeolariu_twitter

    Hi Guys! We were just wondering, is there a reason why the installed iOS apps are auto updating themselves to latest install URLs?

    Usecase: We have 2 install iOS links: install1 uploaded 2 days ago and install2 uploaded yesterday
    Scenario: Even if installing the install1, if you close the app and reopen it shows you the install2 version

    Greg ORIOL
    @GregOriol
    Hello Nicolae!
    It is not possible! Did you double-check the content of each install link? there is no way another link would be installed, and there is no way an "update" would be installed through links like this
    Also by using links, you can install in both ways, newer version over older, or older over newer, iOS and Diawi don't care
    Nicolae Olariu
    @nicolaeolariu_twitter
    W
    We've double checked that, and could reproduce it by our QA team.
    Installed old links, reopen app, new version shows up.
    On dozens of devices.
    At least 70 iPads auto updated to latest link...
    Greg ORIOL
    @GregOriol
    Does you app show the correct version number?
    There is no such thing as auto-update here, that's 100% sure, it must be something else
    Nicolae Olariu
    @nicolaeolariu_twitter
    Yes. We're installing 2.0.5 for instance, and when reopening the app, it shows 2.0.6.
    I see, thank you! We'll debug it on Monday and see if we're doing something weird on our side.
    The thing that made us think to autoupdate was upgrading the account exactly yesterday, when this thing started to happen. We had no issues in months.
    Greg ORIOL
    @GregOriol
    There are no differences between account type on this. But do you also use TestFlight?