Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 13 2016 13:04

    galthaus on develop

    update metadata on test barclam… Merge pull request #1296 from z… (compare)

  • Sep 13 2016 13:04
    galthaus closed #1296
  • Sep 13 2016 04:52
    VictorLowther commented #1296
  • Sep 13 2016 04:52
    zehicle labeled #1296
  • Sep 13 2016 04:52
    zehicle opened #1296
  • Sep 13 2016 04:52
    zehicle assigned #1296
  • Sep 06 2016 20:50

    galthaus on develop

    :3000 no longer needed Merge pull request #1295 from z… (compare)

  • Sep 06 2016 20:50
    galthaus closed #1295
  • Sep 06 2016 20:48
    VictorLowther commented #1295
  • Sep 06 2016 20:48
    zehicle opened #1295
  • Sep 06 2016 06:11

    galthaus on develop

    allow prefix more control in no… Merge pull request #1294 from z… (compare)

  • Sep 06 2016 06:11
    galthaus closed #1294
  • Sep 06 2016 03:18
    VictorLowther commented #1294
  • Sep 06 2016 03:18
    zehicle opened #1294
  • Sep 01 2016 21:05

    galthaus on stop-dns-and-gssapi-in-sshd-in-sledgehammer

    (compare)

  • Sep 01 2016 21:05

    galthaus on develop

    Update sshd in Sledgehammer to … Merge pull request #1293 from d… (compare)

  • Sep 01 2016 21:05
    galthaus closed #1293
  • Sep 01 2016 21:03
    VictorLowther opened #1293
  • Sep 01 2016 21:03

    VictorLowther on stop-dns-and-gssapi-in-sshd-in-sledgehammer

    Update sshd in Sledgehammer to … (compare)

  • Sep 01 2016 14:40

    galthaus on fix-intermittent-network-role-creation-failure

    (compare)

Simon
@analbeard
@greg (or anyone at RackN) - is there no way to view the UI than through the RackN website? The environment my DRP box will live in won't be internet accessible, and even if it were I can guarantee our security team would have a shit-fit if I suggested doing that
@lae I have found some of the docs to be a little out of date and I had to fudge my way around it - editing profiles was oen of them
rackneng
@rackneng
[lae] the rackn UI doesn't access your DRP instance over the internet, it uses JS in your browser to access it - so you just need to be able to access the DRP endpoint from your browser
Simon
@analbeard
oh - i hadn't investigated it because I thought that was how it worked. that certainly improves things!
rackneng
@rackneng
[lae] and uh, my point is that this seems to be an unexpected regression in one of the recent releases. Anyway, I just tried downgrading drpcli to 3.4.1 and 3.2.1 (from 3.6.0) and that works in 3.2.1 but not 3.4.1
rackneng
@rackneng
[vlowther] @lae broken yaml support is definitely a bug. Open an issue?
MattyBoy
@MattyBoy4444
Just reinstalled with force. When I go to setup subnets in UX I just get a spinning "Loading Interfaces". Any suggestions? I am a newbie at drp.
Running v3.6.0
rackneng
@rackneng
[shane] @MattyBoy4444 - are you sure your DRP Endpoint is accessible from your Laptop/Management machine - no Firewalls or IPTables rules blocking access? You can also check the process to make sure it's running on the Endpoint as well (ps -ef | grep dr-provision) ... also - any log output from the running instance if it is running ?
[shane] you need TCP Port 8092 access to the DRP Endpoint from the system you are running the Web Browser connection to the Portal
rackneng
@rackneng
[shane] so ... gohai-inventory of DMI --> BIOS --> BIOSVersion == "VirtualBox" is ... well ... VirtualBox ... so unfortunately - that param won't be reliable for all types of Virtualization
MattyBoy
@MattyBoy4444
@rackneng I can access the UX frontend from my management machine. I did check Chrome console and found a jquery warning
MattyBoy
@MattyBoy4444
error1.jpg
rackneng
@rackneng
[greg] You may want to try changing the base url to portal.rackn.io
MattyBoy
@MattyBoy4444
@rackneng the log inside ux is basically empty
MattyBoy
@MattyBoy4444
@rackneng I am running tip BTW. Sure looks like a bug due to the following changeset: digitalrebar/provision@00f5ac9
rackneng
@rackneng
[greg] @MattyBoy4444 - the image you sent us - shows us that you are running v3.6.0 and a test UX.
[greg] You could try to change: `rackn.github.iotoportal.rackn.io` and see if it loads differently.
[greg] The commit reference you made wouldn’t make a ux hang, because it doesn’t change API output. It would change internal actions. It also makes less thing required.
MattyBoy
@MattyBoy4444
@rackneng Well I installed from this URL. https://github.com/digitalrebar/provision/releases/download/tip/dr-provision.zip. Also the error is in reference the "NextServer" missing, which is what that changeset removes. My 2 cents.
rackneng
@rackneng
[greg] Hmm - okay The image you sent doesn’t align with that, but probably true.
MattyBoy
@MattyBoy4444
@rackneng If you dig into Build.js on that line, I think it references o.NextServer
rackneng
@rackneng
[greg] Yeah - I’m looking at it. The UX is not handling the facct that NextServer can be unset.
rackneng
@rackneng
[greg] Actually, it is just a UX bug.
MattyBoy
@MattyBoy4444
That is what I thought.
rackneng
@rackneng
[greg] I still don;’t think you are using tip, but just a second.
rackneng
@rackneng
[greg] @MattyBoy4444 - try the UX again,
[greg] Then we should try and figure out the version of drp you have.
MattyBoy
@MattyBoy4444
I was afraid you would say that. :) I just wiped and started installing stable. Hmmm... I could wipe again and start over. Not a big deal. I was just setting up a test platform.
??
rackneng
@rackneng
[greg] The bug I think that is happening and I tried to fix. Is only if you are using a stable DRP against the master UX.
[greg] That is what your image was showing.
[greg] It would be nice to see what was in your Info and Preferences page or dr-provision --version
[greg] If you used install.sh from tip, it will still grab stable.
MattyBoy
@MattyBoy4444
I am trying again. Probably take 15 min
Basically, I rm /var/lib/dr-provision and then follow this again. http://provision.readthedocs.io/en/stable/doc/install.html
I originally had stable on this box. I assumed following these instructions after the remove, would basically be like doing a fresh install.
rackneng
@rackneng
[greg] I think so.
MattyBoy
@MattyBoy4444
I am following that same procedure now. I HOPE i didn't waste your time'
rackneng
@rackneng
[greg] no
[greg] The big thing is that to get tip, you have to explicitly ask for it if you are using install.sh.
[greg] I needed to fix the UX bug.
MattyBoy
@MattyBoy4444
I may have downloaded the tip and then ran the following command to install: sudo ./install.sh --force install
I didn't see the switch for the version. So now i just ran the following command: sudo ./install.sh --force=true --version=tip install
rackneng
@rackneng
[greg] hmm - I think it should be --drp-version=tip
[greg] nvm - either works now.
[greg] well for tip install.sh
[greg] :)
MattyBoy
@MattyBoy4444
@rackneng I can now setup a subnet!!