These are chat archives for django/django

27th
Dec 2017
mohammadreza
@ultra2mh
Dec 27 2017 07:19
i got it thankyou @badcoder28
mohammadreza
@ultra2mh
Dec 27 2017 11:41

guys im trying to install django-rest-auth
but the following error occur
```pip install django-rest-auth
Collecting django-rest-auth
Using cached django-rest-auth-0.9.2.tar.gz
Requirement already satisfied: Django>=1.8.0 in ./venv/lib/python3.5/site-packages (from django-rest-auth)
Requirement already satisfied: djangorestframework>=3.1.0 in ./venv/lib/python3.5/site-packages (from django-rest-auth)
Requirement already satisfied: six>=1.9.0 in ./venv/lib/python3.5/site-packages (from django-rest-auth)
Requirement already satisfied: pytz in ./venv/lib/python3.5/site-packages (from Django>=1.8.0->django-rest-auth)
Building wheels for collected packages: django-rest-auth
Running setup.py bdist_wheel for django-rest-auth ... error
Complete output from command /home/mohammadreza/PycharmProjects/mohammadrezaDjangoApp/Django/venv/bin/python3 -u -c "import setuptools, tokenize;file='/tmp/pip-build-xl9ds058/django-rest-auth/setup.py';f=getattr(tokenize, 'open', open)(file);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, file, 'exec'))" bdist_wheel -d /tmp/tmp5sk4s13wpip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

Failed building wheel for django-rest-auth
Running setup.py clean for django-rest-auth
Failed to build django-rest-auth
Installing collected packages: django-rest-auth
Running setup.py install for django-rest-auth ... done
Successfully installed django-rest-auth-0.9.2
```

Roel
@roelzkie15
Dec 27 2017 12:20
@ultra2mh it is because django-rest-auth is built on top of python2 version and you are using python3. but well yea, i could be wrong
mohammadreza
@ultra2mh
Dec 27 2017 12:23
it looks like too .. but what should i do to solve this.. what should do python 3 users . . .
Anish Shrestha
@annshress
Dec 27 2017 13:14
Hello guys
Need help
I have a big db. And currently my primary key is id=AutoField(...) provided default by django.
Now I need to change it to UUIDField. But, It wont allow me to migrate, saying ProgrammingError
Can't cast int into uuid:uuid
Anish Shrestha
@annshress
Dec 27 2017 13:20
Anyone got solution?
Anish Shrestha
@annshress
Dec 27 2017 13:51
ALTER TABLE app1_one ALTER COLUMN id SET DATA TYPE UUID USING (uuid_generate_v4());
ERROR: foreign key constraint "app1_two_fk_id_ed738f2e_fk" cannot be implemented DETAIL: Key columns "fk_id" and "id" are of incompatible types: character varying and uuid.
ForeignKey is causing problem.