by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jul 06 18:04
    avashist003 commented #529
  • Jul 06 14:57
    DJI-Jerry commented #558
  • Jul 06 14:51

    DJI-Jerry on master

    new:update linker armv8 lib Up… new: update x86 linker lib Upd… Merge pull request #559 from DJ… (compare)

  • Jul 06 14:51
    DJI-Jerry closed #559
  • Jul 06 14:49

    DJI-Jerry on 3.6

    Fix onboard sdk issue Merge pull request #558 from HK… (compare)

  • Jul 06 14:49
    DJI-Jerry closed #558
  • Jul 06 14:46
    DJI-Jerry opened #559
  • Jul 06 14:30

    DJI-Jerry on fix_linker_lib

    new:update linker armv8 lib Up… (compare)

  • Jul 06 08:50
    dji-dev commented #557
  • Jul 06 07:58
    DJI-Jerry commented #558
  • Jul 06 07:37
    xuhao1 opened #558
  • Jul 06 06:33
    dji-dev commented #556
  • Jul 06 02:09
    addriumruss opened #557
  • Jul 05 08:50
    ADlead commented #555
  • Jul 04 13:09
    beyond21299 closed #544
  • Jul 04 13:08
    beyond21299 opened #556
  • Jul 04 07:49
    ADlead opened #555
  • Jul 02 20:01
    jicalder commented #479
  • Jul 02 13:41
    DJI-Jerry closed #554
  • Jul 02 13:40
    DJI-Jerry opened #554
Andre Nguyen
@andre-nguyen
@nithinreddygaddam We ended up just using standard antennas with an intel wifi card, but the reality is that if you want good data rates you need a good transmitter AND receiver
If you look at the MBZIRC going on right now you can see some people equipped their drones with ubiquity products
Anna Liao
@anna-osprey
@andre-nguyen very cool!
Adrian Huang
@Adrian_Active_twitter
Could any one help? I try to trigger sdk failsafe after waypoints are done, but after it returns, I could ask A3 to fly way points again
I use setmovementcontrol to keep the connection between board and fligth control without real rc
Anyone could help?
Matias Godoy
@mattogodoy
Hi!
I'm new to C++, and I'm trying to add the OnboardSDK as a lybrary to my project, but I'm not able to do it.
This is my CMakeLists.txt file: https://pastebin.com/GU4PyK6g
When I run "cmake .." from the "build" folder, everything goes fine. The problem comes when I run "make". I get an error saying that "LinuxSerialDevice.h" was not found (even though it is inside "${ONBOARDSDK_SOURCE}/platform/linux/inc" as specified in CMakeLists.txt)
I'm using OnboardSDK version 3.2 (3.3 is not yet available to the M600 Pro)
Can anybody help me build my CMakeLists.txt file?
xorb0181
@xorb0181
does anyone know how to solve the error message "Please call getDroneVersion first."
?????
I get this error message when I try to roslaunch dji_sdk sdk_manifold.launch
rogeriobonatti
@rogeriobonatti
Hi all, when I get the lat / lon values in the dji_sdk/global_position message, does anyone know if those values corresponds to the antenna location, or another specific point in the M100 frame?
Christopher Farm
@farmcp
is there an SDK that allows you to run python on the phantom 3?
Somik Ghosh
@ghoshsomik
@xorb0181 yeah that started happening when i connect with my matrice recently
before my code just worked, but now that message pops up but never leaves
Somik Ghosh
@ghoshsomik

Hi. I've been trying to perform the M100's onboardSDK sample activation (https://developer.dji.com/onboard-sdk/documentation/github-platform-docs/PureQT/README.html) using QT Creator for Windows but it's not working. I typed the ID and Key pair obtained from DJI and then I opened the COM without any problems and received the following message:

STATUS QtOnboardsdkPortDriver::init,line 35: port COM5 open success
STATUS QtOnboardsdkPortDriver::init,line 42: BaudRate: 230400

Then, according to the tutorial from the link above (Activation - 7th step) I should click on the "version" button, but when I do absolutely nothing happens. There's no error nor any response from the application.

Ignoring this step, when I click on the "Activate" button, I get the following ERROR:

ERROR DJI:nboardSDK::CoreAPI::activate,line 388: Please call getDroneVersion first.

However, I believe this error is due to the fact that when I click the "version" button, nothing happens.
Does anyone have any idea as to why it is not responding to the "version" request?

Same issues that I am having. Any ideas?

ViasVegas
@ViasVegas
Hi, does anyone has experience with the DJI's drone M210 ?
I searched through the documentation on DJI's website b
but i cant find which of the expansion ports match the UART pin Rx and Tx, i need help please
Rohit Sant
@rohitsantdji

@ghoshsomik if it doesn't automatically get your version, that means either your application doesn't have permission to talk to the serial port, or your connections are wrong. You will be unable to proceed until you fix that issue.

@ViasVegas An Onboard SDK release with M210 compatibility will be released in the next two weeks, along with updated documentation.

Farhad Ghayour
@FarhadG
Any DJI iOS (React Native) experts available for consulting services?
Billowista
@Billowista
Hi all. New to developing on the A3 flight controller. Is anyone aware of a simulator platform which will allow me to send/receive commands without needing the actual A3 hardware?
josh3333332
@josh3333332
Can anyone suggest the most efficient way to read & log serial telemetry on the M210?
Ang Zhi Ping
@angzhiping_twitter
Any plans to provide binaries for Advanced Sensing 2.0 for armv7 architecture (e.g. Manifold)?
Rohit Sant
@rohitsantdji
@angzhiping_twitter Keep an eye out for Manifold binaries coming out over the next month or so!
@josh3333332 The OSDK allows you to subscribe to various types of telemetry data. Could you tell us about the kind of data you want to log?
@Billowista Currently you will need the hardware for all OSDK development.
Justin Tuchek
@justintuchek
What SDK will the Ronin S fall under?
EricGanzert
@EricGanzert
Hello guys! I am looking for a suitable linux machine to use as an onboard embedded system! The DJI manifold is attractive for interfacing with the flight controller and guidance core. However my boss and co-workers beleive it may draw too much power (5W ~ 15W) for our application. Does anyone know an alternative linux machine that is ARM 32 bit and will work well with Ubuntu?
any suggestions are appreciated!
EricGanzert
@EricGanzert
I am using the M100 drone
peccadillo
@peccadillo
@rohitsantdji How is the binaries development for Manifold for advanced sensing 2.0 coming along! :)
EricGanzert
@EricGanzert
never mind my last comment I bought the manifold computer.
what onboard sdk command can I use to make the drone face North?
weaverlave
@weaverlave
Hello, we use ARM Keil for developing. Does anyone know this error: Error: Flash Download failed - Could not load file 'D:\Onboard-SDK-3.5\Onboard-SDK-3.5\sample\STM32\OnBoardSDK_STM32\Project\Objects\osdk_stm32.axf' i cant find the Problem, tehre is no axf file located
weaverlave
@weaverlave
Hello, we use ARM Keil for developing. Does anyone know this error: Error: Flash Download failed - Could not load file 'D:\Onboard-SDK-3.5\Onboard-SDK-3.5\sample\STM32\OnBoardSDK_STM32\Project\Objects\osdk_stm32.axf' i cant find the Problem, tehre is no axf file located
Ephrem Mekonnen
@effymekonnen_twitter
Hello I am getting L1339: Drone version not obtained error. I am using firmware version of 1.1.6 and SKD version 3.6 I was just trying to run sample demos
Ivica Suran
@isuran
@rohitsantdji does onboard sdk work with m200 ?
afasc
@afasc
Hello, I am trying to run the LiDAR mapping sample from the Onboard SDK. Unfortunately, neither the Linux or the ROS compile correctly. At the end of the process described in the dji developer website I cannot obtain the pointcloud2las needed to perform the mapping. has anyone solved this issue?
Khairul Ikhwan
@imkhairulikhwan
@dleal93 Hi, I got similar issue as well, but I'm using M210. May I know how do you connect the drone to your PC? I use USB A-USB C cable. I have enabled the SDK as well in DJI Assistant but when running the sample, I got similar error message. Have your issues being fixed already? Thanks.
@effymekonnen_twitter Same issue here. May I know if you have fixed it? Thanks.
Alexandr
@muchosun
Hi gays. What about python example for missionwaypoint?
Alexandr
@muchosun
Sdk 3.6
Pavan Kumar B N
@pavankumarbn
Hello Everyone, I have been trying to connect Matrice 100 with Intel NUC onboard computer but facing " getDronVersion,Drone version not obtained. Please do not proceed. Unable to initialize some vehicle components. Any suggestions how to solve this issue? Platform: Ubuntu 14.04LTS, ROS indigo, SDK 3.6
Pavan Kumar B N
@pavankumarbn
@pavankumarbn @imkhairulikhwan
Pavan Kumar B N
@pavankumarbn
@dleal93 Did you fix this issue?
loiopol
@loiopol
@pavankumarbn the last compatible SDK for matrice 100 was (if I remember well) the 3.4
Ivica Suran
@isuran
nope, we are working with 3.6
this could be port issue
peccadillo
@peccadillo
I have experienced a rare problem with the Telemetry update rate.