Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Supratim Chowdhury
    @supratims
    it used to be around 20-30 ms . but recently we went through a website redesign and the new scss is highly modularised, too many cross dependencies/imports/inheritances, @extends etc in scss . Possibly that could be the reason ? as it tries to resolve references everytime.
    half of those are external libraries that we import, so dont need compiling everytime
    nipek
    @nipek
    hello
    i am having a problem installing gulp-sass on my windows 8,node version is 0.10.32
    any idea on what might be the problem???
    AssassinsMod
    @AssassinsMod
    is there a way to append the '--compass' flag ?
    Sam Richard
    @Snugug
    Gulp Sass is the Nose version of Sass, not the Ruby version no Compass flag
    AssassinsMod
    @AssassinsMod
    my bad
    David Manning
    @dlmanning
    @Snugug : FYI, I've given @xzyfer commit / publish rights to github / npm so he can more easily keep us in sync with beta node-sass updates
    Chris Stegner
    @cstegner
    Hey guys, I'm running the latest version of gulp-sass and have a very simple setup, but it's literally just not doing anything for me. Runs, doesn't output anything, no errors, finishes the gulp task. Any ideas?
    Peter Bittner
    @bittner
    @cstegner I've just switched from gulp-ruby-sass to gulp-sass, and it works for me. -- What does your gulpfile look like?
    Peter Bittner
    @bittner
    Does anybody know about a difference in the handling of color values with LibSass vs. Ruby-Sass? (sass-compatibility/sass-compatibility.github.io#47)
    Chris Stegner
    @cstegner
    @bittner I was new to Sass and didn't realize that all files whose filename start with an underscore would be ignored :P
    Was very happy to get working and very very frustrated at all the steps I took to get it working when was something so stupid.
    excellent6
    @excellent6
    Hello, I'm new to gulp-sass and receive the following error: undefined:undefind Invalid UTF-8. I have one main scss file and a partial. When they are in the root of my project, I don't receive it. Any ideas.
    Peter Bittner
    @bittner
    http://stackoverflow.com/questions/32496807/error-invalid-utf-8-when-compiling-sass-with-import
    dlmanning/gulp-sass#322 (path problem, @ import)
    sass/node-sass#716 (path problem, @ import)
    frio
    @frio
    Hi all, I've just raised #394. Would a patch adding a sassMapFile = sassMapFile.replace('stdin.css', 'stdin') be acceptable?
    (I could try git bisect-ing node-sass, but I'm a little lazy ;))
    Alessio Cavaleri
    @alecha
    Hi! I've an issue with this simple task. My issue is that from the console the task ends immediatly (~15ms) without creating any css file. Any hints? Thanks!
    Roman O
    @romanlex
    hello, I have nodejs 5.1.0 and this problem with gulp-sass
    roman@roman-N550JV:/var/www/domains/amorem.lo/source/frontend$ gulp style:build
    module.js:450
      return process.dlopen(module, path._makeLong(filename));
                     ^
    
    Error: /media/Develop/www/domains/amorem.lo/source/frontend/node_modules/node-sass/vendor/linux-x64-47/binding.node: failed to map segment from shared object
        at Error (native)
        at Object.Module._extensions..node (module.js:450:18)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:313:12)
        at Module.require (module.js:366:17)
        at require (module.js:385:17)
        at Object.<anonymous> (/media/Develop/www/domains/amorem.lo/source/frontend/node_modules/node-sass/lib/index.js:16:15)
        at Module._compile (module.js:425:26)
        at Object.Module._extensions..js (module.js:432:10)
        at Module.load (module.js:356:32)
    Mohit127
    @Mohit127
    Which version of gulp-sass started using node-sass 3.4.2? i am having trouble with node-sass 3.4.2. The older version works fine.
    Esteban Vera
    @kiokotzu
    hello, sourceComments router change ?
    troymclure1
    @troymclure1
    Hi there
    when I run npm install I get a deprecated package warning
    npm WARN deprecated lodash@1.0.2: lodash@<2.0.0 is no longer maintained. Upgrade to lodash@^3.0.0
    I'm using gulp sass 2.1.1
    any ideas the best way around this?
    troymclure1
    @troymclure1
    aha found out this is with lib-sass
    wojciechburdzy
    @wojciechburdzy
    Hi could someone please help me how I can remove any external calls when gulp-sass gets installed do to a proxy problem, and I would not be able to contact github for any additional dependency
    I inplemented sinopia as my local npm repo
    Francis Schmaltz
    @Francisschmaltz_twitter

    Hello all! I have a question for the room... no matter what, I can't get my sass styles.scss to import my images directory. I continue to get error Error in plugin 'sass'
    Message:
    src/scss/site.scss
    Error: File to import not found or unreadable: images
    Parent style sheet: /Users/administrator/ybvm/src/scss/site.scss
    on line 27 of src/scss/site.scss

    @import "images";
    ^
    Any help would be a huge help

    Bob Eagan
    @bobeagan
    anyone ever experienced an issue where scss compiles without error but none of the cross-file @extend are included?
    Josh Murray
    @joshmurrayeu
    Hi there. I am trying to complile my styles.scss with gulp-sass but am getting the dest.on error. How can I fix this problem? I'll show you the full error, below.
    [09:48:49] Starting 'e'...
    [09:48:49] 'e' errored after 2.35 ms
    [09:48:49] TypeError: dest.on is not a function
        at DestroyableTransform.Readable.pipe (D:\Data\Web Development\Repositories\ds-www\node_modules\through2\node_modules\readable-stream\lib\_stream_readable.js:485:8)
        at Gulp.<anonymous> (D:\Data\Web Development\Repositories\ds-www\gulpfile.js:44:6)
        at module.exports (D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\lib\runTask.js:34:7)
        at Gulp.Orchestrator._runTask (D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\index.js:273:3)
        at Gulp.Orchestrator._runStep (D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\index.js:214:10)
        at D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\index.js:279:18
        at finish (D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\lib\runTask.js:21:8)
        at module.exports (D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\lib\runTask.js:60:3)
        at Gulp.Orchestrator._runTask (D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\index.js:273:3)
        at Gulp.Orchestrator._runStep (D:\Data\Web Development\Repositories\ds-www\node_modules\orchestrator\index.js:214:10)
    Peter Bailey
    @pea
    Anyone know why gulp-sass might be reporting an error with this & reference?
    #main {
      color: black;
      &-sidebar { border: 1px solid; }
    }
    Daniel Sellers
    @designfrontier
    @pea this is super lateā€¦ but you probably because of a missing color attribute for the border shorthand
    Peter Bailey
    @pea
    So I am. I think it also turned out that I had an error elsewhere but my linter was confusing things by showing this as an error
    Josh Murray
    @joshmurrayeu
    Hey guys! Check out my question? Would be greatly appreciated! http://stackoverflow.com/questions/40313761/gulp-gulp-sass-compiling-from-many-directories
    Kevin McKernan
    @mckernanin
    is there a change log for 3.0? any major changes?
    fabio-silva
    @fabio-silva
    Hey there. Did anybody have an error related to the execSync/node-sass preinstall script?
    Alexander Indo
    @zanderi
    Trying to compile my sass and the pseudo selector :not() is acting like a mixin and injecting all sorts of styles. Any ideas?
    .flexslider.marquee-homepage {
            .eyebrow {
                text-transform: none;
                font-weight: 400;
            }
    
            hr {
                width: 20%;
            }
    
            h2 {
                color: $orange;
            }
    
            @media screen and (min-width:$screen-sm) {
                h1, h2, p, a:not(.btn) {
                    color: #FFFFFF;
                }
    
                a:not(.btn) {
                    text-decoration: underline;
                }
    
                a:not(.btn):hover {
                    color: $blue-lt;
                }
    
                .btn-marquee-blue-lt {
                    @include button-variant(#FFF, $blue-lt, $blue-lt);
                }
    
                .hero-bg::after {
                    padding-top: 50%; /* 2:1 ratio */
                }
    
                .hero-copy {
                    padding-top: 0;
                    @include vertical-align-middle();
    
                    hr {
                        width: 20%; /*.hr-min (only we can't extend within a media query)*/
                        max-width: 100px;
                        background-color: $pinstripe-color;
                        background-color: #fff;
                    }
                }
            }
    Generated output:
    .flexslider.marquee-homepage h1, .flexslider.marquee-homepage h2, .flexslider.marquee-homepage p, .flexslider.marquee-homepage a:not(.btn):not(.dh-button):not(.dh-button-blue):not(.dh-button-blue-cta):not(.dh-content .dh-button-blue):not(.dh-content .dh-button-blue-cta):not(.dh-button-cta):not(.dh-content .dh-button):not(.dh-content .dh-button-cta) {
    color: #FFFFFF; }
    notice the million appended :not()'s
    running: "gulp-sass": "^3.1.0",
    Alexander Indo
    @zanderi
    Turns out this is an issue with lib-sass sass/libsass#2055 and doesn't look like there's going to be a fix soon
    divyameher
    @divyameher

    Hi,
    I'm new to Sass. Can any one tell Why I'm getting this error when trying to import partial Sass file in another sass file:

    Error in plugin 'sass'
    Message:
        src\app\lib\material-cutom-theme.scss
    Error: File to import not found or unreadable: ~/@angular/material/theming.
           Parent style sheet: D:/DevEnv/src/app/lib/material-cutom-theme.scss
            on line 3 of src/app/lib/material-cutom-theme.scss
    >> @import '~/@angular/material/theming';

    Here is my includePaths in gulpfile.js

    gulp.task('compile-sass', function () {
        return gulp.src(srcLibPath + '**/*.scss', { base: './' })
          .pipe(sass(
            { includePaths: ['node_modules/'] }
            ).on('error', sass.logError))
          .pipe(gulp.dest('./'));
    });
    ChenLee
    @muzichen
    Does anyone online?
    Diego Gullo
    @bizmate
    hi folks, using sass in gulp can i tell it to render the css instead of the imports?
    @import url(../node_modules/aos/dist/aos.css);
    E.R. Nurwijayadi
    @epsi-rns
    I am online.