Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Sep 22 06:21
    ivnish opened #1713
  • Sep 20 07:26
    nicoschi synchronize #1712
  • Sep 19 16:58
    lmakarov review_requested #1712
  • Sep 19 16:58
    lmakarov assigned #1712
  • Sep 16 16:57
    justcaldwell commented #1693
  • Sep 16 12:49
    ChrisScrumping commented #1693
  • Sep 15 18:51
    justcaldwell commented #1693
  • Sep 15 15:29
    ChrisScrumping commented #1693
  • Sep 14 13:42
    nicoschi edited #1712
  • Sep 14 13:32
    nicoschi opened #1712
  • Sep 13 15:55
    jajajaime commented #1711
  • Sep 13 10:40
    nicoschi opened #1711
  • Sep 08 06:24
    DewitteNick commented #1707
  • Sep 06 14:44
    purcelltastic commented #1707
  • Sep 06 13:56
    vanelo commented #1422
  • Sep 06 13:33
    DewitteNick commented #1707
  • Sep 06 12:13
    mnavsa-openbox opened #1710
  • Sep 02 22:48
    mdyoung3 closed #1709
  • Sep 02 20:57
    mdyoung3 commented #1709
  • Sep 02 20:56
    mdyoung3 commented #1709
Justin Phelan
@jtphelan
I tried importing a large sql file (1.7GB) and it seems to have bricked my environments. If I shut down and restart the whole system and then start a site everything works, but as soon as I try to do anything (i.e. access it via browser or run a command) the DB container crashes. Any ideas on how to fix it?
~/Projects/devvlyd8 : fin start       
Starting services...
Starting devvlyd8_cli_1 ... done
Starting devvlyd8_db_1  ... done
Starting devvlyd8_web_1 ... done
Connected vhost-proxy to "devvlyd8_default" network.
Waiting for project stack to become ready...
Waiting for project stack to become ready...
Project URL: http://devvlyd8.docksal
~/Projects/devvlyd8 : fin status
     Name                  Command                State                 Ports           
----------------------------------------------------------------------------------------
devvlyd8_cli_1   /opt/startup.sh supervisord   Up (healthy)   22/tcp, 3000/tcp, 9000/tcp
devvlyd8_db_1    docker-entrypoint.sh mysqld   Exit 1                                   
devvlyd8_web_1   httpd-foreground              Up (healthy)   443/tcp, 80/tcp
2 replies
kevin-edmister
@kevin-edmister
I am attempting to get sanity.io studio to work with Docksal. My stack is node. Sanity installs and lists its path at "localhost:3333" when I install it into the CLI. I can't seem to get this to work at my http://testsite.docksal:3333. I'm sure I need to configure something to get this to work. I'm used to using Docksal for Drupal, so new territory here. Anyone out there gotten the sanity studio to work within the container? I need to run multiple sites. Ultimately I'm hoping to setup sanity studio at http://studio.testsite.docksal.
Boris Doesborg
@batigolix
Wondering if someone has an example docksal setup with multiple databases. I'm experimenting with a Drupal website that uses both a mysql and a postgres databases.
Ivan Berezhnov
@ivan-berezhnov
Hi community

I have added one more service to my
docksal.yml

manager:
    depends_on:
      cli:
        condition: service_started
    links:
      - cli
    hostname: manager
    image: docksal/nginx:1.14-1.0
    volumes:
      - project_root:/var/www:ro,nocopy,cached
    environment:
      - NGINX_VHOST_PRESET=php
      - NGINX_SERVER_ROOT=/var/www/docroot/manager
    labels:
      - io.docksal.virtual-host=manager.${VIRTUAL_HOST}

But have fail :(
docksal_manager_1 docker-entrypoint.sh nginx ... Exit 1

$ fin logs manager Attaching to exhibit-docksal_manager_1 manager_1 | /usr/local/bin/docker-entrypoint.sh: running /etc/docker-entrypoint.d/05-config-templates.sh manager_1 | /usr/local/bin/docker-entrypoint.sh: running /etc/docker-entrypoint.d/06-basic-auth.sh manager_1 | /usr/local/bin/docker-entrypoint.sh: running /etc/docker-entrypoint.d/07-user-overrides.sh manager_1 | /usr/local/bin/docker-entrypoint.sh: running /etc/docker-entrypoint.d/10-docker-cmd.sh manager_1 | 2021-04-30 15:04:52 | Passing execution to: nginx -g daemon off; manager_1 | 2021/04/30 15:04:52 [emerg] 1#1: host not found in upstream "php-fpm:9000" in /etc/nginx/includes/upstream.conf:4 manager_1 | nginx: [emerg] host not found in upstream "php-fpm:9000" in /etc/nginx/includes/upstream.conf:4

Can you please help me

2 replies
undersound
@undersound
Let's say I have a project of which I want an exact copy but under a different virtual host name, database seperated etc. What is the fasted / recommended way of doing that?
gabkdlly
@gabkdlly
I am interested in sharing Docksal with my team members, and think that a graphical-user-interface would help. Searching the web, I found this blog post: https://blog.docksal.io/upcoming-docksal-ui-8ee2d8ee9137
I searched the blog, but found no update on this, since the post from 2 years ago. I guess this is not being developed in the open?
Dinesh Kesarkar
@dinesh-kesarkar

Hi All, I am getting below thing while running bash <(curl -fsSL https://get.docksal.io) command, could you please guide me on how to resolve this problem:

curl: (60) server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.
Check file permissions and internet connection.

Stefan Ivic
@stefanivic
Hello everyone, I am was using NFS with ddev and decided to switch to Docksal. When I try to set it up, I am getting:
 ERROR:  There is an error in /etc/exports file
        Read through the error message(s) below and fix errors in /etc/exports manually
        Then run fin system reset
-----------------
---> Got line: # <ds-nfs docksal
---> Got line: /Users 192.168.64.1 192.168.64.100 -alldirs -maproot=0:0
/System/Volumes/Data using UUID 9BDBDE1E-515D-49F5-8771-127A1021935B
kernel export registered for /System/Volumes/Data/Users
---> Got line: # ds-nfs>
-----------------
 ERROR:  NFS sharing has failed
I am on MacOS using Docker for Mac and the /etc/exports file is empty.
gabkdlly
@gabkdlly
I am still pretty new to docksal, but like it enough that I want to stick with it on non-Wordpress projects. Specifically, I want to see if it can be useful for a Django stack. This does not seem to be a common thing, at least my web searches only inform me that docksal comes with Python. Has anyone here been using docksal for Django projects? Is there something novel I have to enter into my search engine? Or is this a bad idea?
aquuleus
@aquuleus

Hi Everyone, I'm running MacOS and I tried to change DOCKSAL_NFS_PATH variable to my external SSD "/Volume/Web/Projects" and when I do a "fin p start" It doesn't seem to work:

ERROR: for smartech_db_1 Cannot start service db: error while mounting volume '/var/lib/docker/volumes/smartech_project_root/_data': failed to mount local volume: mount :/Volumes/Web/Projects/smartech:/var/lib/docker/volumes/smartech_project_root/_data, flags: 0xc00, data: addr=192.168.64.1,vers=3,nolock,noacl,noctoCreating smartech_cli_1 ... error

ERROR: for smartech_cli_1 Cannot start service cli: error while mounting volume '/var/lib/docker/volumes/smartech_project_root/_data': failed to mount local volume: mount :/Volumes/Web/Projects/smartech:/var/lib/docker/volumes/smartech_project_root/_data, flags: 0xc00, data: addr=192.168.64.1,vers=3,nolock,noacl,nocto,actimeo=1: no such file or directory

The project works when added to my home folder ~/Projects

Could anyone help please ?

Robert Casties
@robcast
Did you check if your path made it into /etc/exports? On newer versions of Macos you may need to give disk access permissions to nfsd in system preferences...
aquuleus
@aquuleus
Screenshot 2021-06-10 at 11.09.38.png
Hey @robcast I've added the following /Volumes/Web/Projects 192.168.64.1 192.168.64.100 -alldirs -maproot=0:0 in /etc/exports. I've also authorized nfsd in System Preferences for Full Disk Access. It seems that only Redis is working
aquuleus
@aquuleus

I've managed to make it work after the following:

Formatting the SSD to APFS (exFAT is not supported by Docker)
Re-exporting /etc/exports with Docksal

Thanks for the help @robcast !
jacobsaw
@jacobsaw
Hi there - I'm working on configuring my fin init to run better with mutagen. I'm using a two-way sync and I'm trying to figure out the best way of handling when a user deletes files without containers running. Running fin reset solves the problem but I need to retain the database volume in some cases. Is there any way to trigger the project_root volume to recreate?
1 reply
dvmanjunathdv
@dvmanjunathdv

Hi, Bitbucket Pipelines is failing with source build.

  • source build-env
    bash: build-env: No such file or directory

I'm using below configurations

image: docksal/ci-agent:edge-php

options:
max-time: 40 # limit pipelines to 40 minutes

pipelines:

Pipelines that are triggered manually

custom:

# Stage: Partner site deployment
stage-platform-deploy:
  - step:
      caches:
        - composer
      name: Stage Platform site deployment
      script:
        - source build-env  # Initialize the agent configuration
        - TARGET_SITE=platform DB_NAME=platformmed scripts/bb-pipelines/deploy-stage.sh  # Deploy to Acquia stage
7 replies
Same was working fine on last Friday. Any idea why it's failing, is it issue with docksal or bitbucket?
dvmanjunathdv
@dvmanjunathdv
can some one help me if you have faced such issue
dvmanjunathdv
@dvmanjunathdv
Hi Everyone, when i'm doing Bitbucket to acquia deployment drush failing to find the alias. Nothing is changed in deployment scripts. any help is appreciated.
Thanks in advance
dvmanjunathdv
@dvmanjunathdv
We are are using AWS sandbox to run sandbox projects. Recently we started facing space issue. when we checked AWS server we used only 45% of the space.
Here is the error we get from bitbucket:
  • ssh docker-host "cd $REMOTE_BUILD_DIR && AUTH_USER='${AUTH_USER}' AUTH_PASS='${AUTH_PASS}' CI=${CI} DB_SOURCE=dev fin init" || (build-notify failure && exit 1)
    /home/build-agent/builds/natus-develop/.docksal/docksal-local.env: line 1: =: command not found
    Step 1 Initializing stack...
    /home/build-agent/builds/natus-develop/.docksal/docksal-local.env: line 1: =: command not found
    /usr/local/bin/fin: line 3500: cannot create temp file for here-document: No space left on device
    RTNETLINK answers: File exists
    ALERT: Some Docksal services were not running
       Restarting Docksal system services...
    /usr/local/bin/fin: line 3500: cannot create temp file for here-document: No space left on device
    Configuring network settings...
    /usr/local/bin/fin: line 3500: cannot create temp file for here-document: No space left on device
    sudo: unable to resolve host ip-xxx-xx-xx-xx
    RTNETLINK answers: File exists
    Resetting Docksal system services...
    • proxy
    • dns
      upstream 8.8.8.8
      Enabling automatic *.docksal DNS resolver...
    • ssh-agent
      OCI runtime exec failed: write /tmp/runc-process323885357: no space left on device: unknown
      Removing containers...
      Failed to write all bytes for _bisect.so
      fwrite: No space left on device
      Notifying Bitbucket Status API: ci/docksal => FAILED
4 replies
Do we need to increase Ram size to fix this?
Erich Haemmerle
@erichhaemmerle
I recently realized I need to edit a file that is in a Docksal container. It is the policy.xml file for ImageMagick. It is located in the container at /etc/ImageMagick-6/policy.xml. Obviously, I wouldn't want to bash into the container and directly edit the file. What is the proper way to add a custom version of this file when the container gets created? Then I'm assuming I could just do fin restart and the file would find its way into the container. Is there a way to specify this in docksal.yml or something? THANKS
3 replies
Richard Gilbert
@bixgomez
Hello, Docksal people! I am looking for SSL guidance. I just set up some WordPress sites in Docksal, having moved over from Lando recently. One of them is giving me grief about it, so I'd like to enable it and not continue to side-step it.
4 replies
Jeroen Noten
@jeroennoten
Does anyone know if there is a Docksal command that recreates the container but keeps the volume?
2 replies
Ryan Loos
@rloos289
Has anyone been able to successfully connect the google api to a docksal environment? I'm building a Drupal site and using the following module https://www.drupal.org/docs/contributed-modules/google-api-php-client/google-api-console-configurations. The problem is that I can't authenticate to a .docksal address. I've tried using fin share but I don't have a paid ngrok account to be able to configure it properly.
rmott-littler
@rmott-littler
Per https://docs.docksal.io/tools/acquia-cli/, I have both SECRET_ACQUIACLI_KEY and SECRET_ACQUIACLI_SECRET set globally, but fin pull db fails with "ERROR: SECRET_ACAPI_EMAIL and SECRET_ACAPI_KEY must be set in order to work with Acquia." What am I doing wrong?
4 replies
Shelane French
@shelane
@lmakarov and I appeared on Talking Drupal to discuss Docksal. Check it out: https://talkingdrupal.com/306
1 reply
jacobsaw
@jacobsaw
Hi, upgraded to 1.16.0 and trying to figure out how to work around a proxy port issue with XDebug. In the past, I exposed 9001 in my docksal.yml file and updated my PHPStorm settings to listen on that port. Now I'm getting Xdebug: [Step Debug] Could not connect to debugging client. Tried: 192.168.64.1:9000 (through xdebug.client_host/xdebug.client_port) :-( while running commands. Is there a way to change the xdebug.client_port variable?
6 replies
Chris Zietlow
@aczietlow
Before I go down this rabbit hole, are there any existing docksal images or documentation of adding Apache Tika to the cli container?
2 replies
Leonid Makarov
@lmakarov

@/all We are transitioning Docksal Community Support over to GitHub Discussions

Gitter served us well for all these years, but it cannot provide a good structure and discoverability for all of the knowledge being shared in this room.

GitHub Discussions provides a Q&A/forum like experience, with categories, topics, upvoting, selecting the best answer for a question, etc. On top of that, it's GitHub, so one less thing for us to maintain and for you to log into.


⚠️Please post any questions and ideas over at https://github.com/docksal/docksal/discussions ⚠️

Shahnawaz Mohammed
@mshanawaz114
Hello Guys, Any sugesstions here on my authentication issue for cloud instances drush interactions:

$ fin drush @medicaid.test cr
Bad owner or permissions on /home/docker/.ssh/config

In Process.php line 266:

The command "ssh -t -o PasswordAuthentication=no medicaid.test@medicaidstg.ssh.prod.acquia-sites.com 'drush9 cr --uri=medicaidstg.prod.acquia-si
tes.com --root=/var/www/html/medicaid.test/docroot'" failed.

Exit Code: 255(Unknown error)

Working directory:

Output:

Error Output:

Appreciate any helps thank you in advance :)
docans
@docans
Hi I am trying to install docsal on Windows 10 WSL using Ubuntu-20.04 and i got this error
curl: (6) Could not resolve host: get.docksal.io Any idea how to fix this
docans
@docans

Hi. I just installed Docksal on my wsl2 windows 10 ubuntu using
DOCKER_NATIVE=1 bash <(curl -fsSL https://get.docksal.io)
but i cant seem to access the url http://d9.docksal on the front end of the site.

Do i need to add the 127.0.0.1 d9.docksal to my windows host file or what do i need to do.

aquuleus
@aquuleus
Hi Everyone, since the update to the latest Docksal version, I'm having an issue on MacOS. Everything is running under 0.0.0.0 and no containers are therefore reachable (attached is a screenshot of docksal-vhost-proxy default configuration)
Screenshot 2022-05-10 at 13.49.39.png
aquuleus
@aquuleus
Just FYI. After doing a "fin update" I had to re-install Docker and this fixed the proxy issue
aquuleus
@aquuleus
Actually, nope it re-fails after a "fin p restart".. Does anyone is having the same issue with v1.17.0 ?
Leonid Makarov
@lmakarov
⚠️ This room is retired. ⚠️
⚠️ Please post any questions and ideas over at https://github.com/docksal/docksal/discussions ⚠️
dualizeo
@dualizeo:matrix.org
[m]
Finally found a room I was looking for! :D
Anatolii Poliakov
@anpolimus
Hello. I'm facing with a strange issue on my new project.
I have next images:
WEB_IMAGE='docksal/web:edge-apache2.2'
CLI_IMAGE='docksal/cli:php8.1-3.2'
and getting this old style error
image.png
Patrick Ray. Huang
@phuang07
hi, I have trouble to run phpunit browser test for drupal (i am on v9.3), it seems by setting the "SIMPLETEST_BASE_URL" to the virtual host making test fail. Could someone point me to any reference on setting up drupal functional test using docksal