Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 07 2020 13:24
    clairernovotny unassigned #7
  • May 07 2020 13:24
    BillWagner added as member
  • May 07 2020 13:24
    BillWagner removed as member
  • May 07 2020 13:22
    clairernovotny closed #182
  • May 07 2020 13:22
    clairernovotny commented #182
  • May 07 2020 13:21
    clairernovotny closed #192
  • May 07 2020 13:21
    clairernovotny commented #192
  • May 04 2020 08:11
    MarcoRossignoli opened #192
  • Apr 30 2020 15:40
    NextTurn closed #154
  • Apr 30 2020 02:54
    NextTurn commented #191
  • Apr 29 2020 15:53

    clairernovotny on master

    Fix broken links Split from dot… Merge pull request #191 from Ne… (compare)

  • Apr 29 2020 15:53
    clairernovotny closed #191
  • Apr 29 2020 15:53
    clairernovotny commented #191
  • Apr 29 2020 15:39
    NextTurn opened #191
  • Apr 29 2020 14:06

    clairernovotny on master

    Fix broken links Split from #154 Merge pull request #190 from Ne… (compare)

  • Apr 29 2020 14:06
    clairernovotny closed #190
  • Apr 29 2020 14:06

    clairernovotny on master

    Fix broken links Split from #154 Merge pull request #189 from Ne… (compare)

  • Apr 29 2020 14:06
    clairernovotny closed #189
  • Apr 16 2020 15:55
    NextTurn opened #190
  • Apr 15 2020 15:55
    NextTurn opened #189
TeBeCo
@tebeco
what the relation between hot reload and authN that i'm missing ?
patrick szymkowiak
@pszymkowiak
today all examples specify to enter information in appsettings.json. is it possible to have blazor running and set azure ad authentification without reload the blazor app ?
Ambulatur
@AMBULATUR
Good day, there is a hosting on which i can run a web application only with the .net Framework 4.5 (.0) version, is it possible to somehow ignore and run DotVVM which requires the framework 4.5.1 version>= ?
Stephen A. Imhoff
@Clockwork-Muse
@AMBULATUR - I think I'd be curious as to why you're using a host that can only do a nine-year old release (and one that's been out of support for five). Especially since running something with .Net core would be much easier for them (linux container).
Ambulatur
@AMBULATUR
image.png
not me select that host, btw how can i compile obj/scripts? tsc return errors :
when i try compile project dotvvm/Framework i got missing scripts(obj/script)
image.png
After install Nuget TS MSBuild - throw errors, i'm doing wrong smthing ?
Eugene Krapivin
@EugeneKrapivin

Yo guys, we're currently using app-metrics to gather metrics from our services into influx db, and I'm having doubts about it. It reports too much metrics unless specifically filtered, some of the metrics reported are not intuitive, there is a strange behavior where metrics are kept being reported even though no new reports came in (i.e. no traffic on the service) so it reports 0s.

What are you using to gather and report application metrics in you apps?

Buğra
@BgR8
Hi, while run the code it shows System.NullReferenceException: on 43th line,
var img = capture.QuerySmallFrame();
the code is
using Alturos.Yolo;
using Alturos.Yolo.Model;
using Emgu.CV;
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Drawing.Imaging;
using System.IO;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Windows.Forms;

namespace YoloWebCam
{
    public partial class Form1 : Form
    {
        VideoCapture capture;
        public Form1()
        {
            InitializeComponent();
            Run();
        }

        private void Run()
        {
            try
            {
                capture = new VideoCapture(1);
            }
            catch (Exception Ex)
            {
                MessageBox.Show(Ex.Message);
                return;
            }
            Application.Idle += ProcessFrame;
        }

        private void ProcessFrame(object sender, EventArgs e)
        {
            var img = capture.QuerySmallFrame();
            pictureBox1.Image = img.Bitmap;
            Detect();
        }

        private void Detect()
        {
            var configurationDetector = new ConfigurationDetector();
            var config = configurationDetector.Detect();
            var yolo = new YoloWrapper(config);
            var memoryStream = new MemoryStream();
            pictureBox1.Image.Save(memoryStream, ImageFormat.Png);
            var _items = yolo.Detect(memoryStream.ToArray()).ToList();
            AddDetailsToPictureBox(pictureBox1, _items);
        }

        private void AddDetailsToPictureBox(PictureBox pictureBox1, List<YoloItem> items)
        {
            var img = pictureBox1.Image;
            var font = new Font("Arial", 18, FontStyle.Bold);
            var brush = new SolidBrush(Color.Red);
            var graphics = Graphics.FromImage(img);
            foreach (var item in items)
            {
                var x = item.X;
                var y = item.Y;
                var width = item.Width;
                var height = item.Height;
                var tung = item.Type;
                var rect = new Rectangle(x, y, width, height);
                var pen = new Pen(Color.LightGreen, 6);
                var point = new Point(x, y);

                graphics.DrawRectangle(pen, rect);
                graphics.DrawString(item.Type, font, brush, point);
            }
            pictureBox1.Image = img;
        }

        private void Form1_Load(object sender, EventArgs e)
        {

        }
    }
}
Buğra
@BgR8
how can i solve this problem, i'm the new for c# and want to learn object detection,
TeBeCo
@tebeco
put a breakpoint ?
Buğra
@BgR8

put a breakpoint ?

i tried but don't understand,
put breakpoint to line 43.
var img = capture.QuerySmallFrame(); and run
alt

and click continue and passed to the next line and it shows System.NullReferenceException:

TeBeCo
@tebeco
is capture null ?
if not null once it throw check the callstack/stack frame panel
right click > show external
you might have info on internal code throwing
you can attempt to load symbol and disable "just my code"
and try to debug that code that is not yours
you might find why
it's hard to give more detail from a phone ^^
Ghost
@ghost~6092e2a96da03739847be599
hello everyone
I have a doubt regarding Authentication and Authorization... is this a good place to ask?
Juan Ramos
@ptjuanramos

Hi there, I'm having a trouble with the Generic host configuration.

Host.CreateDefaultBuilder(args)
.ConfigureWebJobs(b => b.AddAzureStorage())
.ConfigureWebHostDefaults(b => b.UseStartup<Startup>());

I have this configured, but when I try to get a value from IConfiguration it actually returns the appsettings.json and not appsettings.development.json :/

Oisin Grehan
@oising
@ptjuanramos set DOTNET_ENVIRONMENT environment variable to "Development"
Juan Ramos
@ptjuanramos
Hi there, sorry for the delay, the environment was set to Development. The problem is when you use the .ConfigureWebJobs(b => b.AddAzureStorage()) builder method... It resets the configurations that CreateDefaultBuilder(...) places in the HostBuilder regarding the appsettings. It's actually a bug for WebJob Sdk. The solution was to re-set the appsettings configurations
Sean
@DapperDeer
hi there, I'm having an issue where I run dotnet build and in my output there is a runtimes folder that contains only linux runtimes, even if I add the --runtimes win-x64 argument. Any advice? To be clear, the --runtimes win-x64 argument does include the win-x64 dll, but it just plops it into my output folder rather than creating a win-x64 folder in runtimes and putting the dll in there.
TeBeCo
@tebeco
aren't you suppose to use dotnet publish for that ?
build is only meant for local dev time
publish is to get something shippable
it adds extra step after the build to be sure the thing "publish" will contains what it needs and are no more depending on your setup
idea is that build is then faster / dedicated only to build FOR YOU
Sean
@DapperDeer
I experience the same issue with dotnet publish
TeBeCo
@tebeco
you have a link to the repo on github ?
This message was deleted
TeBeCo
@tebeco
could be a dependency targeting ns1.x
also your other comment did not mentioned the publish folder
TeBeCo
@tebeco
you're not supposed to look parent folder
bin/<config >/<tfm>/<rid>/publish
Sean
@DapperDeer
There is a GitHub repo but it's a private org. I didn't mention the publish folder because I end up packing the project in the end, not publishing it.
TeBeCo
@tebeco
so no rid then
Thomas Crosman
@TCrosmanDSI
hey anyone here?
Irene Kors
@ik130

Hello AWS .NET community! .NET SDK team is conducting a survey to learn about your recent experiences working with the AWS SDK for .NET and its learning resources. Please help us improve the SDK by taking a few minutes to answer the survey questions.

https://amazonmr.au1.qualtrics.com/jfe/form/SV_bqfQLfZ5nhFUiV0

Filip Vukovinski
@vukovinski
mmm, is MAUI supported in the latest preview of VS 2022?
TeBeCo
@tebeco
check the release note of net6 preview5
regarding sdk workload especially
and there's also a part in vs2022 release not IIRC
Rui Oliveira
@ruilvo
Is this channel adequate for general .net discussion?