These are chat archives for dronekit/dronekit-android

7th
Jun 2016
Randy Mackay
@rmackay9
Jun 07 2016 02:57
@ne0fhyk, not sure if this is the place to ask but I was trying to get video from my NVidia TX1 (running Ubuntu 14.04) to display in Tower. I got the test pattern able to send to tower with no issues, I also got the live video to display on my ubuntu laptop with no problems but when I try to get the live video to display on Tower something appears but it's corrupted somehow. It's like a grey cloud.. the top 80% of the image is always solid grey, the bottom 20% sort of moves around a bit like a wispy cloud. I'll paste my gstreamer commands below in a moment.
running this command on my TX1 allows me to send successfully to my ubuntu laptop:
gst-launch-1.0 -v -e v4l2src device=/dev/video0 ! queue ! video/x-h264,width=640,height=480,framerate=15/1 ! h264parse ! rtph264pay ! udpsink host=10.0.1.254 port=9000
I tried all kinds of different frame rates and height/width combination and it didn't seem to help. removing the queue also didn't help.
Randy Mackay
@rmackay9
Jun 07 2016 03:02
I also looked at the instructions on the Tower wiki from someone who successfully sent from an RPI2 and tried adding the "config-interval" and "pt" commands after the rtph264pay but that didn't help either
By the way, this is all part of my project (sponsored by my new employer) to add open source vision based follow-me, precision landing and then finally GPS denied position estimation and navigation