These are chat archives for dronekit/dronekit-android

14th
Dec 2016
wyq200704
@wyq200704
Dec 14 2016 01:05
i copy the mavlink repo but found pymavlink filefolder have no file
@billbonney
i donot know which mavlink version should choose
wyq200704
@wyq200704
Dec 14 2016 01:11
i used the git submodule init and update,and get the pymavlink submodule sucess
Bill Bonney
@billbonney
Dec 14 2016 03:36
@wqy200704 used master from 28th Nov and it works. see PR of the same
wyq200704
@wyq200704
Dec 14 2016 03:36
i have a try now
right now
Bill Bonney
@billbonney
Dec 14 2016 03:37
I will make MAVLink a submodule of project, so it will be easier in the future
wyq200704
@wyq200704
Dec 14 2016 03:40
i get an error "ImportError: No module named future"
Bill Bonney
@billbonney
Dec 14 2016 03:41
sudo pip install future lxml
that will fix it
wyq200704
@wyq200704
Dec 14 2016 03:43
oh i compile the project in windows
so i change to ubuntu,and have a tyr
try
Bill Bonney
@billbonney
Dec 14 2016 03:45
it’s just some extar dependecies that was added to pymavlink recently
wyq200704
@wyq200704
Dec 14 2016 03:46
btw, i donot know why add the uAvionix.xml?
Bill Bonney
@billbonney
Dec 14 2016 04:12
you don’t need to
I just pasted the command I added before. I added it as I want to look at adding ADSB info packets to the map and I think it’s required for that
wyq200704
@wyq200704
Dec 14 2016 06:03
i recreate the java file about mavlink,but when i compile the dronekit-android project , i got another error D:\android\dronekit-android\ClientLib\src\main\java\org\droidplanner\services\android\impl\core\MAVLink\connection\MavLinkConnection.java
mavlinkResetStats()
wyq200704
@wyq200704
Dec 14 2016 06:32
i have not found 28th Nov,the ver of mavlink of master is 2016-11-08 julinan oes
wyq200704
@wyq200704
Dec 14 2016 06:50
now the error i get is File "lxml.etree.pyx", line 3239, in lxml.etree.parse (src/lxml/lxml.etree.c:69955)
File "parser.pxi", line 1769, in lxml.etree._parseDocument (src/lxml/lxml.etree.c:102257)
File "parser.pxi", line 1789, in lxml.etree._parseFilelikeDocument (src/lxml/lxml.etree.c:102516)
File "parser.pxi", line 1684, in lxml.etree._parseDocFromFilelike (src/lxml/lxml.etree.c:101442)
File "parser.pxi", line 1134, in lxml.etree._BaseParser._parseDocFromFilelike (src/lxml/lxml.etree.c:97069)
File "parser.pxi", line 582, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/lxml.etree.c:91275)
File "parser.pxi", line 683, in lxml.etree._handleParseResult (src/lxml/lxml.etree.c:92461)
File "parser.pxi", line 622, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:91757)
lxml.etree.XMLSyntaxError: AttValue: ' expected, line 1832, column 33
wyq200704
@wyq200704
Dec 14 2016 07:19
if i use the origin ardupilotmega.xml ,i could create the java files success,but when using the ardupilotmega of dronekit it failed
mismyname93
@mismyname93
Dec 14 2016 14:21
hello , hi im new here :)