These are chat archives for dry-rb/chat

19th
Nov 2016
Soumya Ray
@soumyaray
Nov 19 2016 04:48
Greetings, I just installed dry-validation (0.10.3). As soon as i require 'dry-validation' in my code or in pry, I get this warning:
/Users/soumyaray/.rvm/gems/ruby-2.3.1/gems/dry-validation-0.10.3/lib/dry/validation/message_compiler.rb:13: warning: already initialized constant Dry::Validation::MessageCompiler::EMPTY_OPTS
/Users/soumyaray/.rvm/gems/ruby-2.3.1/gems/dry-core-0.2.1/lib/dry/core/constants.rb:52: warning: previous definition of EMPTY_OPTS was here
Tim Riley
@timriley
Nov 19 2016 07:17
@soumyaray that's a known issue, and nothing to worry about. We'll be hopefully fixing soon.
Soumya Ray
@soumyaray
Nov 19 2016 07:20
@timriley thanks! i started an issue on the repo because i didn't see it listed. i'll close it then?
Tim Riley
@timriley
Nov 19 2016 07:45
I dunno, feel free to leave it, we can always close it later.