Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 05:47
    solnic commented #72
  • Apr 22 18:05
    ytaben commented #72
  • Apr 22 18:05
    ytaben commented #72
  • Apr 22 18:04
    ytaben commented #72
  • Apr 22 14:16
    ytaben synchronize #72
  • Apr 22 14:04
    ytaben synchronize #72
  • Apr 22 12:55

    timriley on master

    Bump dry-system to 0.19.0 (compare)

  • Apr 22 12:55

    timriley on v0.19.0

    Bump dry-system to 0.19.0 (compare)

  • Apr 22 12:49

    dry-bot on master

    [devtools] sync (compare)

  • Apr 22 12:48

    timriley on master

    Update changelog (compare)

  • Apr 22 12:48

    dry-bot on master

    [devtools] sync (compare)

  • Apr 22 12:47

    timriley on master

    Update changelog (compare)

  • Apr 22 06:26
    solnic review_requested #72
  • Apr 22 06:26
    solnic commented #72
  • Apr 22 01:57

    dry-bot on master

    [devtools] sync (compare)

  • Apr 22 01:57

    timriley on master

    Fix changelog (compare)

  • Apr 22 01:34

    dry-bot on master

    [devtools] sync (compare)

  • Apr 22 01:34

    timriley on master

    Add changelog entry for 0.19.0 … (compare)

  • Apr 22 01:34

    timriley on add-0-19-0-changelog

    (compare)

  • Apr 22 01:34
    timriley closed #161
Hunter Madison
@hmadison
Dependent types also do a lot of work
If you never looked at them, its a cool concept
Hannes Nevalainen
@kwando
never looked at dependent types, do you know some short ruby code that would illustrate it?
Piotr Solnica
@solnic
@hmadison I haven’t thought about dependent types actually
@kwando no, sorry, nothing from the top of my head (also googling yields no concrete results)
Hunter Madison
@hmadison
No i dont
Hannes Nevalainen
@kwando
aw =/
Piotr Solnica
@solnic
@AMHOL @kwando ^
I also ported the thing to use dry-container so now we can simply register types under symbol keys
Luca Guidi
@jodosha
OMG it returns None :heart:
Piotr Solnica
@solnic
@jodosha hah yeah…I really really wanted that
I wonder if it makes sense to register optional types for all built-in primitives so that you get it OOTB hmmm
also optional_string vs maybe_string? I kinda like “maybe” more :)
@AMHOL I’m thinking about a predicate micro-system that we could share between dry-data and dry-validators, feels like this could be a generic functionality
Andy Holland
@AMHOL
@solnic v.nice :smile:
Piotr Solnica
@solnic
@AMHOL I’m sorry I didn’t pursue our “distributed TDD” idea…but I’m happy to do that next time with something that’s less urgent for me, sounds good?
another thing is separation between simple type-check and coercible-type-check, not sure how those things should be called in container :/
Andy Holland
@AMHOL
@solnic you did a much better job than I would have anyway
Piotr Solnica
@solnic
@AMHOL nah :) but thanks ;)
Peter Saxton
@CrowdHailer
I would vote for maybe_string options get used all over the place.
All looking good now I am reading through learn you a haskell
Piotr Solnica
@solnic
@CrowdHailer yeah I think I will rename it
Andy Holland
@AMHOL
@solnic AMHOL/roda-flow@c882a51 cleaned up roda-flow :)
Piotr Solnica
@solnic
Thoughts on coercible vs noncoercible type identifiers?
atm we use kernel coercions for all primitives but quite often you want to skip that
`
"coercible.string" maybe but I dunno
Andy Holland
@AMHOL
Don't forget about namespace in container for that :)
How about strict.string ?
Could use maybe/always but would probably be a bit weird
Piotr Solnica
@solnic
Then you can have things like "form_input.date"
Andy Holland
@AMHOL
:clap:
Piotr Solnica
@solnic
Hmm I like that yeah, so strict is just typecheck and coercible will first coerce then typecheck
Notice that type check can be anything not just class verification
Andy Holland
@AMHOL
Cool, so could just be a respond_to?
Piotr Solnica
@solnic
@AMHOL any constraint you want but I would prefer strict type check in most cases
Benjamin Klotz
@tak1n
optional_string haters gonna hate, but I love it :D
Piotr Solnica
@solnic
I am optional_string haters hater ;)
Benjamin Klotz
@tak1n
hehe :P
u are using kleisli under the hood right?
love unneeded questions xD
Piotr Solnica
@solnic
@tak1n yeah, I like kleisli
Benjamin Klotz
@tak1n
awesome :D
Piotr Solnica
@solnic
hey so maybe (no pun intended) we should switch to namespaced names?
Andy Holland
@AMHOL
+1
Piotr Solnica
@solnic
”strict.string” ”maybe.string” ”form_input.maybe.string”
Andy Holland
@AMHOL
here
Benjamin Klotz
@tak1n
+2