Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 26 14:38
    2548ir closed #4678
  • Jan 26 14:11
    Jimmi08 commented #4678
  • Jan 26 14:08
    Jimmi08 commented #3090
  • Jan 26 10:33
    Dannyboy001 starred e107inc/e107
  • Jan 26 08:38
    2548ir opened #4681
  • Jan 26 08:38
    2548ir labeled #4681
  • Jan 26 07:15
    2548ir labeled #4680
  • Jan 26 07:15
    2548ir opened #4680
  • Jan 26 07:09
    2548ir labeled #4679
  • Jan 26 07:09
    2548ir opened #4679
  • Jan 26 06:57
    2548ir opened #4678
  • Jan 26 06:57
    2548ir labeled #4678
  • Jan 26 06:45
    2548ir labeled #4677
  • Jan 26 06:45
    2548ir opened #4677
  • Jan 26 06:33
    2548ir opened #4676
  • Jan 26 06:33
    2548ir labeled #4676
  • Jan 26 06:26
    2548ir opened #4675
  • Jan 26 06:26
    2548ir labeled #4675
  • Jan 25 18:57
    Jimmi08 commented #4570
  • Jan 25 18:46
    Jimmi08 commented #4570
Jimako
@Jimmi08
Nevermind, now I am trying to find why my theme version is 2,3 (comma) and not 2.3 (dot). Funny.
Jimako
@Jimmi08
@tgtje look at bootstrap5 core theme and set bootswatch on, you will see that bootstrap is loaded 2x (bootstrap.min.css) and it is loading bootstrap 4 in fact. Maybe intention? No idea.
Windthin
@Windthin
What type of encryption is e107 currently using for passwords?
2 replies
izatar2020
@izatar2020
I am using e107 version 07. 24 and the Movie Menu Plug In for YouTube videos has stopped working. It still appears in the correct menu location, but as a blank box. Any suggestions as to how to get it started again. All the videos are still there, but when I activate them, none of them display. Thanks for any suggestions.
Jimako
@Jimmi08
Check console, if it uses Flash, you should see something there... Link to site would help.
Jimako
@Jimmi08
Hi, is still toDb() way how to filter/sanitize form inputs? I noticed some changes in filtering lately, not sure if this still stays. Before it should be intval() for numbers and toDb() for strings. Is it still correct?
8 replies
Jimako
@Jimmi08
image.png
Next question. Something like this (allowed tags) is not in e107, correct? (I can't find it). If tinymce4 is used, how to allow only those tags before saving?
3 replies
oui3kings
@oui3kings
Not sure if what I’m experiencing is a hack or something else. To sum it up quick. Entertaining root url gives a 500 error. I can get to admin, can also get to other url’s just can’t type in and go to root url. .htaccess file is fine wasn’t altered. Not sure what other file could have been changed or what else would cause the problem. Looked through sys logs and there was an ip blocked for flooding early in the morning
oui3kings
@oui3kings
@Jimmi08 just saw your post about e107/WP combination. Very interesting!
Jimako
@Jimmi08
Thanks. I just don't believe WP with data. And it solves design issues. Easy stuff in WP, custom coding in e107.
Tijn Kuyper
@Moc
@oui3kings check your apache error logs (or ask your hosting provider). These logs contain the actual error information. It's not likely to be a hack.
Jimako
@Jimmi08
Hi, what could be missing if all my dates are in English (member since, last visit...). Thanks
leo
@tgtje
@Jimmi08 where does it happen? In plugin (menu online) or throughout the system? Single language or multiple?
Jimako
@Jimmi08
in all system, for example on user profile, 2 languages, frontend in Slovak, admin sometimes in EN or SK...
image.png
I couldn't find any strings or anything. Missing translation somewhere?
oui3kings
@oui3kings
@Moc Thank you. Yes, the host did an automatic php upgrade that I wasn’t expecting
leo
@tgtje
@Jimmi08 never took real notice Jimmi, so : i confirm he issue. Overall one could say at most places (not all) date is English.. Now the search where something did change (do believe it is in coding somewhere. (for now just to inform you it is likely system).
Jimako
@Jimmi08
@tgtje thanks for your effort.
Jimako
@Jimmi08
@Deltik your fix for 8.1. introduced this problem - strftime is deprecated. Our timezone is set correctly, I am not able to check more.
3 replies
leo
@tgtje
userb.jpg
14 replies
Jimako
@Jimmi08
image.png
site from September, it is translated
Jimako
@Jimmi08
Guys, how to set midnight ? it still falls to 1 hours:
@LaocheXe Will you use Christmas Lights this year? How do you set it?
Travis Thoene
@LaocheXe
@Jimmi08 Yes, but I can't get them to move down any lower - https://www.501stlegion-a3.com/
Jimako
@Jimmi08
Mine work.
just theme issue, signin is there.
Travis Thoene
@LaocheXe
true*
The only thing I couldn't get to work on any of my sites was the 3D snow - but you got it to work on yours so idk lol
Jimako
@Jimmi08
How do you know? It wasn't the intention, yes, it is snowing now, but it can be seen only on the black menu...
Travis Thoene
@LaocheXe
Snow Type = Snow Storm <--- works, However, Snow Type = 3D Snow doesn't - even with the Christmas bulbs enabled/disabled
The Normal Lights don't even work on my end - I don't even get an error message, but currently working on another project atm.
Jimako
@Jimmi08
Thanks for help.
Travis Thoene
@LaocheXe
Question, how would one go about checking to see if a user isn't already in the database, and stop the creation of a new entry in admin_config.php? Thought by adding an if statement in beforeCreate using $new_data['user_id'], with $sql->count() if($check_user_id > 0) displayError. but it creates the new entry
1 reply
Jimako
@Jimmi08
Hm, it ignores those times now. I had to set it fully off.
Travis Thoene
@LaocheXe
@Jimmi08 Think I might jump into FallingHolidays plugin, and maybe re-code the js, and css files into php files like I did with the Unit Clock plugin
5 replies
Jimako
@Jimmi08
Hi, where to look for good example of ratings (stars)? Download plugin? I can see that all votes are in single field (for some item), is there way / example how to get all user votes (list of all one user votes) ?
Jimako
@Jimmi08
Hi, is there some reason why not use MPREFIX and not # in queries? I mean, it is a bit annoying not be able to copy query directly to phpmyadmin if you are working on something.
leo
@tgtje
@Jimmi08 @Deltik @CaMer0n language do seems to display nicely know (github 2.3.1. git sync; php 7.4.22 live). :ok_hand:
4 replies
Jimako
@Jimmi08
Why - if admin deletes news comment in admin area, different query is used than if comment is deleted on frontend? news_comment_total = CAST(GREATEST(CAST(news_comment_total AS SIGNED) - 1, 0) AS UNSIGNED) WHERE news_id='.$deleted_data['comment_item_id'] versus news_comment_total=news_comment_total-1 WHERE news_id=".$id
Jimako
@Jimmi08
Why different users can't send the same comment to the same item? Is it intention?
Jimako
@Jimmi08
Hi, toText() is removing new lines, is this correct?
Jimako
@Jimmi08
No, probably this is going https://www.php.net/manual/en/function.strip-tags.php#110280 some words are getting together... how to rid tinymce field all HTML tags to get the correct words count?
Jimako
@Jimmi08
I suppose you are aware that any bootstrap below 3.3.7 is not compatible with JQuery 3? For admin bootstrap3 you are loading jquery2, why it can't be the general rule, that Jquery3 is used only for themes bootstrap 4 and 5? I know that you can change this in the config file, but it is considered a workaround and people don't know about this. The problem is that I tried to use 3.3.7 but other theme scripts stopped working (3.3.2 was used originally) and the original author didn't update the HTML theme. Why JQuery version can't be set in theme.xml then?
Jimako
@Jimmi08
Any idea why this is happening? clean libraries, no workaround
image.png
Jimako
@Jimmi08
Hi, could somebody check if comments in FAQ plugin work? Thanks
Jimako
@Jimmi08
@Moc or somebody - Feature requests should go to Discussions/Ideas now? Or still in issues?
6 replies