Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 16:29

    bogdan-bondar on master

    Upgraded few dependencies (#129… (compare)

  • 16:29
    bogdan-bondar closed #1296
  • 16:27
    ramannas synchronize #1296
  • 15:26
    stefbehl opened #1299
  • Dec 07 15:32
    herdt-michael synchronize #1293
  • Dec 07 14:27
    hawkbit-bot commented #1298
  • Dec 07 14:26
    StefanKlt opened #1298
  • Dec 02 07:07
    hawkbit-bot commented #1297
  • Dec 02 07:06
    StefanKlt edited #1297
  • Dec 02 07:04
    StefanKlt opened #1297
  • Nov 30 15:11
    ramannas synchronize #1296
  • Nov 30 14:47
    hawkbit-bot commented #1296
  • Nov 30 14:40
    ramannas opened #1296
  • Nov 30 14:03
    StefanKlt synchronize #1294
  • Nov 30 13:37
    StefanKlt synchronize #1294
  • Nov 30 12:59
    StefanKlt synchronize #1294
  • Nov 30 07:03
    StefanKlt synchronize #1294
  • Nov 29 15:18
    StefanKlt synchronize #1294
  • Nov 29 15:02
    herdt-michael synchronize #1293
  • Nov 29 13:24
    dimitar-shterev synchronize #1294
Bondar Bogdan
@bogdan-bondar
@esramirez if DDI API generates the correct link and you are able to download the artifact the problems lies not within the Hawkbit server, but rather on the client, please consult swupdate project. In case you narrow down the problem/have more logs/insights of what is happening on the client we can continue the discussion
rmk544
@rmk544
@JulianFeinauer
Hi Julian,
I am quickly trying to verify if Hawkbit is useful for my project and since I am a beginner, can you kindly give me a quick python script which you used in your youtube video to download and save an artifact which would greatly help me in knowing thins in more detail...
I saw you were using DDI APIs and a "hawkbit_quickstart.py" script which could possibly help in verifying just connect to hawkbit and download an image...
Thanks very much,
R.M Kumar
Julian
@JulianFeinauer
Hey @rmk544 you can find the code here https://github.com/JulianFeinauer/webinar-hawkbit
rmk544
@rmk544
Hi Julian,
Thanks so much for your help.
Best Regards,
rmk544
@rmk544
@JulianFeinauer
Hi Julian,
as specified on your github, I have created a distribution of app only and then uploaded the Jar file. but whatever I am trying assign the software module to the distribution, I get "Action not allowed" I have been trying hard but no success so-far..
The message is so cryptic it doesn't say what is the reason...
However your demo video, you did it with ease and wondering what I am missing..
Pls help
Best Regards,
Julian
@JulianFeinauer
@rmk544 hm... I have no idea... Perhaps the hawkbit version changed since then? I can try to look into it later today but it should work pretty straight forward. Perhaps you missed to mark the distribution as "application" and not OS?
rmk544
@rmk544
@JulianFeinauer
@JulianFeinauer
Sorry to bother, I did mark as application, tried an image "recovery.img" as OS, OS with apps... all I tried. But no way it works.
I am wondering how others also reporting these issues, though it is a proven in IOT space.
anytime you are free or have some hint, pls share it.
Best Regards,
Diego Rondini
@diegorondini
@bogdan-bondar link from the docs to sandbox is dead (https://hawkbit.eclipse.org/) while sandbox itself is fine (https://hawkbit.eclipseprojects.io/UI/)
Bondar Bogdan
@bogdan-bondar
@diegorondini thanks for pointing this out, will fix it soon
1 reply
GauravSharma77
@Sharma77Gaurav_twitter
I have the Hawkbit running on my Ubuntu server and am able to successfully run it and use it. I simulated a load of 10,000 devices successfully without any issue. However, what I see is that even after the test load run is finished , there are certain DB queries that are still running and the CPU consumption does not drop to pre load test levels. Any pointers would be helpful. I see the below type of queries running in DB.

db: hawkbit

Command: Query

Time: 0

State: executing

Info: SELECT DISTINCT t1.id AS a1, t1.tenant AS a2, t1.address AS a3, t1.controller_id AS a4, t1.created_at AS a5, t1.created_by AS a6, t1.description AS a7, t1.install_date AS a8, t1.last_modified_at AS a9, t1.last_modified_by AS a10, t1.last_target_query AS a11, t1.name AS a12, t1.optlock_revision AS a13, t1.request_controller_attributes AS a14, t1.sec_token AS a15, t1.update_status AS a16, t1.assigned_distribution_set AS a17, t1.installed_distribution_set AS a18, t1.target_type AS a19 FROM sp_target t1 LEFT OUTER JOIN sp_action t0 ON ((t0.target = t1.id) AND (t0.distribution_set = 44)) WHERE (((UPPER(t1.controller_id) LIKE 'BN-%' ESCAPE '\' AND (t1.created_at > 1642395600000)) AND (t0.id IS NULL)) AND (t1.tenant = 'DEFAULT')) LIMIT 0, 999

Akaarir Mohamed
@Akanichi
Hi everyone, i have a problem with limite of storage so i get the error message from the web application of hawkbit when i upload a new file, here is the error message : Storage quota exceeded, 119 MB left
So when i removed a bundle's file i don't get this message anymore, and when i wanted to upload a new file, i get the same error message,
what's the way to change the storage quota?
Thank you!
1 reply
rmk544
@rmk544
Hi All,
Need some help,
If I have thousands of device clients for updating, then what is the best way to name them?
Can all of them have same ControllerID or TargetName?
If not what is the best scheme to name?
Regards,
Diego Rondini
@diegorondini
Hi. This message is for the Bosch SI team working on the Bosch IoT Rollouts implementation of hawkBit. We'd like to make sure the hara-ddiclient works just fine with IoT Rollouts. We see that in your implementation you use CDN for download of artifacts and we have a questions about that: how do you manage the generation of the CDN URL? Is the client redirected to a CDN URL generated "on-the-fly" when the it starts downloading the file from deployment.chunks[].artifacts[]._links.download?
5 replies
zyga
@zyga:fosdem.org
[m]
hello
I'm trying to start hawkbit in docker, following https://www.eclipse.org/hawkbit/gettingstarted/
on startup the container keeps looping on connection refused org.springframework.amqp.AmqpConnectException: java.net.ConnectException: Connection refused (Connection refused)
am I missing some sort of configuration step?
Diego Rondini
@diegorondini
@zyga:fosdem.org which way are you trying to start up the container? A, B or C? Does A work?
zyga
@zyga:fosdem.org
[m]
@diegorondini: hey!
I think A, namely docker run -p 8080:8080 hawkbit/hawkbit-update-server:latest
perhaps there is some confusion, the app keeps logging connection errors but the web ui starts up
Diego Rondini
@diegorondini
yep, the container is actually up 'n' running, it's just looking for an AMQP service which is (of course) not there, but it's not fatal. I think there's an option to silence that (tell hawkBit to disable AMQP support)
zyga
@zyga:fosdem.org
[m]
do you know how to do that? I'm a complite novice on hawkbit
having the logs spam constantly is hard to follow any useful diagnostics
Diego Rondini
@diegorondini
property is hawkbit.dmf.rabbitmq.enabled=false but I don't know how to disable it "on-the-fly". Option "B" includes AMQP, so doesn't spam on the log
zyga
@zyga:fosdem.org
[m]
thanks, I'll play with this some more and then try option B
may I ask for one more bit of advice, for local learning and experiments, do I need a FQDN for my installation or can it all work with plain IP addresses
my goal is to set up enough of hawkbit to see rauc+hawkbit app doing something meaningful
shoragan
@shoragan:matrix.org
[m]
zyga: we've not needed a FQDN, but then were not using a container, just https://github.com/eclipse/hawkbit#build-and-start-hawkbit-update-server
zyga
@zyga:fosdem.org
[m]
shoragan: thanks, I'll probably switch to this
shoragan
@shoragan:matrix.org
[m]
zyga: but my memory is a bit fuzzy there, that was a few years ago ;)
fabioancarani
@fabioancarani
Hi all, I was developing an hawkbit agent implementing partial download of artifact exploiting RFC7233 (Range header). Hawkbit server works fine, but after some tests downloading the same artifact (placed inside same upload module and same distribution) and interrupting the download to test the partial and resume feature, the hawkbit server responds with an http status of 403 ("forbidden"). Since I don't have any permission or restriction problem (before I downloaded the complete artifact with previous test without closing the action) I suppose there is a quota limit exceed. When I receive the 403 I can only stop the action in the server and reprogram a new action (with same distribution!) to be able to download it again. How can I be sure that 403 doesn't happen in production, or how can I automatically reset it once happened? Thanks in advance.
praveen mugadur
@praveen0430:matrix.org
[m]
org.springframework.web.client.RestClientException: Error while extracting response for type [class org.eclipse.hawkbit.ddi.json.model.DdiDeploymentBase] and content type [application/hal+json;charset=UTF-8]; nested exception is org.springframework.http.converter.HttpMessageNotReadableException: JSON parse error: Unrecognized field "sha256" (class org.eclipse.hawkbit.ddi.json.model.DdiArtifactHash), not marked as ignorable; nested exception is com.fasterxml.jackson.databind.exc.UnrecognizedPropertyException: Unrecognized field "sha256" (class org.eclipse.hawkbit.ddi.json.model.DdiArtifactHash), not marked as ignorable (2 known properties: "sha1", "md5"])
can anyone help with this erro? i was getting it when i deploy new package into hawkit
the older packages were working fine and i was able to download
Sourabh
@Sourabh1107

Hello All,

I have a question regarding integrating casync with hawkbit? Is it possible to use casync feature with hawkBit to store casync chunk files?

Sourabh
@Sourabh1107

Hello,

Hello All,

I have a question regarding integrating casync with hawkbit? Is it possible to use casync feature with hawkBit to store casync chunk files?

Any update on above request would be helpful.

mmiiot
@mmiiot
Hi, I started with hawkbit and started with adding users, but I have problems to work with hashed passwords for authentication. Is there a routine in hawkbit to add users (username + password) or to generate hashed passwords? There is no problem with {noop} and a plaintext password. How can I generate a hashed passwort for hawkbit user login? I am not familiar with java and spring boot and spring security therefore, a step by step tutorial might be useful. I run hawkbit with docker-compose.
Bragma
@bragma
Hi, I am trying to run hawkbit on Azure using AKS. I've followed the quickstart and almost worked, but the hawkbit-ingress nginx-ingress-controller is stuck on "pending". Any idea on what to check? Thanks
GittyDan
@GittyDan
Hi all, I am trying to set up a hawkbit server. It’s placed behind a reverse proxy. According to the ddi api for https artifact downloads it should use the property „deployment.chunks[].artifacts[]._links.download“ instead of „deployment.chunks[].artifacts[]._links.download-http“. All configurations I tested are for „download-http“ (e.g. hawkbit.artifact.url.protocols.download-http.protocol=https, hawkbit.artifact.url.protocols.download-http.port=443). How can I configure hawkbit to use „download“ and not „download-http“?
zyga
@zyga:fosdem.org
[m]
I'm seeing the exact same problem in my setup
Ashish8800
@Ashish8800
Hello there, So we are tying to download the artifact in our target device , but we are facing issue "Waiting_authorization_to_start_download" we are not getting the authorization pop-up.
19 replies
Ashish8800
@Ashish8800
Screenshot from 2022-04-11 18-01-19.png
Ashish8800
@Ashish8800
Screenshot from 2022-04-12 17-43-31.png
already apiMode = true: but still facing issue