Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 07:07
    hawkbit-bot commented #1297
  • 07:06
    StefanKlt edited #1297
  • 07:04
    StefanKlt opened #1297
  • Nov 30 15:11
    ramannas synchronize #1296
  • Nov 30 14:47
    hawkbit-bot commented #1296
  • Nov 30 14:40
    ramannas opened #1296
  • Nov 30 14:03
    StefanKlt synchronize #1294
  • Nov 30 13:37
    StefanKlt synchronize #1294
  • Nov 30 12:59
    StefanKlt synchronize #1294
  • Nov 30 07:03
    StefanKlt synchronize #1294
  • Nov 29 15:18
    StefanKlt synchronize #1294
  • Nov 29 15:02
    herdt-michael synchronize #1293
  • Nov 29 13:24
    dimitar-shterev synchronize #1294
  • Nov 29 10:26
    dimitar-shterev synchronize #1294
  • Nov 28 10:35
    blomark synchronize #1295
  • Nov 28 09:58
    herdt-michael synchronize #1293
  • Nov 28 09:07
    hawkbit-bot commented #1295
  • Nov 28 09:06
    blomark opened #1295
  • Nov 28 09:05
    StefanKlt synchronize #1294
  • Nov 25 09:31
    herdt-michael synchronize #1293
shoragan
@shoragan:matrix.org
[m]
zyga: we've not needed a FQDN, but then were not using a container, just https://github.com/eclipse/hawkbit#build-and-start-hawkbit-update-server
zyga
@zyga:fosdem.org
[m]
shoragan: thanks, I'll probably switch to this
shoragan
@shoragan:matrix.org
[m]
zyga: but my memory is a bit fuzzy there, that was a few years ago ;)
fabioancarani
@fabioancarani
Hi all, I was developing an hawkbit agent implementing partial download of artifact exploiting RFC7233 (Range header). Hawkbit server works fine, but after some tests downloading the same artifact (placed inside same upload module and same distribution) and interrupting the download to test the partial and resume feature, the hawkbit server responds with an http status of 403 ("forbidden"). Since I don't have any permission or restriction problem (before I downloaded the complete artifact with previous test without closing the action) I suppose there is a quota limit exceed. When I receive the 403 I can only stop the action in the server and reprogram a new action (with same distribution!) to be able to download it again. How can I be sure that 403 doesn't happen in production, or how can I automatically reset it once happened? Thanks in advance.
praveen mugadur
@praveen0430:matrix.org
[m]
org.springframework.web.client.RestClientException: Error while extracting response for type [class org.eclipse.hawkbit.ddi.json.model.DdiDeploymentBase] and content type [application/hal+json;charset=UTF-8]; nested exception is org.springframework.http.converter.HttpMessageNotReadableException: JSON parse error: Unrecognized field "sha256" (class org.eclipse.hawkbit.ddi.json.model.DdiArtifactHash), not marked as ignorable; nested exception is com.fasterxml.jackson.databind.exc.UnrecognizedPropertyException: Unrecognized field "sha256" (class org.eclipse.hawkbit.ddi.json.model.DdiArtifactHash), not marked as ignorable (2 known properties: "sha1", "md5"])
can anyone help with this erro? i was getting it when i deploy new package into hawkit
the older packages were working fine and i was able to download
Sourabh
@Sourabh1107

Hello All,

I have a question regarding integrating casync with hawkbit? Is it possible to use casync feature with hawkBit to store casync chunk files?

Sourabh
@Sourabh1107

Hello,

Hello All,

I have a question regarding integrating casync with hawkbit? Is it possible to use casync feature with hawkBit to store casync chunk files?

Any update on above request would be helpful.

mmiiot
@mmiiot
Hi, I started with hawkbit and started with adding users, but I have problems to work with hashed passwords for authentication. Is there a routine in hawkbit to add users (username + password) or to generate hashed passwords? There is no problem with {noop} and a plaintext password. How can I generate a hashed passwort for hawkbit user login? I am not familiar with java and spring boot and spring security therefore, a step by step tutorial might be useful. I run hawkbit with docker-compose.
Bragma
@bragma
Hi, I am trying to run hawkbit on Azure using AKS. I've followed the quickstart and almost worked, but the hawkbit-ingress nginx-ingress-controller is stuck on "pending". Any idea on what to check? Thanks
GittyDan
@GittyDan
Hi all, I am trying to set up a hawkbit server. It’s placed behind a reverse proxy. According to the ddi api for https artifact downloads it should use the property „deployment.chunks[].artifacts[]._links.download“ instead of „deployment.chunks[].artifacts[]._links.download-http“. All configurations I tested are for „download-http“ (e.g. hawkbit.artifact.url.protocols.download-http.protocol=https, hawkbit.artifact.url.protocols.download-http.port=443). How can I configure hawkbit to use „download“ and not „download-http“?
zyga
@zyga:fosdem.org
[m]
I'm seeing the exact same problem in my setup
Ashish8800
@Ashish8800
Hello there, So we are tying to download the artifact in our target device , but we are facing issue "Waiting_authorization_to_start_download" we are not getting the authorization pop-up.
19 replies
Ashish8800
@Ashish8800
Screenshot from 2022-04-11 18-01-19.png
Ashish8800
@Ashish8800
Screenshot from 2022-04-12 17-43-31.png
already apiMode = true: but still facing issue
Ashish8800
@Ashish8800
waiting_for_server.png
nipunpal
@nipunpal

Hi all : I am reaching out to all the members in the community with a certain technical problem.

I am running a docker eclipse hawkbit instance on an amazon ec2 instance. I have a device node running embedded linux with swupdate running surricutta mode. The device gets detected by the hawkbit running on the instance. In the swupdate.cfg I have configured public dns for the ec2 instance as the server ip to reach out too.

The problem occurs when I try to push the update to device. Upon looking at device information i discovered that the IP address of the device is incorrect and it is showing up as one of the ISP's server address. The node device's IP running swupdate is definitely not public.

Is there some network configuration or settings needs to be done at either at hawkbit / swupdate end so that , eclipse hawkbit is able to push updates to device without any issue or able to discover it?

Note : The entire system works completely fine on local network.

TIA

5 replies
Ashish8800
@Ashish8800
Hello there, any one can help for how to run hawkbit server for production
Igor Jakobencsuk
@dezony-ij_gitlab

Hi everyone, i hope you are all doing great. Recently I encountered a continuous problem which you can see in the screenshot. So it’s about Invalid checksum: a expected b. After uploading a file and creating new software module and assign it to distribution, and at the end assign the distribution to the target, the target throws this error.

  • The hashes in database are the same, the file has not been modified, and the file size is the same as it was – nothing has changed in Management UI.
  • Target uses rauc-updater to communicate with the hawkbit.

What is suspicious, that download does not require the same amount of time, when the request is successful, and I can not download the artifact from the Management UI.

My workaround is to upload the same file again, and it starts working, but after some time I do become the same error.

So guys, do you have any ideas why it happens or how to fix it?

Thanks in advance🙂

1 reply
Igor Jakobencsuk
@dezony-ij_gitlab
This message was deleted
sachin60Inevitable
@sachin60Inevitable
Hello...! I am trying to download artifact but I am facing some issues i.e failed to download file with md5.so how can I solve this issues ????
sachin60Inevitable
@sachin60Inevitable
Hello!!! .. I am using hawkbit and Update factory for the client side ...I am trying to download artifact but geting error and that errors are:--- 1...- failed to download file with md5 b14f29fe8cea6b25e62a8e5c48b5a3a1 due to [trials exhausted due to errors (artifact01.file), exception: FileNotFoundException. message: /data/cache/update_factory/artifacts/1/b14f29fe8cea6b25e62a8e5c48b5a3a1.downloading: open failed: EACCES (Permission denied), exception: FileNotFoundException. message: /data/cache/update_factory/artifacts/1/b14f29fe8cea6b25e62a8e5c48b5a3a1.downloading: open failed: EACCES (Permission denied), exception: FileNotFoundException. message: /data/c 2.....ache/update_factory/artifacts/1/b14f29fe8cea6b25e62a8e5c48b5a3a1.downloading: open failed: EACCES (Permission denied)]
Ashish080
@Ashish080
MariaDB_Driver_error.png
Hello there,
I am facing issue while I am trying to run " java -jar ./hawkbit-runtime/hawkbit-update-server/target/hawkbit-update-server-0.3.0-SNAPSHOT.jar --spring.profiles.active=mysql ". update server is not running.
Screenshot from 2022-04-28 16-06-13.png
Screenshot from 2022-04-28 16-07-12.png
5 replies
ashishsingh75
@ashishsingh75
Screenshot from 2022-05-06 00-40-09.png
lreinecke
@lreinecke
This message was deleted
1 reply
Ashish080
@Ashish080
Screenshot from 2022-05-06 17-42-43.png
Flyway_upgrade_recommended.png
1 reply
meladon1337
@meladon1337
Hi all, i have the problem, that the sw-update is sending requests to the hawkbit api and they fail sometimes... if i test it with curl on my target the exact same command once works and i get http 200 and sometimes it failes and i get 401... i do not understand this... the request is exactily the same.
2 replies
Ashish080
@Ashish080
Hello All, So i am trying to upload Artifact >1GB it fails, When I look into Jenkins logs it show Broken pipe.
1 reply
I am able to upload 600mb file It successfully upload on hawkbit.
so what I do for Upload Artifact >1GB.
XING Yun
@BigFatDog
Hi, I get this error during triggering rollout on target filters. Hawkbit version is 3.0.7, I'm using default tenant:
2022-05-10 19:34:00.237  WARN 19413 --- [executor-pool-2] o.e.h.repository.jpa.utils.QuotaHelper   : Cannot assign 1 Action entities to Target '300' because of the configured quota limit 2000. Currently, there are 2000 Action entities assigned.
2022-05-10 19:34:00.237 ERROR 19413 --- [executor-pool-2] o.e.h.r.jpa.JpaSystemManagement          : Exception on forEachTenant execution for tenant DEFAULT with error message [Quota exceeded: Cannot assign 1 more Action entities to Target '300'. The maximum is 2000.]. Continue with next tenant.
Any advice is appreciated
Alexander Left
@left.alexandr_gitlab
Hi there.
I have a question.
Is it ok if I'll be using tags for groups like "alpha", "beta" and "release"?
Thnak you.
2 replies
Ashish080
@Ashish080
Screenshot from 2022-05-12 15-34-32.png
Hi, I got error while Downloading the Artifact through Update factory client.
/cache/update_factory/artifacts/21/b14f29fe8cea6b25e62a8e5c48b5a3a1.downloading: open failed: EACCES (Permission denied)]
failed to download file with md5 b14f29fe8cea6b25e62a8e5c48b5a3a1 due to [trials exhausted due to errors (artifact01.file), exception: FileNotFoundException. message: /data/cache/update_factory/artifacts/21/b14f29fe8cea6b25e62a8e5c48b5a3a1.downloading: open failed: EACCES (Permission denied), exception: FileNotFoundException. message: /data/cache/update_factory/artifacts/21/b14f29fe8cea6b25e62a8e5c48b5a3a1.downloading: open failed: EACCES (Permission denied), exception: FileNotFoundException. message: /data
4 replies
Kanstantsin
@KonstantinBYvitebsk
Hi there.
Question. Does hawkBit Management API provide simple way to get a list of tags for a pointed controlerId?
I see 'GET /rest/v1/targettags/{targetTagId}/assigned' but it means I have to iterate over all tags.
3 replies
asmadeus
@asmadeus:codewreck.org
[m]
Hello. I've opened an issue last month about creating artifacts shell with an external url (e.g. instead of uploading file just have hawkBit point clients to whatever was set) -- eclipse/hawkbit#1244
From my understanding there really isn't much else to do than write a new extension, but I'm surprised this never came up. Is there a way of doing this I missed?
Thanks!
Ashwani-k101
@Ashwani-k101
Hello there,So I am facing problem while Assigning the Distibution_set to target, The pop-up comes "Download progress and apk is downloaded at 0.0%", so kindly tell me what to do for downloade the artifact and after that uptate the Artifact to assiging the target
4 replies
client_is_waiting.png
workpush
@workpush
Hello everybody!
Does anyone has a running instance of hawkbit with mariadb 10.5?
I receive:
Caused by: org.flywaydb.core.api.FlywayException: Unsupported Database: MariaDB 10.5
Or can anyone tell me what it needs to get it running, so I could try to fix it by myself?
zyga
@zyga:fosdem.org
[m]
Hello, is there any plan to refresh the docker containers? I would love to see an up-to-date build published