Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 15:01
    n-deliyski commented #3448
  • 11:07
    BanDianMan commented #3448
  • Dec 07 14:28
    avgustinmm commented #3398
  • Dec 07 14:26
    avgustinmm synchronize #3398
  • Dec 06 15:20
    avgustinmm commented #3321
  • Dec 06 15:13
    avgustinmm review_requested #3452
  • Dec 06 15:13
    avgustinmm ready_for_review #3452
  • Dec 06 14:21
    avgustinmm synchronize #3452
  • Dec 06 13:56
    avgustinmm synchronize #3452
  • Dec 06 13:30
    avgustinmm synchronize #3452
  • Dec 06 12:37
    avgustinmm opened #3452
  • Dec 06 09:59
    avgustinmm synchronize #3398
  • Dec 06 09:32
    MatthiasK-Sotec commented #3451
  • Dec 06 08:01

    sophokles73 on master

    Refer to Java 17 documentation … (compare)

  • Dec 05 15:28

    sophokles73 on master

    Disable Traefik Ingress control… Improve security of TLS endpoin… (compare)

  • Dec 05 13:02
    MatthiasK-Sotec synchronize #3451
  • Dec 05 12:05
    avgustinmm synchronize #3398
  • Dec 02 15:34
    MatthiasK-Sotec review_requested #3451
  • Dec 02 15:34
    MatthiasK-Sotec review_requested #3451
  • Dec 02 15:34
    MatthiasK-Sotec review_requested #3451
Anoop Kumar
@anoopk30
Hello, I am new to Eclipse Hono. I am able to connect my raspberry Pi 4 with eclipse hono installed on my Ubuntu machine on minikube using nginx reverse port forwarding. I can communicate in between using amqp. But I am facing trouble while connecting it to Eclipse Kura. It shows connected status for 2-3 second then disconnect. Could you tell me how to connect eclipse hono with Kura on local network?
Kai Hudalla
@sophokles73
What version of Kura are you using?
Anoop Kumar
@anoopk30
4.1.2
Kai Hudalla
@sophokles73
Then you should be able to connect to Hono's MQTT adapter using Kura's Eclipse Cloud Connection type
Anoop Kumar
@anoopk30
Could you provide me steps for doing it?
Anoop Kumar
@anoopk30
Thanks, I am able to make connection between them.
Kai Hudalla
@sophokles73
That's good to hear :-)
Bob Claerhout
@BobClaerhout
@calohmn , considering your remarks on eclipse/packages#279, I've updated the PR accodring to what I understood from your remarks. Can you have a look and verify whether this is what you were aiming for?
Anoop Kumar
@anoopk30
I am not receiving any log in Eclipse Hono Example Client 1.9.0 when I tried to publish data using mosquitto_pub command. It is working fine when I use curl command.
Anoop Kumar
@anoopk30
I have solved this problem.
Anoop Kumar
@anoopk30
How can I subscribe to topic other than telemetry?? When I tried mosquitto_sub command, it's showing "All Subscription Access Were Denied".
Kai Hudalla
@sophokles73
A device cannot subscribe to any other topic than the command topic which it uses to receive command messages from back end applications. The MQTT adapter is not an MQTT broker but simply supports the MQTT 3.1.1 protocol to exchange messages with devices. Please also refer to the MQTT adapter user guide (https://www.eclipse.org/hono/docs/user-guide/mqtt-adapter/) for information regarding subscribing to the command topic.
Anoop Kumar
@anoopk30
Ok, thanks.
Julian
@JulianFeinauer
Good Morning people : )
Julian
@JulianFeinauer
I observed a strange behavior when using eclipse hono via eclipse ditto (through the cloud2edge kubernetes package). I subscribed with a „device“ to receive commands via MQTT but the topic I got the command at was missing a „/„, so it was ${request-id}replies… instead of ${request-id}/replies (so the slash was missing)
Kai Hudalla
@sophokles73
@JulianFeinauer Hi Julian, hope you're doing well :-) Can you post the topic that you used to subscribe to commands? Where did the commands originate from? Is there a north bound application which sends the command or is that a command that originates from Ditto?
Julian
@JulianFeinauer
@sophokles73 thanks, I’m well, yes, I hope you are too!
I was following the guide from here https://www.eclipse.org/packages/packages/cloud2edge/tour/ ("Sending a command to the device via its digital twin“)
I was subscribing command///req/#
And the command was sent via ditto
curl -i -X POST -u ditto:ditto -H 'Content-Type: application/json' -w '\n' --data '{
  "water-amount": "3liters"
}' http://xxx:8080/api/2/things/org.acme:my-device-1/inbox/messages/start-watering?timeout=60
image.png
Julian
@JulianFeinauer
Here is the response I get
(you could also try it out yourself as my test cluster is public…)
Kai Hudalla
@sophokles73
I see. Which version of the chart are you using? In particular, which version of Hono and Ditto is being installed?
Kai Hudalla
@sophokles73
I am not 100% sure but it looks like ....replies is actually the reply-id being used by Ditto. It may look strange but the Hono MQTT adapter user guide does not specify a separate replies segment in the command topic. Are you able to actually PUBLISH a response to the command using the reply-id ending in ...replies?
Julian
@JulianFeinauer
no.. I am unable to reply no matter what kind of topic I sue
let me check
The Helm Chart is 0.2.1
Kai Hudalla
@sophokles73
The response would need to be published to command///res/${req-id}/${status} with ${req-id} being the string ending in ...replies and ${status} being an HTTP status code ...
9 replies
Julian
@JulianFeinauer
Ditto is 2.0.1 and Hono is 1.8.0
Julian
@JulianFeinauer
Slightly related question… If I want to try out command & control without Ditto but with „plain hono“, how can I create credentials for an „application“ (the north bound site)? Did I miss that in the documentation?
I am able to write code that works with the sandbox (where the credentials are known) but with my cloud2edge setup I am missing that
This has to be configured in the dispatch router (qpid?), or?
Julian
@JulianFeinauer
ah, nvm… found it
Kai Hudalla
@sophokles73
@/all I would like to do 1.9.1 and 1.8.3 service releases today. Anything else you need to have in there?
Julian
@JulianFeinauer
I only have another question (regarding 1.8.0): I am now able to get the „north“ side running via AMQP but I do not yet get a command message sent to a client (client via HTTP adapter). I try to do the whole thing without ditto, so HONO only. Just to ensure that I got everything right:
  • Application creates a connection and a sender link to target command/{self.tenant}/{self.deviceId}
  • Application creates a receiver link to target telemetry/{self.tenant}
  • Client sends a telemetry with header hono-ttd and wait time in seconds
  • When my application receives the message it can send the command as message witth properties properties={"to": f"command/{self.tenant}/{self.deviceId}", "subject": "work“} via above sender link
Julian
@JulianFeinauer
The message does neither get rejected, released nor accepted (amqp side) nor does the client receive it (answer is 202) and I dont see errors in the logs
08:18:03.873 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - sent request [target address: registration/d7338cdc-6c72-4e3c-a329-54ab939221d7, subject: assert, correlation ID: registration-client-d813ceee-4adc-4fe7-9dea-c9843f37b0e1, device ID: 7a3f6a37-db90-4671-9a29-ac0f69e717cf] to service
08:18:03.880 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - received response [reply-to: registration/d7338cdc-6c72-4e3c-a329-54ab939221d7/a750eeca-997c-4e4d-957d-b0491f3c3772, subject: null, correlation ID: registration-client-d813ceee-4adc-4fe7-9dea-c9843f37b0e1, status: 200, cache-directive: max-age = 300]
08:18:03.880 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.impl.CachingClientFactory - creating new client for [cmd_router-d7338cdc-6c72-4e3c-a329-54ab939221d7]
08:18:03.881 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - client provided response handler did not settle message, auto-accepting ...
08:18:03.882 [vert.x-eventloop-thread-0] DEBUG o.e.h.client.impl.HonoConnectionImpl - receiver open [source: cmd_router/d7338cdc-6c72-4e3c-a329-54ab939221d7/fd10a6dc-c3fb-4d07-9c60-4ec794282c33]
08:18:03.882 [vert.x-eventloop-thread-0] DEBUG o.e.h.client.impl.HonoConnectionImpl - sender open [target: cmd_router/d7338cdc-6c72-4e3c-a329-54ab939221d7, sendQueueFull: false, remote max-message-size: null]
08:18:03.882 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - request-response client for peer [c2e-test-service-command-router] created
08:18:03.882 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.impl.CachingClientFactory - successfully created new client for [cmd_router-d7338cdc-6c72-4e3c-a329-54ab939221d7]
08:18:03.883 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - sent request [target address: cmd_router/d7338cdc-6c72-4e3c-a329-54ab939221d7, subject: register-command-consumer, correlation ID: cmd_router-client-d87de6e0-fdad-4f6b-9d80-f6f565524de6, device ID: 7a3f6a37-db90-4671-9a29-ac0f69e717cf] to service
08:18:03.893 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - received response [reply-to: cmd_router/d7338cdc-6c72-4e3c-a329-54ab939221d7/fd10a6dc-c3fb-4d07-9c60-4ec794282c33, subject: null, correlation ID: cmd_router-client-d87de6e0-fdad-4f6b-9d80-f6f565524de6, status: 204, cache-directive: null]
08:18:03.893 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.impl.CachingClientFactory - creating new client for [telemetry/d7338cdc-6c72-4e3c-a329-54ab939221d7]
08:18:03.893 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - client provided response handler did not settle message, auto-accepting ...
08:18:03.895 [vert.x-eventloop-thread-0] DEBUG o.e.h.client.impl.HonoConnectionImpl - sender open [target: telemetry/d7338cdc-6c72-4e3c-a329-54ab939221d7, sendQueueFull: false, remote max-message-size: 131072]
08:18:03.895 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.impl.CachingClientFactory - successfully created new client for [telemetry/d7338cdc-6c72-4e3c-a329-54ab939221d7]
08:18:08.894 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.impl.CachingClientFactory - reusing cached client [cmd_router-d7338cdc-6c72-4e3c-a329-54ab939221d7]
08:18:08.894 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - sent request [target address: cmd_router/d7338cdc-6c72-4e3c-a329-54ab939221d7, subject: unregister-command-consumer, correlation ID: cmd_router-client-c0cd1a7e-dd8b-40d0-ab8b-08f7de9ca5a8, device ID: 7a3f6a37-db90-4671-9a29-ac0f69e717cf] to service
08:18:08.897 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - received response [reply-to: cmd_router/d7338cdc-6c72-4e3c-a329-54ab939221d7/fd10a6dc-c3fb-4d07-9c60-4ec794282c33, subject: null, correlation ID: cmd_router-client-c0cd1a7e-dd8b-40d0-ab8b-08f7de9ca5a8, status: 412, cache-directive: null]
08:18:08.898 [vert.x-eventloop-thread-0] DEBUG o.e.h.c.amqp.RequestResponseClient - client provided response handler did not settle message, auto-accepting ...
Kai Hudalla
@sophokles73
Have you tried following the steps described in Hono's Getting Started guide (section Advanced: Sending Commands to a Device)?
Once you have successfully run it using the MQTT adapter, it should be only a small change to use the HTTP adapter instead ...
Julian
@JulianFeinauer
Yes i followed the guide the main difference is that I do the „north side“ myself and not via the java client
Kai Hudalla
@sophokles73
Does it work with the java client using the HTTP adapter?
Julian
@JulianFeinauer
Yes it works if I use the Java Client as stated in the documentation… thus I wanted to ensure that I do the things right in my python impl : )
(and a quick glance on the client didnt help me to exactly see the program flow)
Julian
@JulianFeinauer
I think I do everything similar but my message gets rejected and I have no idea why
Julian
@JulianFeinauer
From the log of the command router I see: command message has no valid address but the to property of my message seems to be correct and the sender link also...
Kai Hudalla
@sophokles73
Maybe you want to share your Python code?
Julian
@JulianFeinauer
Sure