These are chat archives for effektif/effektif

30th
Mar 2016
Stefano
@esseti
Mar 30 2016 14:10
hello, i saw that you released the timers & the sub-process. that's very good news. But i've a couple of question on that (i checked the documentation and it seems not to be updated).
1) is it possible to launch a subprocess and pass some variable that there will be used later on in some way?
Christian Wiggert
@SilentGert
Mar 30 2016 14:11
yes, this will be part of the next releases
Christian Wiggert
@SilentGert
Mar 30 2016 14:12
we are extending the subprocess to allow you to map variables from the parent to the child process
Stefano
@esseti
Mar 30 2016 14:12
good, i was trying it out
Christian Wiggert
@SilentGert
Mar 30 2016 14:12
currently, there is no event which tells you about the timer delay
but there will be one in the future
Stefano
@esseti
Mar 30 2016 14:14
in the process forget about the JS. what i wanted to try was also if the two branches are executed (the bottom one after 1 minute). but apparently only the upper one is executed
or am i missing something?
Christian Wiggert
@SilentGert
Mar 30 2016 14:14
that example should actually work
Stefano
@esseti
Mar 30 2016 14:15
i'll try to execute it again, i have removed the js part
i tried again. I also created this process https://www.dropbox.com/s/0dz6rrvuyg6nds9/Screenshot%202016-03-30%2017.19.43.png?dl=0 but the result is not what i expected https://www.dropbox.com/s/sxm67nc8ytfcq5y/Screenshot%202016-03-30%2017.20.03.png?dl=0 . shouldn't be that both branches are executed?
Christian Wiggert
@SilentGert
Mar 30 2016 14:21
there might be an issue with timers
we are looking into it
Stefano
@esseti
Mar 30 2016 14:21
(y)
+1
Christian Wiggert
@SilentGert
Mar 30 2016 16:00
@esseti I just deployed a new version, your workflows should now work as expected
Stefano
@esseti
Mar 30 2016 17:30
it works! good. just asking: when will be the map of variable for subprocesses released (more or less)?
Peter Hilton
@hilton
Mar 30 2016 19:05
Next week if all goes well. Otherwise, a week or two later.
Stefano
@esseti
Mar 30 2016 19:46
good!
in the cases, the table header is without text. is it me that i haven't configured anything or what? https://www.dropbox.com/s/icugj5zensgzkfe/Screenshot%202016-03-30%2022.46.19.png?dl=0
probably it's me
Peter Hilton
@hilton
Mar 30 2016 20:37
That's odd - I’ll have a look in the morning
Christian Wiggert
@SilentGert
Mar 30 2016 21:46
you will see table headers without labels, if you haven't defined any name for the variable or the variable was deleted
on the right side above the table you should see the option to configure the columns, you can rename and / or hide them there as well